Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

BUG - Category merge not visible in drop-down menu

@kjz posted this issue at:
https://community.quicken.com/discussion/7861032/category-merge-bug

Their post was subsequently closed by @Rocket J Squirrel because they couldn't reproduce the problem. I have reproduced the bug and the workaround that @kjz provided also worked for me.

In the Category List, when I right-click on a category that is IN USE the option to merge is not in the drop-down menu. When I select Delete, then choose "No", then right-click on the category again then the Merge option appears.

I am using Windows 10 (fully updated) and Quicken Deluxe year 2020, version R31.5, Build 27.1.31.5.
Tagged:

Best Answers

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Accepted Answer
    Now that you have added the new information about starting with Quicken with the usage column off, I can reproduce the problem.  That will certainly help in getting fixed because the developers should now be able to reproduce the problem.

    And I agree that what seems to be the problem is that the displaying of this column isn't just affect the display.  Turning it on or off decides if Quicken is going gather the information about the usage or not.  Given then "not" then in fact Quicken doesn't have enough information to decided what menu to display in this case.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Quicken Jeff
    Quicken Jeff Member, Employee ✭✭✭
    Accepted Answer
    Thanks for bringing this to our attention. I have reported this to the Quicken product team (QWIN-18647).

Answers

  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    Their post was subsequently closed by @Rocket J Squirrel because they couldn't reproduce the problem.
    False. I'm a user and I can't close threads. Only moderators & administrators can close threads.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    I assume that the original post by @kjz was closed by a moderator due to lack of response.
    In my Category List, the right-click popup responds correctly depending on the Usage count and whether I click on a subcategory, a parent category, a built-in undeletable category.
    @Cris Williams ,
    can you please attach some screen image snapshots of the Category List plus the popup menu, to show your situation? Be sure to have the Usage count column enabled in the Category List.
  • Cris Williams
    Cris Williams Member ✭✭
    > @Rocket J Squirrel said:
    > False. I'm a user and I can't close threads. Only moderators & administrators can close threads.

    Apologies. I made the assumption you were a mod.
  • Cris Williams
    Cris Williams Member ✭✭
    > @UKR said:
    > I assume that the original post by @kjz was closed by a moderator due to lack of response.In my Category List, the right-click popup responds correctly depending on the Usage count and whether I click on a subcategory, a parent category, a built-in undeletable category.
    > @Cris Williams ,
    > can you please attach some screen image snapshots of the Category List plus the popup menu, to show your situation? Be sure to have the Usage count column enabled in the Category List.

    I believe I have found the source of the bug. When you first open Quicken and the Usage column is not displayed in the Category List, the issue occurs for any category that you know are in use.

    Once you do the "select Delete/decline Delete" workaround on one category, the issue no longer occurs for any category as it appears Quicken has loaded the usage counts for all categories into memory at that point.

    Turning on the Usage column makes the problem go away entirely.

    So, it would appear that the problem can be fixed by either forcing a memory load of all category usage counts upon Category List screen load, or, force the Usage column to be displayed at all times. But, I'm wagering that was not done so due to the performance hit associated with gathering those counts each time the screen is displayed.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Accepted Answer
    Now that you have added the new information about starting with Quicken with the usage column off, I can reproduce the problem.  That will certainly help in getting fixed because the developers should now be able to reproduce the problem.

    And I agree that what seems to be the problem is that the displaying of this column isn't just affect the display.  Turning it on or off decides if Quicken is going gather the information about the usage or not.  Given then "not" then in fact Quicken doesn't have enough information to decided what menu to display in this case.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Quicken Jeff
    Quicken Jeff Member, Employee ✭✭✭
    Accepted Answer
    Thanks for bringing this to our attention. I have reported this to the Quicken product team (QWIN-18647).
Sign In or Register to comment.