Quicken Mac does not export Tax Schedule to .csv

EPK29
EPK29 Member ✭✭
This is a known problem and has been for years. I created a custom Tax Schedule (Only Schedule D, for specific accounts) and then went to export. The "Export to .csv" button is available (not greyed out), and it brings up the Mac Finder dialog box to choose a file and location to export to, but when I hit OK, nothing happens. This is a system bug . . . the chat line was able to duplicate my problem. Does anyone have a workaround?  Running 6.1.1 under Mac OS 10.14.6

Answers

  • MontanaKarl
    MontanaKarl Member, Windows Beta, Mac Beta Beta
    I'm on MacOS 10.15.7 with QMac 6.1.1 (build 601.37924.100) and have no problem exporting a filtered Schedule D report to CSV following your steps.

    I did have to give QMac permission to access my Desktop folder (where I saved the file) and I suspect that MacOS security settings might be the problem you're having...

    I can't remember if these settings were needed in 10.14.6 which you're running... but go to System Preferences > Security & Privacy and then give QMac "Full Disk Access" (add it if not there, and put a checkmark in front of it), or see if you can add it to the Files and Folders group and give it access to the areas where you would save your CSV file.  Strangely, I had to give permission to save the CSV to my desktop, but did not have to give permission to save to my Documents folder.  Both worked fine though.

    Quicken Windows and Mac subscription.  Quicken user since 1990.

  • jacobs
    jacobs SuperUser, Mac Beta Beta
    It works fine for me as well. Quicken 6.1.1., macOS 10.14.6. Are you sure it isn't putting it in a location other than where you're looking? That is, I think it defaults to Documents, but maybe try your Desktop.

    Also, where is your Quicken data file located? On your local hard drive? Odd things happen when people trying putting the data file in Dropbox or iCloud. (If it's on your Desktop or Documents, also make sure in macOS System Preferences for iCloud that you don't have iCloud Drive storing your Desktop and documents folders on iCloud.)
    Quicken Mac Subscription • Quicken user since 1993
  • EPK29
    EPK29 Member ✭✭
    Thanks to you both, but it does not seem to be working. I gave Quicken full disk access (although it shouldn't need it, because that's just for admin functions) and rebooted. Data file lives in Documents; iCloud does not back up Documents folder (or Desktop). I can go all the way through to hitting "Save", but the file doesn't show up anywhere. (I checked Recents to see if it landed in a strange place and searched for type:csv; no joy). I CAN save backups (to pretty much anywhere, including online locations), and always have been able to do so. And if I try to do a .txf export, I still get the 38-byte file.
  • EPK29
    EPK29 Member ✭✭
    Update: It must have had something to do with the filters. I WAS able to export a full, unedited "Tax Schedule" for last year. I could also export a report limited to 3 specific accounts, but with no other filters. When I went further an limited it to Schedule D, however, it did not export (it DID show up on the screen, so it's not that it doesn't know how to do those filters at all). That is, again, weird, because the Sched D info IS in the report for the 3 accounts (but no schedule/category filters).

    So I'm OK (if frustrated a bit), but the developers should look at this.
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    @EPK29  Glad you found a way to get it. You should use Help > Report a problem to submit a bug report. Provide the description you did here about how to reproduce it. No one from development will read this thread to discover the issue.
    Quicken Mac Subscription • Quicken user since 1993
  • EPK29
    EPK29 Member ✭✭
    Reported. Thanks again for your help.
  • qw_mac_15
    qw_mac_15 Member ✭✭
    This has still not been fixed – custom reports will not export on macOS. I have submitted a bug report. In the meantime, the simplest workaround is to select all while the report is on the screen, then copy and paste it into a spreadsheet.
  • qw_mac_15 said:
    This has still not been fixed – custom reports will not export on macOS. I have submitted a bug report. In the meantime, the simplest workaround is to select all while the report is on the screen, then copy and paste it into a spreadsheet.
    Hello qw_mac_15,

    I understand that these kinds of issues are frustrating and I am sorry that you are still experiencing this issue. If you and @EPK29 would be willing, could you send us a new report with a sanitized data file attached? To be clear, this will copy scrub the data file that is being sent of all personal information. In order to send a sanitized report, you would go to the 'Help' menu in the top of the screen, then select 'Report a problem,' then you would check the little box next to 'sanitized data file'. Leave log files attached as well.

    Also, it would help us a great deal if you could send screenshots of the steps you are taking when you notice this issue. You can find the steps to submit screenshots here on the Community boards in this thread:https://community.quicken.com/discussion/7867159/faq-how-do-i-post-a-screenshot-in-the-community-from-windows#latest. Please note that you can remove personal information from the screenshots if necessary.

    Thanks, 

    Quicken Jared
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    @EPK29 How were you creating the Tax Schedule report limited to just Schedule D? There is no setting to select a specific tax schedule for the report, so I'm unclear what you were trying to do? Were you restricting the categories to the types that would show up under Schedule D? I tried this, and the export of the report with only selected categories worked as expected. 

    @qw_mac_15 Could you clarify what custom reports you are unable to export? Are you talking about the Tax Schedule report, or something else? Any report I've tried exports as expected. Please let us know what report you are using, and what customization you are doing to that report. 
    Quicken Mac Subscription • Quicken user since 1993
  • EPK29
    EPK29 Member ✭✭
    Don't trust your sanitization, so I won't go the way you suggest. Running Version 6.4.5 (Build 604.41859.100) on Mac OS 10.14.6. Steps are: (1) Open a new report (Tax Schedule); (2) clear all accounts and select 3 accounts; (3) select Categories Realized Gain and the three CG Dist categories; (4) Date range is YTD; (5) create report. The report shows up on the screen and appears correct. It has the transactions (sales) and the gain/loss calculation for each. Then (5) hit the Export icon and select Export to .csv; (6) Mac Finder Dialog box opens; (7) select "Documents" folder and hit "Save". (8) Dialog box closes, but no file is created. Note that Quicken has "full disk access" in the Security/Privacy settings, although it shouldn't need it to save a file. The problem is clearly in restricting it to "Realized Gain" transactions. I DO get an export on an unrestricted report (all accounts, all categories), and I also get one when I go to three accounts/all categories. But I do not get on (although the report appears correctly on the screen) when I go to three accounts and only Realized Gain. And there is likewise no export on all accounts/realized gain. So it's the restriction to REalized Gain that triggers the bug.
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    @EPK29  FYI, the sanitized file is actually pretty innocuous. You can try it without sending it by selecting Help > Sanitize File and then examining the resulting file. 

    Now back to the matter at hand. I have created a Tax Schedule report deselecting all categories and then selecting just these:



    I get the Schedule D transactions on screen, in two different Schedule D groupings of LT capital gains: one for gains from the sale of securities, one for capital gains paid in cash or reinvested. When I export this report, I get a CSV file which matches what I see on screen. I repeated this by selecting only one account. It still worked. I've tried different permutations, but in every case, the exported CSV file matches what I see onscreen. (I'm also on macOS 10.14.6, so it isn't an operating system issue.)
    Quicken Mac Subscription • Quicken user since 1993
  • EPK29
    EPK29 Member ✭✭
    Nope. Still doesn't work. However, since I can get a "full" tax schedule (i.e., without selecting specific categories), I can use that export and simply delete the portions I don't want. As workarounds go, it's not bad, so I'll just proceed that way. Thanks.
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    @EPK29  Just for kicks, have you tried the export to a different folder? I can't imagine why that would matter, since you are able to get some exports to the documents folder.

    I tried both Desktop and Documents and it worked fine in both places. I can't figure out why some of your Tax Schedule exports work and some don't, but they all seem to work for me.

    As you say, it's not hard to work around. (But without being able to figure out how to reproduce it consistently, it's not something the developers will be aware or or will fix.) 
    Quicken Mac Subscription • Quicken user since 1993
This discussion has been closed.