Is there a way to treat mortgage principal as an expense instead of an internal transfer?

For my income and expense report, is there a way to display my mortgage principal paid as an expense? Quicken treats it like an internal transfer, which technically it is since it adds to my home equity. But from a cash flow perspective, it’s one of my biggest monthly expenses, and excluding it from the expense column makes my report look misleading. In the customize report window, in the advanced tab, there are four options to display transfers: include all, exclude all, exclude self-transfers and exclude internal. The report would be more useful with an option to include mortgage principal and exclude other internal transfers.
Tagged:

Best Answers

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    Accepted Answer
    If you exclude the mortgage account from the Income and Expense report, the transfers to the mortgage account should appear as an expense in the default report: open the report, press Alt + C, select the Accounts tab, uncheck the mortgage account, and select OK
  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    Accepted Answer
    You will also need to make sure the loan Account is selected as a "Category" under the Category tab (if it isn't already), and on the Advanced tab enable transfers to be shown.  This might bring up a whole lot of transfers that you don't want to see so some additional fine tuning in the Category and Accounts area may be required.

Answers

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    Accepted Answer
    If you exclude the mortgage account from the Income and Expense report, the transfers to the mortgage account should appear as an expense in the default report: open the report, press Alt + C, select the Accounts tab, uncheck the mortgage account, and select OK
  • TheBobster
    TheBobster Member ✭✭
    This is great -- thank you. I had no idea it is that easy.
  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    Accepted Answer
    You will also need to make sure the loan Account is selected as a "Category" under the Category tab (if it isn't already), and on the Advanced tab enable transfers to be shown.  This might bring up a whole lot of transfers that you don't want to see so some additional fine tuning in the Category and Accounts area may be required.
This discussion has been closed.