Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Latest Version [6.1.1 (Build 601.37924.100)] Suddenly Slow

I've got a MacBook Pro (Retina, 13-inch, Early 2015). Until the latest update [6.1.1 (Build 601.37924.100)], I'd had no problems with speed.

After updating, however, every action, down to marking a transaction as cleared, produces a few seconds' delay with a spinning beach ball.

I tried deleting and then reinstalling, but no luck. Any ideas?

Answers

  • jacobs
    jacobs SuperUser, Mac Beta Beta
    edited February 25
    I've seen two other users report the same problem you're describing, which you can read in this thread.

    Whatever's going on, it's clearly not a widespread problem, because many thousands of users have upgraded to 6.1.1. without a problem. But if three people have reported the same sluggishness, there's something that needs to get uncovered. 

    Unfortunately, the users in the other thread never responded to the questions I asked and the suggestions I offered for trying to isolate the problem. I'll post them here, and if you can reply, I think we'll either figure out how to fix the problem or create a solid case to report to Quicken. 

    First question: is your Quicken data file living on your local hard drive? (E.g. it is not on Dropbox or iCloud? and if it is on your Desktop or Documents folder, is your iCloud Drive set to not not store those folders in iCloud?) I know you said this problem just started with the most recent update, but all sorts of strange things have been known to happen when people have their data file on a cloud storage service. 

    Next, I have a few suggestions you could try:

    (1) I think you're indicating you already did this, but in case not: download a fresh install of Quicken 6.1.1 by logging into your account on Quicken.com. Delete the current app from your Applications folder; run the installer to install the new one. It's rare that this would solve a problem, but we're hunting for a rare problem here. ;)

    (2) Temporarily create a new user account on your Mac (System Preferences > Users & Groups). Copy your data file to live on the desktop of that user login. Try running Quicken. Same problem or no problem here? (If the problem goes away, it means your Quicken application and your Quicken data file are fine, and the problem is something with your regular user account. We can dig into where Quicken's preferences files live to try to replace them if this is the case.)

    (3) Try a backup file from before the recent 6.1.1 update. Do you have Time Machine or some other backup from before you installed the 6.1.1 update that you could try opening to see if the problem is still there or not?
    Quicken Mac Subscription • Quicken user since 1993
  • Hi Jacobs, very much appreciate your quick response. I've tried all your suggestions. Here's my feedback, point-by-point:

    1. I deleted my old copy of Quicken (including associated preferences files, using an app called AppCleaner), emptied the trash, downloaded a new copy of Quicken, and installed it. When I opened my data file, it was just as slow. No improvement.

    2. I created a new user account, restarted my Mac into that account, opened Quicken and my data file. Just as slow. No improvement.

    3. I found an old backup of my data file (from November 2019), and opened it using my normal Mac user account & the new install of Quicken. The program went through a process of upgrading/updating the database, which took a couple minutes. It also downloaded new transactions for a few of my accounts whose connections parameters hadn't changed since then. The slowdown disappeared. In particular, no more spinning beach ball when I clear transactions!

    So I guess the question now is, Is there a way similarly to fix my current data file?

    Thanks again for your help.
  • Quicken_Tyka
    Quicken_Tyka Moderator mod
    Hello @johannesfact

    Thank you for the response and the additional details.

    First, if you see improvement in an older backup, are you able to restore a more recent backup saved prior to installing the update?

    If not, or you still experience this trouble in a recent backup. Can you confirm if "Automatically update investment quotes every 60 minutes" is checked or unchecked?"

    This located under Quicken > Preferences > Connected Services.



    Please let me know what you find!

    -Quicken Tyka
    ~~~***~~~
  • johannesfact
    johannesfact Member
    Hi Quicken Tyka,

    I did in fact locate a much newer backup in the "Automatic Backups" folder (which took me a while to locate or even to realize to look for; a bit clueless, yes).

    The backup was from sometime last week. I can't tell whether it was pre-version-upgrade or after; in any event, it appears to have solved the problem! There's no lag at all, no spinning beach ball!

    Not sure if it's still relevant, but to answer your question: "Automatically update investment quotes every 60 minutes" was in fact checked.

    Thanks again for your help.
  • marcdesin
    marcdesin Member ✭✭
    I have the exact symptoms described in the original issue. Quicken for Mac has been a great app for me - until 4 days ago when it began responding very slowly, and behaved bizarrely

    It is very slow to open, close, and update online accounts. I see the spinning ball constantly, even while selecting different accounts from the sidebar. Also, after I update my online accounts, the category names change to GUIDs like this: '5EACAEDB-863B-4C34-A1C5-2FDA466E51C3:Postage and Office Expense'. If I close and re-open, the accounts look correct again. My accounts have all stopped updating their transactions - I can see transactions on the web that are no longer being picked up in the application.

    I tried chatting with tech support, but it was excruciatingly slow to move forward with them (long, long pauses between tech responses).

    I assume this will be fixed in some future update.

    Marc
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    When we've seen these problems with mangled category names, I don't know if the exact culprit has ever been pinned down, but I believe it is always related to some corruption from syncing with your account on Quicken Cloud (mobile app and or web interface).

    I suggest going back to a back from just prior to this problem occurring, turning off mobile sync at least temporarily, and resetting your cloud data. Check to make sure everything looks normal and is working as you'd expect. Then, if you use the mobile app or web interface, you can try turning sync back on. Give it a while to sync properly, and then keep a close eye on it to make sure the corruption doesn't recur.

    (I wish I could advise you on some specific activity or sequence to avoid, but as I said, I don't think anyone knows what causes a very small number of Quicken Mac users to suffer this corruption from the cloud service. The good thing is that the reports of this problem seem to be fairly infrequent, and it doesn't seem to recur for the same users repeatedly.)
    Quicken Mac Subscription • Quicken user since 1993
  • marcdesin
    marcdesin Member ✭✭
    Thank you for your response jacobs. I don't use the mobile app or web app, and have that turned off. I do go online to get my account updates - and as soon as I do that, the app breaks down. It works fine before I press online updates.

    Cheers,
    Marc
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    @marcdesin  Have you tried retrieving a backup from just prior to 4 days ago when you said this happened? 
    Quicken Mac Subscription • Quicken user since 1993
  • marcdesin
    marcdesin Member ✭✭
    I just tried with a backup from early Feb. It looks great until I update my accounts. You can see in real-time the categories change from their labels into GUIDs.

    I thank you for sticking with me on this. For now I'm going to wait to see if any future update fixes this. Until then, it's no longer usable for me.
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    I wouldn't count on a future update fixing a problem the developers may not know exists.

    And -- just making sure -- you're certain you have Preferences > Mobile/Web Sync set to Off, and have clicked Reset on the Preferences > Connected Services screen? 

    The only other thing I can suggest is to call Quicken Support after the weekend a get a Quicken representative who can screen share with you, and go through this with them so they can see it happen. It sounds like you can reproduce it on demand, going back to your backup file and then updating your accounts, so that's often a huge advantage in trying to track down a bug. If you luck out with a good support representative, you might make some headway in having them gather data to pass on to the developers. 
    Quicken Mac Subscription • Quicken user since 1993
  • Quicken_Tyka
    Quicken_Tyka Moderator mod
    Hello @marcdesin

    Thank you for taking the time to visit the Community to report this issue, although I apologize for any frustration that this has caused

    This is a known issue that is currently being investigated. Please open Quicken and navigate to Help >  Report a Problem. Please include "CTP-1626" as the subject.

    Please let me know once the report has been submitted.

    -Quicken Tyka
    ~~~***~~~
  • marcdesin
    marcdesin Member ✭✭
    > @jacobs said:
    > And -- just making sure -- you're certain you have Preferences > Mobile/Web Sync set to Off, and have clicked Reset on the Preferences > Connected Services screen? 

    This seems to have solved the problem! Specifically clicking Reset did it for me. I was sure that Mobile/Web Sync was set to off, but had not tried pressing Reset.

    Quicken now operates quickly and consistently for me again. jacobs - thank you so much for your effective troubleshooting and communication. @Quicken_Tyka - I won't be sending the report since I can't reproduce the problem anymore. Of course, you can see what helped me, and maybe that is useful information.

    Marc
  • jacobs
    jacobs SuperUser, Mac Beta Beta
    Marc, well, we maybe lost some additional clues on what causes this problem to occur, but I'm glad you're back up and running smoothly again. ;)
    Quicken Mac Subscription • Quicken user since 1993
Sign In or Register to comment.