Security Lots in 'Specify Lots...' Show Double Number of Shares Entered

chipwhite935
chipwhite935 Member ✭✭
edited May 18 in Investing (Windows)
After a parent company spun off another company (on 10/2) , I removed each lot of the parent (dated 10/2) and then added each lot back in (dated 10/3) with the new post-spinoff cost basis. Now, when I open previously entered (after 10/3) sell orders and click "Specify Lots..." the first lot shows double the number of shares it should have in the "Available to Sell" column - this doubling continues for each subsequent sale.
I did run "Validate and Repair..." but it did not find any problems.

Answers

  • Quicken Anja
    Quicken Anja Moderator mod
    Hello @chipwhite935,

    Thank you for reaching out to the Community to tell us about your issue, though I apologize that you are experiencing this and for not having received a response yet.

    Could you please provide which version of Quicken you have currently running?
    • Help > About Quicken

    Also, when you Validated your file, did you create a copy first and include Rebuild investing lots during the validation? If you haven't already, I suggest you create a copy of your data file in an attempt to rebuild all of the internal lists and database tables. Then, try to Validate your data file, and Rebuild investing lots in the copied file by following the steps below. However, I do recommend that you also save a backup of your data file first before trying these steps (just in case).
    1. Navigate to the File menu
    2. Select File Operations
    3. Copy...
    4. Leave the presets as is and click OK
    5. Wait for the copy procedure to complete
    6. Select New Copy and click OK                                                                              If Quicken reports an error when creating the Copy file, then hold Ctrl + Shift while you click File > File Operations > Copy. When prompted to "Ignore errors that prevent file copy?" click Yes. Note: Only do this if you receive an error as this may cause some data loss.
    7. Once the newly copied file opens, navigate back to the File menu
    8. Select File Operations
    9. Validate and Repair...
    10. Select Validate file, and Rebuild investing lots (You can either select these together at once and run them at the same time or select and run them one at a time - either way is fine)
    11. Click OK
    12. Close the Data Log
    13. Close Quicken (leave it closed for at least 5 secs)
    14. Reopen Quicken and see if the issue persists.
    You can also try to Super validate the copied file by holding down the Ctrl + Shift keys on your keyboard while selecting Validate and Repair... (step 9) which will give you the option to Super validate file instead of Validate file.

    If this does not resolve the issue, you can either switch back to your original file or restore the backup you saved prior to performing the above troubleshooting instructions (both the original and backup files should remain unaffected by the steps performed in the copied file).

    Follow the steps below to switch back to your original file
    :
    1. Click the File menu.
    2. Look near the bottom of the options list.
    3. Select the data file you want to open. 


    Quicken will list the most recently opened data files, with a checkmark next to the file you are currently viewing.

    Let us know how it goes!

    -Quicken Anja
  • chipwhite935
    chipwhite935 Member ✭✭
    I forgot to mention that I had run both Validate file, and Rebuild investing lots, but it did not fix the problem.
    I started to wonder if perhaps the preexisting Sell orders were somehow still attached to the lots I had deleted (although this is counter intuitive from a ledger perspective), and decided to delete those Sell orders and reenter them. This did fix the problem, but it still seems like a bug to me.

    Quicken Version: R32.12
    Build: 27.1.332.12
    Windows 10.
Sign In or Register to comment.