Quicken 6.2.0 & Mac Big Sur 11.3.1 compatibiity

Hi - I've got an IMPORTANT Quicken Data file (20+ yrs old) ... it seems to be working fine in my MacOS Catalina 10.15.7 environment under Quicken 6.2.0 on my main iMac.

I'm ready to try my IMPORTANT Quicken Data file with my main iMac system...upgrading to Big Sir

Question: Has anyone run into problems with using there Quicken Data file within the new MacOS 11.3.1 operating environment and using Quicken 6.2.0?

Nothing better than a non-corrupted Quicken Data file!

DALE

Answers

  • Quicken Anja
    Quicken Anja Moderator mod
    Hello @dalefinal,

    Thank you for reaching out to the Community with your question.

    Quicken for Mac 6.2.0 is compatible Mac OS Big Sur 11.3.1., please review this support article for reference on this topic.

    However, if you still wish to take extra precautions just in case, you can open a backup file first before opening your main data file.

    I hope this helps! 
    -Quicken Anja
Sign In or Register to comment.