Quicken will not let me post transaction. Canadian company symbol is TSE:CCL.B.

robert28412
robert28412 Member
edited May 24 in Investing (Windows)
I have done all the work up to the final post and once I clicked the transaction the following message appears. Please select a security whose currency matches the currency of your account. The currency of the transaction is Canadian Dollars. The security is a Canadian company and the symbol is TSE:CCL.B. Any assistance you can give me will be appreciated. I have never had this problem when posting Canadian Dollar transactions.

Answers

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Any security you purchase in Quicken must match the currency you have set for the account; only one currency is allowed per account. What is the currency setting for the account you are using?
    QWin Premier subscription
  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    Are you running Q US?  Or Q Canada?
    And, as @Jim_Harman stated, you can only have a single currency in any account.  This includes not mixing CAD securities and USD securities in the same account.
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • robert28412
    robert28412 Member
    I am running the US version of Quicken and have separate US$ and Can$ accounts. I am not mixing one with the other; they are separate accounts. I have maintained this configuration for the past 10 years with no problems. You suggested verifying the currency but I do not know how. Can you please advise. Thanks.
  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    IF the security is CCL Industries, Class B ... they trade in the US OTC market as CCDBF

    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • robert28412
    robert28412 Member
    While stock is traded over the counter it does not appear to solve my problem. Need to be able to post in currency of purchase. If any other ideas.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    When I set this security up in Quicken US, it was assigned the ticker CCL.B (with no TSE). It defaults to being a USD stock. 

    I think you need to go to the security details and change the ticker to TSE:CCL.B and the currency to CAD before trying to buy it in your CAD account.

    When I made these changes, I could download historical prices and Buy it in a CAD account.
    QWin Premier subscription
  • Ps56k2
    Ps56k2 SuperUser ✭✭✭✭✭
    [EDIT] updated topic title to better reflect the actual Q&A
    Quicken Subscription - Windows 10
  • Ps56k2
    Ps56k2 SuperUser ✭✭✭✭✭
    Jim_Harman said:  I think you need to go to the security details and change the ticker to TSE:CCL.B and the currency to CAD before trying to buy it in your CAD account.
    Changing the Symbol is easy - but where do you change the CAD currency ?
    Can you do it for the ... Account, Security, or is it global for the entire QDF file ?

    Quicken Subscription - Windows 10
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited May 25
    Ps56k2 said:
    Changing the Symbol is easy - but where do you change the CAD currency ?
    Can you do it for the ... Account, Security, or is it global for the entire QDF file ?


    In Quicken US, you must first enable multicurrency support at Edit > Preferences > Calendar and currency. 

    The currency for an account is set when the account is created and AFAIK cannot be changed.

    For securities, the currency is set when the security is created, and is shown when you click on Edit details on the security detail page. You can change the currency there, but only if there are no transactions for the security. Once a transaction has been recorded, the currency selection dropdown is grayed out.
    QWin Premier subscription
  • robert28412
    robert28412 Member
    Jim we solved the problem regarding the posting of CCL.B and it was quite easy once we got lucky.
    When we went to View (Accidently), then opened the ‘securities list’ and saw where the security TSE:CCL.B was shown as USD. We then changed the currency to CanD and re-entered the transaction. Everything then balanced.
    Many thanks for your help in this matter.
    Robert Park
Sign In or Register to comment.