"Cannot retrieve action item definition"

Error message today when trying to switch accounts via toolbar icons (i.e. from Checking to Brokerage) : "Cannot retrieve action item definition"
Only able to switch using the sidebar account list.

Q-Win R33.19

Best Answer

  • Eastwayroad
    Eastwayroad Member ✭✭
    Accepted Answer
    After updating to latest QWin version the issue remained.
    However, I solved the problem by removing then re-adding the account icons to the toolbar. Seems fine now.

Answers

  • Quicken Anja
    Quicken Anja Moderator mod
    Hello @Eastwayroad,

    Thank you for reaching out to the Community to tell us about your issue, though I apologize that you are experiencing this.

    Since you are currently still running version release R33.19, to start with, I recommend updating your Quicken program to the latest version release; R33.24 first and see if doing so will help resolve this issue.

    To update, please navigate to Help > Check for updates, or you can download and install the R33.24 Mondo Patch through this support article

    Let us know how it goes!
    -Quicken Anja
  • Eastwayroad
    Eastwayroad Member ✭✭
    Accepted Answer
    After updating to latest QWin version the issue remained.
    However, I solved the problem by removing then re-adding the account icons to the toolbar. Seems fine now.
  • Ronn
    Ronn Member
    I am getting the same "Could not retrieve action item definition" error message when I click on one of my customized toolbar icons. I am using Quicken for Windows R 33.24. I have a dozen customized icons that I have used for a long time and don't want to recreate them all.
  • Quicken Anja
    Quicken Anja Moderator mod
    Hello @Ronn,

    Thank you for reaching out to the Community and adding to this discussion to tell us about your issue, though I apologize that you are experiencing this.

    To clarify; do you receive this error for all your toolbar icons, or only for a/some specific one(s)? Also, when did this error first start occurring for you?

    Please, check back and let us know! Thank you.
    -Quicken Anja
  • Ronn
    Ronn Member
    The error started yesterday when I posted the message. It occurs for all the icons that I created that have been working for years.
  • Quicken Anja
    Quicken Anja Moderator mod
    @Ronn Thank you for the additional information.

    To start with, if you haven't already, I suggest that you please try validating and/or super validating your data file. However, I do recommend that you first save a backup file prior to performing these steps.

    Validate
    1. File
    2. File Operations
    3. Validate and Repair
    4. Validate File
    5. Click OK
    6. Close the Data Log
    7. Close Quicken (leave it closed for at least 5 secs)
    8. Reopen Quicken and see if the issue persists.

    Super Validate:
    1. File
    2. File Operations
    3. Hold CTRL + Shift and click Validate and Repair
    4. Super Validate File
    5. Click OK
    6. Close the Data Log
    7. Close Quicken (leave it closed for at least 5 secs)
    8. Reopen Quicken and see if the issue persists.

    Let us know how it goes!
    -Quicken Anja
  • Ronn
    Ronn Member
    I did a Super Validate and it did not fix the error. I have restored to June 4 and the Toolbar icons work again, but I have to reenter some transactions which is not good.
Sign In or Register to comment.