Quick Pay doesn’t work with Bank of America credit card

Since switching to MFA on my BOA Visa account Quick Pay does not work. I am able to set up the biller in Quicken, but every time I try to pay the credit card bill the payment fails. There is no indication of why. I have resorted to using check pay which works. Funny thing is, I am able to pay the bill directly from my bank account using my bank’s bill pay system. This I clearly a Quicken issue.

Answers

  • Quicken_Tyka
    Quicken_Tyka Alumni ✭✭✭✭
    Hello @MikeP

    Thank you for taking the time to visit the Community to share your issue although I apologize that you have not received a response.

    I have reviewed your online biller profile for Bank of America and see that the issue is due to a missing one-time code. At any point are you asked to select a method to receive a code or have a place to enter a code?

    If you are not asked for a code, I would recommend Validating the Online billers. To do so, please, navigate to the Bills & Income tab and click on the Gear-icon on the top-right. Then, click on Validate Online billers in the dropdown menu (see below).



    Once this has been completed, do you receive any additional messages? Please let us know!

    -Quicken Tyka

    ~~~***~~~
  • jobworker
    jobworker Mac Beta Beta
    That does not appear to be a Mac Bills & Income screen.  I do not have such a screen at all.  See attached image of screen shot of my Quicken Mac Bills & Income screen. I have no gear wheel and none of the items you show on your screen shot.
  • Quicken_Tyka
    Quicken_Tyka Alumni ✭✭✭✭
    Hello @jobworker

    Thank you for the response and the clarification, although I apologize for any confusion. Can you select the 3 dots next to the Bank of America bill and choose to unlink the bill.

    Once that has been completed, please attempt to relink the bill and let me know if at any point are you asked to select a method to receive a code or have a place to enter a code?

    Please let me know how it goes!

    -Quicken Tyka
    ~~~***~~~
  • MikeP
    MikeP Member ✭✭
    Thank you for the advise. Unfortunately, I have linked and unlinked the bill several times, and payment still fails. I have entered the one-time MFA code when updating the biller. When I do that the payment is registered in my checking account. However, within 24 hours the payment status is always update to “Payment Failed.” They only workaround I can find is to pay by check.
  • jobworker
    jobworker Mac Beta Beta
    Quicken_Tyka
    I did as you suggested, with one exception.  I do not have an account with BofA so I did it with Citi Bank.  I unlinked and then executed a new "Link eBill".  With Citi I did not get any request to receive and enter a code.  I was presented with a screen to validate the account I was linking, then "NEXT" and I received a final screen.  I was now Connected to Citi.
    However, I might mention that with Chase, I have to at least once a week get a code and submit it to them to validate my owning the account.  So F/I's seem to behave differently. 
    NOTE: Both Chase and Citi are Bills & Income eBill accounts, the only difference between them being the Payment Method.  Chase is a "Pay with Bank Bill Pay" account and Citi is "I pay the biller directly (typical)".
  • Quicken Francisco
    Quicken Francisco Moderator mod

    Hello @mikep

    Thank you for reaching out to the Community regarding your issue, though I am sorry to hear that you are experiencing this.

    The Described behavior is not one I've normally seen here, as such we would recommend contacting Quicken Support directly for the best assistance. This will let us see first hand what exactly is causing the issue you're having as well as letting us check directly where the issue lies. I will leave our hours down below so you can find a time that works best for you.

    Click here to review Quicken Support's hours of operation.

    Thanks,
    Quicken Francisco


Sign In or Register to comment.