Decimal point ignored in quote or price field

I am trying to register a buy of share with number of shares and price with decimals. The data entry field only accepts a decimal point (no comma) that is ignored. Thus I cannot register the buy correctly.
(riunning QUICKEN fo windows R33.24, build 27.1.33.24 on Mac High sierra (13.13.6) under Crossover virtualization software (20.0.04.33197)

Answers

  • Quicken Paloma
    Quicken Paloma Moderator mod
    Hello @PJ-Morin

    Thank you for reaching out to the Quicken Community. I apologize that you are having difficulties entering your shares bought. To better assist you I will need a bit more of information. Could you please attach a screen shot to view the discrepancy. 

    For further instructions on how to attach a screenshot click here
    Please note that you may have to drag the image into the response box. 

    Once more details are obtained we can diagnose the issue at hand. 

    -Quicken Paloma
  • PJ-Morin
    PJ-Morin Member
    Hello Paloma.

    here is the printscreen of the share buying info before doing ENTER ( value is 8560.3246, (the point being the decimal point)
    and after (with the share field in blue) and the value 85.606.246
    The same occurs in the price paid field

    I hope this help diagnose the problem
    regards
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Quicken is a US product, and as such isn't really "checked out" for all the different quirks of foreign formatting and such.  Since you are using the opposite of the US formatting for numbers you have run into a bug where the input fields of Number of shares and Price Paid have to be inputted in the US format even though the other fields are being displayed in your currency format.

    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • PJ-Morin
    PJ-Morin Member
    Thanks Chris.

    I understand this, and it would not be a problem if I could input the comma as separator which I cannot:
    Actually I have been using quicken US prior versions since a long time ago and there was no problem. Could it be because I uses Crossover virtualization software ?

    Thanks
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    In the past were you running Quicken on a Windows PC, not virtually?

    Are you able to enter the decimal point if you select the US currency settings in the OS before running Quicken?
    QWin Premier subscription
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    edited June 26
    PJ-Morin said:
    Thanks Chris.

    I understand this, and it would not be a problem if I could input the comma as separator which I cannot:

    That's the point.  You have to use the period.  As in, you have to input the numbers as if you were in US format.  Note that the "thousand separator" is never entered.  If I was to input 10,000.00 Quicken would block the comma and I would end up inputting 10000.00 in that text box.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Quicken Paloma
    Quicken Paloma Moderator mod
    Hello @PJ-Morin

    Thank you providing those additional helpful details. After attempting several times I was unable to recreate the issue you are experiencing. I would suggest that you enter the number as is without the comma or use a period instead (US formatting). 

    Hope this helps. Let us know how it goes!

    -Quicken Paloma 

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Hello @PJ-Morin

    Thank you providing those additional helpful details. After attempting several times I was unable to recreate the issue you are experiencing. I would suggest that you enter the number as is without the comma or use a period instead (US formatting). 

    Hope this helps. Let us know how it goes!

    -Quicken Paloma 

    I have played with this some more and even entering the numbers in US formatting doesn't work.

    To reproduce the problem:
    With Quicken not running:
    Edit C:\ProgramData\Quicken\Config\Quicken.ini
    Change sDecimal=. to sDecimal=,
    Change sThousand=, to sThousand=.
    Save file.

    This changes the numeric format from: 1,000,000.00 to 1.000.000,00.

    The expected behavior would be that this new format is used everywhere in Quicken, but it isn't in the investment  dialog.

    Here is me entering a charge of 1000 dollars and 59 cents in a credit card account.

    Now I save it.


    If you were to try to enter the same number in the investment buy dialog you would find that it will block entering the comma and instead of taking the period as a comma separator it would take it as the decimal separator resulting in this:


    Once saved, it does this very strange thing of changing it to 10.059.

    Now look at if I put in a price of $1.

    That is a cost of 10 thousand 59 dollars.


    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • PJ-Morin
    PJ-Morin Member
    Thank your Chris. I believe that you have replicated the problem I am experiencing. I suppose that you have run Quicken directly under windows operating system, and that we can therefore exclude the crossover virtualization software as a possible cause. I have reinstalled quicken and made no changes to the settings, and everything works fine with de point being the decimal point. Is is a pitty that quicken US does not support international settings, especially after having discontinued Quicken XG UK version that did support European settings and that I have been using for years .
    So I will keep the original setting a wait for a newer windows version that supports international settings.
    Thanks for the help of all the Quicken community folks.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Just to confirm, yes this has nothing to do with Crossover.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
Sign In or Register to comment.