Day Trade transactions are generating multiple Quicken Messages

I day trade stock equities. Whenever I download my transactions into Quicken I get a Quicken window asking "is this due to a same-day sales from an employee stock or similar plan" . I get this message for EVERY transaction I download. I dont have an employee stock plan. How do I turn this off?

Answers

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    As far as I know you can't turn that message off.  Quicken was never designed for day traders, so it isn't surprising that it would have problems with such.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Rich Gaughan
    Rich Gaughan Member ✭✭
    Thanks Chris, Would upgrading my Quicken version make any difference?
  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    Offhand I don't understand why "day trading" would result in the "same day sale" question popping up unless there's some flaw in the program where the daily volume of trades results in some sort of "overflow" situation and the program or data gets scrambled.  Has this question always popped up or have you been day trading for a while and then the problem was triggered?
    I'd be tempted to start a new file from scratch with only that one brokerage Account in it and simply start clicking on Accept All with every download and see if the behavior is the same in the new file.
  • Rich Gaughan
    Rich Gaughan Member ✭✭
    Thanks Tom, this question has always popped up since I have day-traded. I average 1-3 round trip trades per day, not a lot. So I have opening and closing trades for the same equity each day. Quicken seems to think that is related to a employee stock plan where an employee exercises their company stock option and subsequently sells the stock on the same day. I am prompted with this question for every trade. Otherwise Quicken is working fine. Any suggestions how I can get Quicken to understand that this activity is not related to a employee stock plan?
  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    edited August 2021
    I've never used the employee stock options aspect in Quicken "for real" but I've played around with them in a test file and I've only every seen that prompt (or something similar) in those Accounts where I've created options:
    so my instinct is that somewhere, somehow, you might have created some kind of option.  Or, maybe the fact that you're trading the same equity daily is somehow triggering that question.  If it's a problem that's somehow "file associated", i.e., something you might have done in this file leads Quicken to believe the stock is associated with an employer option, then running the test file I've suggested should expose that.  If the test file behaves the same as your live file then it does seem to be a Quicken quirk of some sort.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Thanks Chris, Would upgrading my Quicken version make any difference?
    No, it wouldn't matter.  Hopefully @Tom Young idea might shed some light on the problem.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    P.S.  I did have employee options at one time, and I notice that what it did for this is create a new security with "Option" at the end.  As in KLA-Tencor Corporation became KLA-Tencor Corporation Option.  So you might look for that.  (It did a similar thing for the ESPP)
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Rich Gaughan
    Rich Gaughan Member ✭✭
    HI Tom,
    What exactly is meant by "so my instinct is that somewhere, somehow, you might have created some kind of option". When you recommend creating a test file are you suggesting I create a test account or a new QDF file? Is there any setting in Quicken for ESPP plans or employee stock plan, I could not find anything in the account settings.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    There are no settings for ESPP or employ stock option plans.
    In both cases they are created by using a certain "action" when creating a transaction, and using a wizard.



    Does the security name have "Option" or "ESPP" after it?
    If the security was created using one of these wizards it would have that.  And it would make sense to get a message like you have seen.  On the other hand if the security wasn't created by one of these wizards then most likely what you are seeing is just some kind of bug in Quicken or maybe a bug in what the financial institution is sending making Quicken think it is one of these.

    If I was going to try to test if it was something created in that data file I would certainly create another data file and try it there.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    edited August 2021
    "What exactly is meant by 'so my instinct is that somewhere, somehow, you might have created some kind of option'".
    As I said, it just seemed odd to me that simply numerous trades in a day would somehow trigger that question, so the other programmatic reason for the question is that Quicken thinks the transaction is related to an employer stock option.  That might be the case if you, somewhere along the line and not even mining to, created an employer stock option. 

    "When you recommend creating a test file are you suggesting I create a test account or a new QDF file"
    A new "file."  If the problem is somehow related to an embedded problem in your current file then creating a new Account in the file could easily exhibit the same behavior.

    "Is there any setting in Quicken for ESPP plans or employee stock plan, I could not find anything in the account settings."
    As @Chris_QPW mentioned, the creation of employer stock plan option, (all forms of employer stock incentive plans can and are called "options"),  is an "Action" in an Investment Account.  You can create an option for an existing stock in your file and that option might "live" inside your regular Investment Account or a new Investment Account that you create for just that purpose.  Or you can create an option for a stock that currently doesn't exist in you file. 
  • Rich Gaughan
    Rich Gaughan Member ✭✭
    Tom,

    Looking at at this problem. I recall that when I upgraded Quicken SW around 1 to 1.5 years ago this message started to show up. Note that this message is the same no matter which equity is traded (AAPL, GS, AMZN etc).
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Can you post a screenshot of the action and security columns for one day?
    I tried buying and selling in the same day on the same security and didn't get the message:

    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Rich Gaughan
    Rich Gaughan Member ✭✭
    Chris,

    Here are two Quicken screen shots. One shows the round trip same-day AMZN transaction in Quicken, the other show the Quicken window with the employer stock plan question. Let me know what you think.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    edited August 2021
    It looks like to me that in fact the date/time on the sell is newer than the date/time on the buy, and is "confusing" Quicken.  Note entering these in manually doesn't trigger the same message, but that might be that it just treats the time differently.

    If you look at the OFX log you should be able to find the trades with their date and times.
    You should find it look like this (but might not be as nicely formatted).
                        <BUYSTOCK>
                            <INVBUY>
                                <INVTRAN>
                                    <FITID>162937783
                                    <DTTRADE>20110308160000.000[-5:EST]
                                    <DTSETTLE>20110311160000.000[-5:EST]
                                    <MEMO>BUY
                                </INVTRAN>
                                <SECID>
                                    <UNIQUEID>464288687
                                    <UNIQUEIDTYPE>CUSIP
                                </SECID>
                                <UNITS>51.0
                                <UNITPRICE>39.45
                                <COMMISSION>7.0
                                <TOTAL>-2018.95
                                <SUBACCTSEC>CASH
                                <SUBACCTFUND>CASH
                            </INVBUY>
                            <BUYTYPE>BUY
                        </BUYSTOCK>

    EDIT:  You can get the OFX log with: Help -> Log Files... -> OFX Log
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    I don't think anyone asked if you are having transactions automatically entered into the transaction list.  If so, you might try turning that option off.  

    From your two attachments, I think Quicken is mixing up the message.  If Quicken thinks the sell is before the buy, I would be expecting it to ask of this should be a Short sale situation, not a Employee stock plan issue.  (There are sure to be special cases for the stock plans I am not aware of.)

    Doing the search Chris suggested may reveal that the brokerage is listing the sales before the buys.  I don't think I have ever seen actual trade times reflected in the download info.  
  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    edited August 2021
    Are you actually selling short?  If you are and if you are allowing transactions to be automatically entered in the transaction list, then turn off automatic entry and try manually entering a Short Sale consistent with what you're seeing in the Downloaded Transactions area and then matching the downloaded transaction to the manually entered transaction.  Then do a manual Cover Short Sale for the downloaded Buy.
    Even if that works, it still doesn't make any sense.
    I'd still recommend running that one Account in a newly-created separate file to see if that changes things.

  • Rich Gaughan
    Rich Gaughan Member ✭✭
    Tom, No I am not selling short. I am automatically downloading 1-3 round trip transaction per day. I believe there is a setting in Quicken that has set this account as a Employer Stock Plan. It is a taxable brokerage account, it is not an ESP. If I was to create a new separate file for that account what do I learn from that? If the new file does not have this issue then I have to move all those transactions from the old account to the new account? Really?
    I began this support case thinking there was a simple setting in Quicken that would turn off this inquiry/window. The suggested solutions I have been given are actually worst then the issue.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    edited August 2021
    There is no such thing as a ESPP account (EDIT clarifying, There isn't any ESPP account TYPE, one would create an account for it, but it would just be a regular brokerage account).  There are ESPP securities and transactions.
    Example:


    When that buy is edited:


    So there isn't any "setting" for this.  It simply because the transaction was entered using this action:



    Note that my Kla-Tencor ESPP security doesn't come up because I left that company years ago.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    "If the new file does not have this issue then I have to move all those transactions from the old account to the new account? Really? "
    Well, you'd learn that this is really a "file" problem not a "Quicken programming" problem at which point you'd at least understand that, if nothing else. 
    With only a handful of transactions a day I'd try entering those transactions manually, in the proper order, and see if that stops the question from popping up when you download the transactions. 
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Note this problem can be at the security/account/file level/program level.
    1. Security level created with something set that causes this (doesn't look like that here).
    2. Account level, does this do this in the new accounts in the same data file?  If not, a new account could be created and the transactions moved to workaround.
    3. Data file level.  If this is proved to be true the rebuilding of the data file if one wants to preserve the history is going to be quite hard.
    4. If this is a programming error, not something that is picking up as a bad value in your data file, then only the Quicken developers can fix it.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    You have indicated you are "downloading automatically".  A scheduled One-set update perhaps? 

    You have not indicated how those downloaded transactions are moving into your transaction list.  Options I know about would be: 
    1) Automatically entered - a preferences setting
    2) Accept All - your action from the list of available downloaded transactions
    3) Accept individually - your action from the list of available downloaded transactions
    Which is it (or some other path I've omitted)?

    Either if the first two might cause some type of question from Quicken if it was trying to sell before the buy.

    I am more suspicious of the 'sell before the buy' clue than I am the employee stock consideration.  I realize that when all is done by whatever action and sequence you have used, the round trips are properly sequenced in the account transaction list (buy before sale).  
  • Rich Gaughan
    Rich Gaughan Member ✭✭
    I am doing a One-Step update and then I do an "Accept All". I appreciate all the detailed responses but nobody seems to know why Quicken generates the question in my comment above. What mechanism in Quicken would cause this message to be generated? Most SW tools I use have a error/warning index within the message that can be used to find the source of the problem.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    I am doing a One-Step update and then I do an "Accept All". …
    Then in the list of downloaded transactions, are the sales listed before the buys?  I am not aware of any standard that requires the FI to download the transactions in the same order you generated them. I would expect Quicken to process them in the order shown which presumably is the order the FI sent them. 

    Try individually accepting the Buys, then perhaps an Accept All for the rest. See if that avoids the problematic message. 
  • Rich Gaughan
    Rich Gaughan Member ✭✭
    Hi Q_Lurker, I will try out your suggestion this week-end regarding the order of accepting transactions. I'll let you know.
  • HI Q-Lurker, I had some family circumstances that came up which delayed my comment. In response to your suggestion, the problematic message appears before I can individually accept each transaction. At this point I believe I have to live with these messages each time I download transactions. I opened this case thinking that this would be a simple switch setting. Thank you for your detailed responses, I appreciate your support and that of the other Quicken members.