On the Spending tab, All Accounts Excludes an Asset Account (the account is not hidden) [edited]

The graph on the Spending tab does not shows expenses in a certain asset account I have. "All accounts" in the drop down is selected. I do not change the Last 30 Days or Spending selections.

The account is not a hidden account. It used to be hidden, but I un-hid it, and it still does not show in the graph. It is also not a separate account.

But if I select Custom and select All Accounts (excludes hidden and separate accounts) in the dialog, the account DOES show in the graph. What is the difference between All Accounts and Custom, All Accounts? What is the difference in the two settings that would explain this strange behavior?

Best Answer

  • David Shuford
    David Shuford Member
    Answer ✓
    After two chat sessions with Customer Support, I realize why this is happening. The Spending tab just does not see Asset accounts, by design. It only looks at what it thinks of as "spending" accounts. Kind of makes sense. Spending tab - spending accounts. But I had spending in a miscellaneous asset account for a special purpose I have.

    This is a case where Quicken is not as friendly as it could be. The dropdown on the Spending tab that says “All Accounts” should say “All banking accounts”. That would eliminate all of this confusion. If you want it truly to see "all accounts", then you have to use the Custom option.

    That's the workaround until or if Quicken fixes this.

Answers

  • Quicken Anja
    Quicken Anja Moderator mod
    Hello @David Shuford,

    Thank you for reaching out to the Community and telling us about your issue, though I apologize that you are experiencing this and for not having received a response yet.

    To start with, if you haven't already, I suggest that you please try validating and/or super validating your data file. However, I do recommend that you first save a backup file prior to performing these steps.

    Validate
    1. File
    2. Validate and Repair File...
    3. Validate File
    4. Click OK
    5. Close the Data Log
    6. Close Quicken (leave it closed for at least 5 secs)
    7. Reopen Quicken and see if the issue persists.

    Super Validate:
    1. File
    2. Hold CTRL + Shift and click Validate and Repair File...
    3. Super Validate File
    4. Click OK
    5. Close the Data Log
    6. Close Quicken (leave it closed for at least 5 secs)
    7. Reopen Quicken and see if the issue persists.

    Let us know how it goes!
    -Quicken Anja
  • Thank you for the response. I did a Validate (I don't think that had ever been done.) It corrected one scheduled transaction. However, the problem is still there. I thought I would try a Super Validate. But the backup before I did that said Not Responding. I try it later when I have more time. BTW, the Validate did not respond either. I had to reboot before it would work.
  • I tried a Super Validate. The first time, Quicken bombed and asked me to send an error report, which I did. The second time was successful. Results were the same as the Validate. (You would think it would not have found the thing the Validate found, i.e. the Validate actually fixed the transaction error.) In any event, the original problem persists. The Spending tab graph does not reflect the non-hidden account.
  • Quicken Anja
    Quicken Anja Moderator mod
    Thanks for the update, though I apologize that the issue continues to persist.

    At this point, I recommend that you reach out to Quicken Support directly instead, for more extensive troubleshooting and possible escalation if they see fit.

    I apologize for any inconvenience this may cause! Thank you.
    -Quicken Anja
  • David Shuford
    David Shuford Member
    Answer ✓
    After two chat sessions with Customer Support, I realize why this is happening. The Spending tab just does not see Asset accounts, by design. It only looks at what it thinks of as "spending" accounts. Kind of makes sense. Spending tab - spending accounts. But I had spending in a miscellaneous asset account for a special purpose I have.

    This is a case where Quicken is not as friendly as it could be. The dropdown on the Spending tab that says “All Accounts” should say “All banking accounts”. That would eliminate all of this confusion. If you want it truly to see "all accounts", then you have to use the Custom option.

    That's the workaround until or if Quicken fixes this.