Date entry

NOTL
NOTL Member
In previous versions of Quicken I used the + and - keys to increase or decrease the date when entering a new transaction. It was quick and handy.
Doesn't work any more. I miss it.
I still use m to put in the first day of the month, h for the last day, t for today, etc. but the + and - don't work.
Can you fix it?

Best Answer

  • Rocket J Squirrel
    Rocket J Squirrel SuperUser ✭✭✭✭✭
    edited January 6 Answer ✓
    You don't have to use the predefined date formats. You can use any combination of valid formatting characters (d, M, y) you like as long as the separator is the slash.
    The order of the date fields doesn't matter. I set mine to yyyy/MM/dd and the + and - keys work fine.

    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.

Answers

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    The + and - keys still work for me to change the date. Are you using the + and - in the main keyboard, or off to the right with the keypad on a big keyboard?

    If the latter, type + and - on the keypad into a text editor and make sure they produce the correct characters. If not, some utility may have redefined these keys.
    QWin Premier subscription
  • Frankx
    Frankx SuperUser ✭✭✭✭✭
    Hi @NOTL

    A blast from the past - I had actually forgotten about those.

    However, if you'd like Quicken to "fix it" I would suggest that you start an "Product Idea" post here in the Q Community at this LINK.  Idea posts can be voted upon by users and those that receive enough up votes are often schedules for production.

    Good luck!

    Frankx

                            Quicken Home, Business & Rental Property - Windows 10-Home Version

                                             - - - - Quicken User since 1984 - - - 
      -  If you find this reply helpful, please click "Helpful" (below), so others will know! Thank you.  -

  • Rocket J Squirrel
    Rocket J Squirrel SuperUser ✭✭✭✭✭
    The + and - keys continue to work correctly to move the date forward and back, whether pressed from the top number line or the numeric keypad.
    But they are dependent on the Windows Short Date format being compatible with Quicken. If you've set the short date format to "05-Jan-22", for example, the keys will not work. Quicken prefers short dates with slashes, like "1/5/22" and similar.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • NOTL
    NOTL Member
    Rocket - I use metric dating (today is 2022-01-06). There doesn't seem to be any way in Quicken to change the date format; it seems you have to change it in Windows, which affects all your programs.
    I use a Microsoft Surface Pro 7 computer. The little calendar obscures the date as well. Annoying.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    If you're trying to post an Idea, to change Quicken to work with all sorts of Date formats, you'll probably have this idea fall on deaf ears. But go ahead nevertheless. Or search the Community for already existing Ideas on this subject.
    Quicken is primarily marketed towards the North American market and uses the US standards MM/DD/YYYY (or Canada DD/MM/YYYY). International users are requested to follow these standards, to avoid potential problems.
    If your "little calendar obscures the date" try making the Date column a little wider.

  • NOTL
    NOTL Member
    UKR - I widened the date column, and it worked! I can see the whole date! Now why didn't I think of that? Thanks.
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    NOTL said:
    Rocket - I use metric dating (today is 2022-01-06). There doesn't seem to be any way in Quicken to change the date format; it seems you have to change it in Windows, which affects all your programs.
    I use a Microsoft Surface Pro 7 computer. The little calendar obscures the date as well. Annoying.
    I would advise changing the Windows short date to YYYY/MM/DD instead of YYYY-MM-DD if you want to use the +/- keys to increment the date. 
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • NOTL
    NOTL Member
    mshiggins - Thanks for the suggestion, but it didn't work. My Windows doesn't offer YYYY/MM/DD, only YYYY-MM-DD. I tried all 8 of the available date formats, and found the + and - keys only work if the format includes slashes, but not if it includes dashes. All the format options that use slashes are American dating - e.g. 6/1/22 - which I don't use as I can't remember if it's June 1st or January 6th. That's why I prefer metric dating. Thanks again.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    It wouldn't matter if you put in slashes.  It isn't just the separator that messes Quicken up, it is also the order of the different parts.  For + and - to work it has to be MDY.  For instance, setting it to YY/MM/DD will not work.

    BTW there are ways to change the formatting besides the "standard ones" by going into the Control Panel Region settings, but like I said in this case it doesn't matter.

    Quicken is pretty lame about the fact that it expects the US format for these to work.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser ✭✭✭✭✭
    edited January 6 Answer ✓
    You don't have to use the predefined date formats. You can use any combination of valid formatting characters (d, M, y) you like as long as the separator is the slash.
    The order of the date fields doesn't matter. I set mine to yyyy/MM/dd and the + and - keys work fine.

    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭

    The order of the date fields doesn't matter. I set mine to yyyy/MM/dd and the + and - keys work fine.

    Strange, on my test the order did matter...

    I think I just fooled myself.  I tried YY/MM/DD. and that doesn't work.  I can see why without the 4 digits for the year it doesn't know the first two digits are the year.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • NOTL
    NOTL Member
    Rocket - Brilliant! I customized the date format to yy/MM/dd and the + and - keys now work. Amazing!
    Thanks so much.
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser ✭✭✭✭✭
    edited January 6
    Chris_QPW said:
    I tried YY/MM/DD. and that doesn't work.  I can see why without the 4 digits for the year it doesn't know the first two digits are the year.
    yy/MM/dd works fine in my Quicken.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Chris_QPW said:
    I tried YY/MM/DD. and that doesn't work.  I can see why without the 4 digits for the year it doesn't know the first two digits are the year.
    yy/MM/dd works fine in my Quicken.
    Hmm.  Doesn't for me.  Oh well, it isn't like I actually use any of this.   ;)
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    BTW from a programmer's standpoint I really don't understand why they are doing it the way they are.  Clearly, they are parsing the text to do this, but these have to stored as "Dates" internally, which are subject to "formatting".  Why they don't just deal with the internal date instead and leave the formatting to the "displaying" of them I don't know.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
This discussion has been closed.