Last Resort for Some Help - Quicken Not Consistently Saving Manually Entered Transactions!

dogbite00
dogbite00 Member ✭✭
I've been a Home and Business user for almost 15 years. Over the past 3-4 months I am finding Quicken fails to save recent entries. I manually enter everything, and have about 6 accounts I use Quicken to track. I Use quicken typically twice a day, 7 days a week. Over this time period I would say about 10-15% of the time I open Quicken, the entries from the last use are not present. I have had 2 occasions where one of my accounts showed NO ENTRIES when opening Quicken - that data returned after closing and re-opening the file. I haven't tried that when an entry is missing but plan to next occasion.

I have had 2 customer support contacts. The first time they had me validate my data file (no problems/errors) and reconnect my software to my cloud account. The 2nd customer service contact was not helpful as we had a language barrier. He did have me submit a ticket through the software to their engineering team. No response yet (2 days). Problem continues as of today.

I've found other threads on this forum with similar issues but no clear solution. Any suggestions would be appreciated. [Removed - Rant]

Answers

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Where are you storing your data file, the whole path to it?

    It is possible that another program is "locking" your data file while Quicken is running, and the result is Quicken can't update the data file.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • dogbite00
    dogbite00 Member ✭✭
    The data file is on my D drive which is an internal SSD on my machine. The only possibility on something locking the file would be backup software. I only run that manually and don't recall running any backups immediately after closing Quicken - but I'll keep it in mind.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Do you use OneDrive?  (or any other "cloud folder").

    The default location for the Quicken data file is in Document, which if one uses OneDrive and has selected to back up their files to it, Documents will be in OneDrive's folders.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Note this wouldn't be any thing that you run manually.  It only takes Quicken a split second to update the data file.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • dogbite00
    dogbite00 Member ✭✭
    I don't use OneDrive, but backup my D drive to Sync.com - This is done once a day and MANUALLY. I actually had an issue many years ago when my Quicken data file got corrupted a few times. Learned my cloud service was trying to copy it as I was trying to open it. Yet another annoying problem with Quicken. I don't encounter similar problems with any other software. My general impression is this is ancient software with a lot of patching.
  • Ps56k2
    Ps56k2 SuperUser ✭✭✭✭✭
    What version .... Help --> About Quicken
    There was a recently reported bug -
    where manually entered transactions were not showing up until Quicken closed/opened.
    I also think the Sort Order of the Register was affecting the display.
    QWin Deluxe Subscription - Win10
  • dogbite00
    dogbite00 Member ✭✭
    Version R37.67 Build 27.1.37.67
  • dogbite00
    dogbite00 Member ✭✭
    I saw other threads several weeks ago when I 1st started researching this - they all pointed toward some issue with the software not connecting properly with Quicken. The recommended fix was to d/c file from account and reconnect which I have done twice at the recommendation of their customer support. No joy.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    dogbite00 said:
    The data file is on my D drive which is an internal SSD on my machine. The only possibility on something locking the file would be backup software. I only run that manually and don't recall running any backups immediately after closing Quicken - but I'll keep it in mind.
    Here’s an off the wall controversial test. 
    Move your data file to a Drive C folder. I know it should not matter, but some say it does. 
  • dogbite00
    dogbite00 Member ✭✭
    Thanks for the suggestion. I may try it. Annoying that I may need to adjust my work flow because a piece of software is temperamental?
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    Are the accounts where transactions are disappearing synced to the Quicken cloud?


    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • dogbite00
    dogbite00 Member ✭✭
    Not sure - when I open preferences > Quicken ID and Cloud Accounts I get a message "We could not retrieve your Quicken profile information."
  • dogbite00
    dogbite00 Member ✭✭
    FWIW - I just got off with support again after realizing the software was not connecting to my profile. I had to re-connect (edit>preferences>Quicken ID and Cloud Accounts). I remembered that before my 1st customer support call the software was not connected initially. Talking with today's agent it seems Quicken will often disconnect with the cloud profile after updates (OS or Quicken). He said this is almost certainly why I was seeing entries not saving (no explanation why, however). His recommendation was to always make sure the software is connected AND also to manually disconnect and re-connect once a week. This can be done by clicking the link "Sign in as a different user."

    So..... I guess I'll try that for a while. However, sitting here shaking my head. Why does this software take so much baby sitting? Horrible, even if this were free. For paid software this is inexcusable. It can't run offline and it may not save entries if not connected? Just terrible. Really, they should be paying me to babysit. I'll add all of this to my checklist of running Quicken.....

    Don't save your data file anywhere near a cloud backup folder.
    Don't run on any internal drive except "C" - maybe.
    Don't have open if any backup software wants to copy the file.
    Check to see if any recent transactions are missing once open.
    Check to make sure the software connected with your profile.
    Disconnect and reconnect your profile every week.
    Print out any critical business reports to pdf's in case the proprietary software chokes.
    Cross your fingers and hope for the best.

    I appreciate everyone's help, but my, my, my. Good things are slow right now, because most weeks I don't have 2-3 hrs to dedicate to customer support to keep my business financial software running.
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    I would give the opposite advice. If you are connected to the Quicken cloud and syncing account to the Quicken cloud, it is highly likely the cloud sync is disappearing your transactions. 

    I would also say that all the Super Users here have similar lists of do/don't do. Don't sync to the cloud. Don't use Express Web Connect. Do have a good back up strategy.
     
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • dogbite00
    dogbite00 Member ✭✭
    ...so, would it be best to just disconnect from Quicken cloud? Will I receive updates when they're pushed out? There's no reason to my understanding that I need anything from Quicken cloud. I just want the software to run locally (and reliably) on my machine and for manual entries. My impression talking with customer support x3 was the software MUST connect. What is the purpose of the cloud connect?
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    mshiggins said:
    I would give the opposite advice. If you are connected to the Quicken cloud and syncing account to the Quicken cloud, it is highly likely the cloud sync is disappearing your transactions. 

    I would also say that all the Super Users here have similar lists of do/don't do. Don't sync to the cloud. Don't use Express Web Connect. Do have a good back up strategy.
     

    Thanks for mentioning this, I didn't cover it is a possibility, but it is certainly a strong possibility.

    If you are using Sync to Mobile/Web, I would certainly turn it off, at least for a test.

    On the subject of your "Profile" and the error you got.

    For testing on different a different machine, I jump between different data files and Quicken Ids and as such I have seen that error once in a while.  I'm not really sure exactly what triggers it, but I something to say about the error itself.  Depending on what you are doing with your data file, it might not matter at all.

    I have run just fine, and then come in and find that error, so one has to even wonder what it is for.

    The first thing that the Quicken Id (actually the Intuit Id) was use for is registering after the install to prove you bought the software.  That was/is done with a connection to the Quicken Cloud dataset, but show have been a very small amount of "data.  Clearly with the Subscription they have "extended" that, but there is also an "offline mode" after you have registered, so it isn't clear if this is in indication that it really can't check the license or not.

    Past that one looks of what is stored in the Quicken cloud dataset.  Certainly "Sync to Mobile/Web" is there, but since the start of last year, Express Web Connect is using it too.  Then there are things like the credit score, and Quicken Bill Manager, ...

    If that error means anything then you would expect these features to stop working.

    Well, I don't use them, except in a test file every once in a while, so I can't comment on if they would fail to work if your "profile login" is in this error state.

    But I will say this on my real data file, that doesn't use them, I have never seen that error, and wouldn't expect it to "disconnect".  I certainly wouldn't be logging out and back in on a weekly basis.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • dogbite00
    dogbite00 Member ✭✭
    > @Chris_QPW said:
    > Thanks for mentioning this, I didn't cover it is a possibility, but it is certainly a strong possibility.
    >
    > If you are using Sync to Mobile/Web, I would certainly turn it off, at least for a test.
    >
    > On the subject of your "Profile" and the error you got.
    >
    > For testing on different a different machine, I jump between different data files and Quicken Ids and as such I have seen that error once in a while.  I'm not really sure exactly what triggers it, but I something to say about the error itself.  Depending on what you are doing with your data file, it might not matter at all.
    >
    > I have run just fine, and then come in and find that error, so one has to even wonder what it is for.
    >
    > The first thing that the Quicken Id (actually the Intuit Id) was use for is registering after the install to prove you bought the software.  That was/is done with a connection to the Quicken Cloud dataset, but show have been a very small amount of "data.  Clearly with the Subscription they have "extended" that, but there is also an "offline mode" after you have registered, so it isn't clear if this is in indication that it really can't check the license or not.
    >
    > Past that one looks of what is stored in the Quicken cloud dataset.  Certainly "Sync to Mobile/Web" is there, but since the start of last year, Express Web Connect is using it too.  Then there are things like the credit score, and Quicken Bill Manager, ...
    >
    > If that error means anything then you would expect these features to stop working.
    >
    > Well, I don't use them, except in a test file every once in a while, so I can't comment on if they would fail to work if your "profile login" is in this error state.
    >
    > But I will say this on my real data file, that doesn't use them, I have never seen that error, and wouldn't expect it to "disconnect".  I certainly wouldn't be logging out and back in on a weekly basis.

    So I'm a bit confused based on the different answers (all appreciated).

    When I've contacted support my Quicken ID showed not connected and I had to re-enter my credentials (edit>preferences>Quicken ID and Cloud Accounts"). Simply trying to re-connect would not work. This has happened several times. I don't know if the software disconnecting is causing the issue, or whether something on their Cloud was "disappearing" some entries when it was connected. I guess I can try it both ways and see, but it seems outrageous to have to log in and out of their cloud ID every week. Support suggested this may be most likely to occur after an update, and I did receive one the past few days, so it seems plausible that disconnected my Cloud ID + sync.

    FYI, Mobile and Web has always been and continues to be OFF.

    Support even said when you close the program it really 'only minimizes' and it continues occasionally syncing to the cloud - really? Anyone else just using the software locally - do you let it connect to Quicken cloud ID?
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Sometimes I wonder about Quicken support answers...

    The upshot of what I was saying about logging in is that if you are switching Quicken ids, and data files I would expect that you are "never logged out".  My main data file is never "logged out".  But even if it was, i doubt it has much impact on the use of the Quicken data file.

    As for this:
    dogbite00 said:

    Support even said when you close the program it really 'only minimizes' and it continues occasionally syncing to the cloud - really? Anyone else just using the software locally - do you let it connect to Quicken cloud ID?
    What do they think Quicken Windows is running on, Android?
    Actually, I think there are some mixed up statements here.

    When you close it, it isn't doing anything in the background, it isn't running.
    Now if you have scheduled downloading turning on, clearly it is running Quicken in a non GUI kind of mode, more using the "backend of Quicken" to download transactions at that time, and quit.

    And the "Quicken cloud dataset" is on the Quicken server.  If it has accounts connected to financial institutions because you are using Express Web Connect or Sync to Mobile/Web, then yes that server periodically goes out an gets transactions from the Fianacial institution's and saves them waiting for Quicken Desktop to sync with it and bring those transactions down into the Quicke Desktop data file.
    Note they use the transaction unique Ids to make sure that you don't get duplicates.

    Now even if you were doing everything entirely local, pure manual entry, Quicken is doing to periodically talk to the Quicken server/Quicken cloud dataset to confirm things like your subscription is active, is there any updates to Quicken, ...  But this happens when you run Quicken, not when it is "closed".
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • dogbite00
    dogbite00 Member ✭✭
    FWIW this is still a persistent issue for me - no resolution has been found. I have been able to rule out an issue with the software connecting to the cloud being the root of the problem. In other words, the last time entries failed to save I WAS connected at the time (and on next launch of the software).

    I have filed 2 tickets to Quicken through the software with no contact or reply from support after several weeks. My calls to support are all over the place in terms of suggestions (non of which have helped), so not really wanting to waste any more time with phone support. The only two items left to consider....

    1) This all started when I moved Quicken to a new PC - running WIN 10 pro. My old PC was running WIN 10 Home. I find it hard to believe that would be an issue, but happy to hear if anyone else has had a similar experience.

    2) My Quicken file is running off an internal hard drive, but not my C:\Drive. I may move it to C to see whether this makes any difference - again, any comments on why that should even matter welcome.

    Thanks to all for some suggestions.
  • dogbite00
    dogbite00 Member ✭✭
    FYI, today I moved Quicken to my C drive - no help. Still had an entry that didn't save after re-opening the software. What was odd was that I made the entry, then edited 2 prior entries. The new entry was lost after closing the software. But the edits to the prior entries were saved. This is absolutely crazy.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    dogbite00 said:
    FYI, today I moved Quicken to my C drive - no help. Still had an entry that didn't save after re-opening the software. What was odd was that I made the entry, then edited 2 prior entries. The new entry was lost after closing the software. But the edits to the prior entries were saved. This is absolutely crazy.
    I think I've been able to reproduce the issue in R36.38:

    Add a new transaction to a register but do not save the new transaction.
    Left click on another transaction in the register.   

    Edit an existing transaction but do not save the existing transaction.
    Left click on another transaction in the register.   

    Exit Quicken and reopen Quicken.


    Note: If the To save a transaction after changing it  notify preference is checked, when we left click on another transaction after changing an existing transaction, we are prompted to save the transaction.  We are not prompted when we click on another transaction if the transaction is new and not saved.  If the To save a transaction after changing it  notify preference is not checked, the change to the existing transaction is saved but the new transaction is not saved.
  • dogbite00
    dogbite00 Member ✭✭
    The "To save a transaction after changing it" preference was selected, and I do get a warning if trying to close the software and something wasn't saved. Re-opening the software finds all of the entries/edits present from the last time in the software. My normal routine is to just hit the "ENTER" key after a new entry is completed. I hear the a sound confirming the save, no warnings when I close the software (that something wasn't saved), but about 2-3 x a week the last entry (or entries) will be missing when I re-open the software.

    Not sure if I'm understanding your post, but I'm about ready to toss Quicken and go to something else.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    dogbite00 said:
    The "To save a transaction after changing it" preference was selected, and I do get a warning if trying to close the software and something wasn't saved. Re-opening the software finds all of the entries/edits present from the last time in the software. My normal routine is to just hit the "ENTER" key after a new entry is completed. I hear the a sound confirming the save, no warnings when I close the software (that something wasn't saved), but about 2-3 x a week the last entry (or entries) will be missing when I re-open the software.

    Not sure if I'm understanding your post, but I'm about ready to toss Quicken and go to something else.
    With the To save a transaction after changing it notify preference checked, we do not get a warning if trying to close the software and a new transaction has not been saved if we have subsequently saved a change to another transaction in the same register.  

    I think there is a bug in Quicken.  In my opinion, Quicken should be treating the new and existing transactions the same way when they are pending a save.  Instead, the unsaved new transaction may appear as if it is in the register when it no longer really exists.  When we click away from the unsaved new transaction to an existing transaction, Quicken should either prompt us if To save a transaction after changing it notify preference checked or automatically save the transaction if To save a transaction after changing it notify preference not checked just like it does for unsaved existing transactions.

    If you're certain you saved the new transaction before saving the existing transactions, then I did not reproduce your issue.   Otherwise, perhaps I provided you a clue as to what might be happening.
  • dogbite00
    dogbite00 Member ✭✭
    I've not heard any more suggestions on this topic for a few weeks - appreciate everyone's attempt tot help. I have done more online searches about this problem and found several other posts on this forum with users experiencing the exact same problem - none offered any solution - those threads were also closed. Those threads date back over the past year or more, so I believe this is a bug that Quicken needs to address.

    For anyone considering QUICKEN as an option (not currently using it) - I CANNOT RECOMMEND IT AT this time. I use only about 20% of its functionality and it can't be trusted to simply save and store data.

    I can only hope the software engineers get this fixed - doubtful, but hopeful.
This discussion has been closed.