Has anybody figured out how to fix the MorningStar X-Ray SAMLERROR: Redirect failed issue?

mhkwildcat
mhkwildcat Member ✭✭
edited March 25 in Investing (Windows)
I get this message on my X-Ray report and have had it for over a month. I just sent the second 'Report a problem' to Quicken but have not heard anything about it.

Best Answers

  • GeoffG
    GeoffG SuperUser ✭✭✭✭✭
    edited February 24 Answer ✓
    If you are looking to refresh MorningStar, the problem is that recent upgrades do not respect the custom security settings. If you reselect investments only with valid security symbols, the refresh will work. I'm not sure if it's after a Quicken update that it resets to all or if the setting is not retained at all. 

    *UPDATE* I can confirm that any custom setting is not retained regardless of update. Until the developers fix this issue, you must reselect intended securities each time you view this tab.
    user since '92 | Quicken Windows Premier - Subscription | Windows 11 Pro version 21H2
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    edited February 24 Answer ✓
    I think I have seen that same SAM… error in my file. I was able to track it down to one specific security (a muni bond). Including that security produces the error. Exclude the security no error. 

Answers

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Quicken does not acknowledge issues reported through Report a problem. 

    See this discussion
    https://community.quicken.com/discussion/7906036/error-when-trying-to-access-portfolio-x-ray
    for possible fixes. Please let us know if either of these fixes the problem for you.
    QWin Premier subscription
  • mhkwildcat
    mhkwildcat Member ✭✭
    Thank you for the quick response, yes, I have tried that and it did NOT fix the issue, unfortunately!
  • GeoffG
    GeoffG SuperUser ✭✭✭✭✭
    edited February 24 Answer ✓
    If you are looking to refresh MorningStar, the problem is that recent upgrades do not respect the custom security settings. If you reselect investments only with valid security symbols, the refresh will work. I'm not sure if it's after a Quicken update that it resets to all or if the setting is not retained at all. 

    *UPDATE* I can confirm that any custom setting is not retained regardless of update. Until the developers fix this issue, you must reselect intended securities each time you view this tab.
    user since '92 | Quicken Windows Premier - Subscription | Windows 11 Pro version 21H2
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    edited February 24 Answer ✓
    I think I have seen that same SAM… error in my file. I was able to track it down to one specific security (a muni bond). Including that security produces the error. Exclude the security no error. 
  • mhkwildcat
    mhkwildcat Member ✭✭
    Thank you GeoffG and q_lurker!! That fixed the issue -- once I deselected the appropriate investment accounts it refreshed. Greatly appreciated on the help!!
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    Follow up -- It has always been one specific security that has produced that error.  I can't spot anything form-wise different in that muni bond than in other muni bonds that I own and that don't cause that error.  It is something I intend to research more at some point - but have not yet pursued 
  • mhkwildcat
    mhkwildcat Member ✭✭
    Mine in particular were accounts I use to track crypto and 529 accounts. But nothing tied to specific securities. Weird that it tried to read those accounts. I’ll double check tomorrow to make sure I’m not forgetting something.
This discussion has been closed.