American Express SMS MFA still being required

I have two sets of Amex accounts, one for myself and one for wife. My accounts have been requiring a SMS validation for awhile and her don't. This has been in other posts and I can't stop getting the required MFA everyday. I've reset the connection (using Quicken Connect) and deleted the quicken entry in Keychain and nothing has eliminated. I know Amex/Quicken connection has been having some challenge and is that part of those issues or how can I get this to stop requiring everyday?

Answers

  • Quicken Jasmine
    Quicken Jasmine Moderator mod
    Hello @checkyourmirrors,

    Thank you for contacting the Quicken Community, though I do apologize that you are experiencing this error with the repeated MFA with your American Express accounts.

    First, could you please provide which version of Quicken you currently have running?
    • Quicken > About Quicken
    To start with, I suggest deactivating the account(s) experiencing this error, removing the saved login credentials from the Keychain Access app, and then reactivating the accounts. However, before doing so, I do recommend saving a backup of your data file first (just in case). Then, please check and make sure you do not have any hidden accounts that may be connected to this financial institution.
    1. Go to the Accounts menu and choose Hide and Show Accounts
    2. Uncheck any accounts with this specific financial institution that are checked as hidden in Lists
    After that, please follow the troubleshooting instructions below.
    1. Open the account register and navigate to the Settings gear on the bottom-right corner
    2. Click on the Downloads tab
    3. Click Disconnect Account (if there are more than one account associated with this financial institution, please repeat steps 1 through 3 for each account)
    4. Quit Quicken
    5. Open Finder and navigate to Applications > Utilities > Keychain Access app
    6. On the left panel in the Keychain Access app, select Login and select Passwords at the top
    7. Search for the financial institution's name in the top-right search field and delete any entries found showing "Quicken password for [your financial institution username] at [financial institution name] "
    8. Quit the Keychain Access app and reopen Quicken
    9. Navigate to Accounts > New and choose the appropriate account type for the accounts that you previously deactivated 
    10. At the bottom of the window showing the list of the financial institutions, click on the "My bank is not listed" question mark icon, then click Update List
    11. Wait for the list to finish updating and " Updated: " displays the current date.
    12. Click the Show List button to continue
    13. Use the search field at the top of the list to find and select your financial institution and click Continue
    14. Follow the prompts to sign in using your login credentials associated with the financial institution
    15. If the accounts have been found successfully; use the dropdown menus to link each account to the appropriate account in Quicken
    As you mentioned, we do currently have an active alert regarding online banking errors with American Express and the error that you are experiencing could be related to our active alert. So just in case the above instructions do not assist you towards a resolution then I have added a link to the alert here so you may follow and bookmark it in order to remain up to date on any resolutions that may occur.

    Please let me know how this goes!
    -Quicken Jasmine
  • checkyourmirrors
    checkyourmirrors Member ✭✭
    I successful deleted the password from Keychain, added new accounts and in turn Linked them to the two Quicken register accounts I have, and downloaded transactions. I will update the thread in the next couple of days with hopefully no more daily MFA requests