How can I set up lots in my investment account?

GregM
GregM Member
edited June 2022 in Investing (Mac)
I have one stock purchase plan investment account that I sold shares from for the first time today. I purposely selected specific lots to sell when I set the trade with the brokerage. When I tried to record the sale in Quicken the list of lots to choose from is blank. The "Specify Lost Assigned in This Transaction" dialog is empty with the header "Specify Lots of (null) Sold"

I can understand not being able to see all lots since this account was open before I started using Quicken and many lots were transferred in. But even quarterly transactions (lots) since I set up the account in Quicken are not listed.

So, how can I set up the lots correctly in Quicken. I am using Quicken for Mac, but will install in a Windows VM if there is functionality there to set it up and then transfer the data as necessary (assuming I cannot use the same Quicken data files.

Answers

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    If you were using Quicken for Windows, you likely accepted a placeholder transaction to establish your holdings that you should replace with the appropriate Added action transactions to establish the correct lots.

    As you're using Quicken for Mac, I have requested a moderator move your post to an appropriate Quicken for Mac category.
  • GregM
    GregM Member
    I am using Quicken for Mac as my primary platform. When the account was created the first 30-odd purchases were all created as a single "Shares Added" transaction. But even if that is read as a single lot I would expect to see five lots (the initial Added, plus the last four quarterly buys). None are shown.

    Quicken Mac does not have a an option to fix the lot assignment (on the File Operations menu referenced in another post) that I can find. That is why I stated that I would be willing to use Quicken Windows to fix this if that would work. But I would not want to continue with the Windows option long-term.
  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭✭
    @GregM - You are not seeing any lots?  Do you have Simple Investing turned on?  Simple Investing does not have that functionality.  If you want to have specific lots history you should not have Simple Investing turned on.  Turn it off an you will be able to enter/edit specific lots. 
    But once you turn off Simple Investing you will show no lots for the time period you had Simple Investing turned on.  If you want to show lots for that time period those lots will need to be added.
    Two ways to add missing lots:
    1. Restore a backup file from before Simple Investing was turned on.  Run OSU and download transactions from your investment broker.
    2. #1 might not be practical....depends on how long ago that Simple Investing was turned on.  If that is not practical, then the missing lots will need to be manually entered.
    (QW Premier Subscription: R44.20 on Windows 11)
  • GregM
    GregM Member
    Sorry - I should have mentioned at first. I do NOT have Simple Investing enabled. I can see all transactions in my account. The first several years were all added into the register as a single "Add Shares". But there were four quarterly buys since that time. At a minimum I would have expected to see the four buys as specific lots. I would also expect to see the Add Shares to show up as one additional lot.

    I set all my investment accounts with full details. This is the first trade I've made since switching to Quicken that were not simple FIFO and that I selected specific lots. I just checked another account and the same issue exists with that broker.

    I need to set up all the historical lots so I can choose them for my sale. But I still don't see where to do that, or understand why the current buys are not included in the lots.
  • lhossus
    lhossus SuperUser ✭✭✭✭✭
    I am no expert in recording sales by lot, but ...

    To establish LOTS, one simply records each acquisition of shares with a transaction of type Buy, Reinvest, or Add Shares. Quicken then should present these transactions as LOTS. 

    Quicken for Mac has no repair mechanism, or separate LOTS editor, for dealing with missing LOTS data. One just needs to enter the correct Buy, Reinvest or Add Shares.

    I think you understand all this. So, the mystery is why doesn't Quicken present the LOTS when a Sell transaction is entered.

    To investigate further:

    Make a backup of your Quicken Data file. Quitting and re-launching Quicken will do this if, in Preferences, you have File backup set to Automatically back up data file when Quitting Quicken.

    a) In the Portfolio view of an investment account, select Portfolio Value and group By Security.

    Now for the security of interest, click on the disclosure icon (>) to the left of the security Name. A new icon (v) appears and the LOTS should be displayed showing the date of acquisition. There should be at least one LOT displayed for every security.



    b) Try adding shares of a new security that you don't currently hold using one of the three transaction types.

    Now look in the Portfolio view and check for LOTS.
    Quicken Mac Subscription • macOS Monterey 12.6 on MacBook Pro 13" M1
This discussion has been closed.