R41.9/R41.10 - lost ability to add date to backup file choosing different path (fixed R42.8)



  • rjkray
    rjkray Member
    Another related issue is that I am not currently able to get my backup to be stored in the file location I prefer, a separate "Quicken Backup Data" file location not located inside the Quicken Data file - I was also not able to see any change in that location when I went to the Edit/Preferences/backup/Change backup directory and changed the location to my previously used file location shown above. When I go to that edit sequence a second time it shows the new/old location for the file, but it does not come up when I attempt to do a backup. There have been more issues created with the new version than just the date issue regarding the backup process. AARGH!!!
  • I think if you click on "Change" next to the dropdown box, you will be able to change the backup directory and/or backup name.  This will also allow the date and time checkboxes to work correctly.
  • rjkray
    rjkray Member
    I did change it in the change backup dialog and it shows that location has changed when I go back and repeat the change location dialog, but it doesn't actually change it in the process of actually saving the backup.
  • rjkray
    rjkray Member
    And when one changes the location while actually saving the backup it eliminates the date time component and saves it without any identifying nomenclature unless you actually type in a change to the name of the backup manually. Which I suppose one can do, but it's very annoying when it has been working properly and without effort for years.
  • Ron Shanbrom
    Ron Shanbrom Member ✭✭
    > @GeoffG said:
    > Not sure why you are experiencing issues with backup. The option still remains and in fact has been enhanced with now including a timestamp. 

    I turned my computer off last night w/flash drive still in. Turned it on today and was able to get it to back up to flash drive. But, recently I had this problem on 2 separate occasions, having tried the back-up multiple times, all w/o success. That's when I posted my issue. Apparently, others were able to replicate the problem which, I saw, will be addressed in the next update.
  • Ron Shanbrom
    Ron Shanbrom Member ✭✭
    > @J Smith said:
    > A work around: When changing to another backup location, backup without the date the first time. The date will not be greyed after the backup completes and you can choose date and do another backup with date.
    > It is a shame Quicken doesn't properly check revisions. Almost as bad as Quicken's success getting a Marcus credit card setup. That problem has been ongoing since April. All one receives is there is no ETA when Quicken will fix the
  • Ron Shanbrom
    Ron Shanbrom Member ✭✭
    I tried backing up to my computer later, but could only add the time, not the date. However, unlike yesterday, the back up screen defaults to my flash drive, allowing me to back up both date and time.
  • yetanotherdave
    yetanotherdave Member ✭✭
    edited June 2022
    After installing the current Quicken update, when I attempt to change the backup directory location, the "Add date to back filename" option is "grayed out", unselectable.

    The option to "Also add time to name" is new in this version, it is selectable. If I select this option the name is corrupted (truncated to the first character only); the time is NOT added.

    This problem did not appear until I installed the current update.

    Workaround: Make no changes to the backup directory path, complete backup "as is", manually move backup file to desired location.

    Is anyone else experiencing this issue?

    [Merged Post]
  • yetanotherdave
    yetanotherdave Member ✭✭
    also submitted through Help -> Report a problem...
    to increase the "vote count"
  • B Cash
    B Cash Member
    Let's get the "Add date to back filename" issue resolved. Can't understand why the technical team didn't thoroughly test this before going live.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    edited June 2022
    They didn't announce it fixed in the release notes but is now working for me in R41.16.
    Update and Mondo Patch: Subscription Release of Quicken for Windows
    This is my website: http://www.quicknperlwiz.com/
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    It seems I didn't test all the use cases.  If you have multiple locations in the pulldown menu, then it will mess up like it did before for selecting "Change".
    This is my website: http://www.quicknperlwiz.com/
  • TTSguy
    TTSguy Member ✭✭✭✭
    Why is it that when they try to improve something in Quicken with Quicken working, it then breaks something in Quicken. I happens what seems like 9 out of 10 attempts. Something is seriously wrong with the way the system works, Never tested! Other companies seem to be able to do it just fine. I don't understand!
  • BlazerBob
    BlazerBob Member
    I am assuming Quicken is a large and successful company. Two recent incidents have me pondering otherwise. The US Bank fiasco and now this! Each problem takes too long to fix. This problem should NEVER have happened unless the tech support team has one or two persons. Quicken user since 2004 trying my patience.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Define "large", by most standards Quicken Inc isn't large.
    This is my website: http://www.quicknperlwiz.com/
  • BlazerBob
    BlazerBob Member
    Then let us strike the first sentence, shall we.
  • Edva
    Edva Member
    Since it is broken...time / date check boxes hosed, uncheckable if choosing a different file path int the drop down regardless if you navigate to backing up the long way or use CTRL-B. (I'm a shortcut type of dude)

    I found it's a two step process as a work around. If someone posted this, I apologize for the duplicate.

    1. CTRL-B
    2. Keep your existing path, you'll see both time/date buttons can checked selected unselected
    3. Make the backup
    4. CTRL-B again
    5. Choose another file path
    6. YES... time/date buttons now hosed
    7. Make the backup
    8. CTRL-B - NOW you will notice the new path is is visible as are the TIME/DATE buttons selectable
    9. Make the back up
    10. At this point you have two files backed up, the original and the newer one with and without time date
    11. Repeats steps for the next file path, basically two backups are made, one with and without time/date
    12. I suggest end up with your main file until the time date are are again selectable

    I agree you'll have multiple backups but in different paths with the Quicken time/date and the other with the Windows time/date. I'm sure EVENTUALLY QKN "SW Development" will fix it ? ? ? ?
  • ringo11
    ringo11 Member ✭✭✭
    Lost ability to add date to backup file --- Got a cheap-seats work-around.
    On my quicken version the time stamp check box is not greyed out initially. (after a Ctrl+B).
    Grey-out occurs should I move to a different target drive.

    Before changing target drive check "Add date to backup file name" , highlight & copy correctly stamped file name - change to target drive paste file name into field. Click save backup.

    Almost good as new.
  • Gamma50
    Gamma50 Member
    Time to fix this Quicken. It is a big hassle
  • Ps56k2
    Ps56k2 SuperUser ✭✭✭✭✭
    Is this a R41.10 issue or a new R41.19 issue ?

    QWin Deluxe Subscription - sticking with R47.15 - Win10

  • yetanotherdave
    yetanotherdave Member ✭✭
    First encountered on R41.10
    > @yetanotherdave said:
    > After installing the current Quicken update, when I attempt to change the backup directory location, the "Add date to back filename" option is "grayed out", unselectable.

    Just installed R41.19, the problem remains, although it mangles the intended filename in new ways.

    In the "good old days" it worked well enough, but now I have to pay an annual fee to get forced installs of new bugs with no rollback method. It's surprisingly easy to turn a 30+ year customer into a dissatisfied whiner. ;-)
  • toby0901
    toby0901 Member
    This error has existed in the last three revisions. When is it going to be fixed??? I'm tired of using the workaround to get my files backed up by date.
  • jollymon
    jollymon Member ✭✭
    Having the same issues as others above. Sometimes, I don't want the "time" option in the filename (just the date), but Quicken does not give me the ability to only select the "date". The date option is dimmed out so I have to have both. There are also times when both the date and the time options are dimmed out so I cannot select either. It all appears to be at random. Please fix or just go back to the old way. Any fixes?
  • Denny43
    Denny43 Member ✭✭
    I'm having the same issue and hope that it is resolved soon. If I backup with no date and then go back in and back it up again, the date box is available. I just have to always back it up twice rather than the good old days of doing it once. I back up to 3 devices to it's a bit of a hassle.
  • thecreator
    thecreator SuperUser ✭✭✭✭✭
    Hi All,

    I can't see the problem. I am storing the Manual Backups to Z:\Quicken Backup and created a new folder: Z:\quicken Backup Test\.

    I had the used of adding Date to Manual Backups, without a problem.

    I would suggest that you post your destination and describe the location of your destination folders.
    thecreator - User of Quicken Subscription R46.12 (HF1)  USA & Quicken 2017 HBRP R20.6 USA
                       Windows 10 Pro 32-Bit Build 19045.2486                  
                       Windows 10 Pro 64-Bit Build 19045.2486 Release Preview Channel. Lost Win 11.
                      also  Windows 10 Pro 64-Bit Build 19045.2526 .
    View: https://community.quicken.com/discussion/7859218/work-with-copies-of-your-actual-quicken-data-files/p1?new=1

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    @thecreator try this sequence.

    Deselect "Add date to backup file name".
    Select Change... and browse to a different location.
    The "Add date to backup file name" is now disabled and can't be selected, until you restart Quicken.
    This is one sequence that doesn't work right on R41.19.  There might others.

    Note that on R41.9 there were different sequences causing problems, and I almost said it was fixed until I tried a few more sequences.  Looking back, I see that part of the needed sequence is to have multiple locations on the file pulldown menu:

    I personally don't use Quicken's backup, but I did test when this first was pointed out (R41.9) and when R41.19 came out.
    This is my website: http://www.quicknperlwiz.com/
  • funderbj
    funderbj Member
    The option to add the date is grayed out when I go to save a backup. I am unaware that I changed anything. Did Quicken? How do I get the date option back? I can manually add it, but that is less than slick.
  • TTSguy
    TTSguy Member ✭✭✭✭
    edited July 2022
    Quicken [mess]ed it up with the last update. They're aware. Who knows if or when they'll get it fixed.
  • rjkray
    rjkray Member
    So, after the latest update, If you change the file location to use on the first save on a manual backup, it just saves the file without the date being available the first go around, but then when you do a second manual backup the date and time checkboxes are available and work as they should - except of course for having to do it twice. Still needs to be fixed!
This discussion has been closed.