RSUs broken in R44.27?

jasonwaltman Member ✭✭
edited November 2022 in Investing (Windows)
I have an account with RSU Grants that I created once the feature became available. I recently updated Quicken to R44.27.

I noticed today that I can no longer create a new RSU Grant. In the investment account, in the "Enter Transactions" dialog, I don't have an option for "RSU Grant" as a transaction type. Furthermore, if I click the "Record Vesting" button on one of my previously entered "RSU Vest" entries. I see an "Edit Investment Transactions" dialog for a split second, then it disappears. I can't record a vesting.

I tried reinstalling from scratch. The download from the Quicken website is pre-RSU so I have to install the update from within the application, but the re-installed and re-updated app is still broken for me.

Anyone else have this issue?


  • markus1957
    markus1957 SuperUser, Windows Beta Beta
    I suspect R44.27 is not so much an update as it is a rollback to prior code while they figure out what they broke.
  • QuickenNB
    QuickenNB Member
    Same issue with R44.27. "RSU Grant" is not a selection choice in the Enter Transactions drop down list.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited October 2022
    QuickenNB said:
    Same issue with R44.27. "RSU Grant" is not a selection choice in the Enter Transactions drop down list.
    What edition of Quicken are you running? According to this discussion, starting with R44.20 the new RSU support is limited to Premier and up.
    QWin Premier subscription
  • jasonwaltman
    jasonwaltman Member ✭✭
    @Jim_Harman I'm running Deluxe...and from the thread you posted, it would seem that maybe this is a Premier and up feature now.

    If true...this is a horrible bait and switch. When the RSU feature was released, it worked in Deluxe. I had a system for tracking RSUs and I manually re-entered years worth of data to fit the new paradigm. Now, a month later I'm told I need to upgrade to Premier to use the feature? No thank you.

    I'd be perfectly fine with this if it was a Premier feature when it was first released, but to switch it after a month is just plain wrong.
This discussion has been closed.