Transaction Report - Selected Categories Reset to include Hidden Categories

bkinva
bkinva Member ✭✭
edited January 15 in Reports (Windows)
Anyone seeing similar behavior?

1. I create a new Banking --> Transaction Report
2. Select Date Range: Custom Dates (current calendar year in this case, 1/1/22 - 12/31/22)
3. Click Customize. Click Categories. Click Clear All [Show Hidden Categories checkbox below list of Categories was checked as well], then select the ones I want to include (2 in this case) and click Show Report
4. Subtotal by Category
5. Report looks just like how I want it. Save report and close.
6. When I re-open the saved report, it appears as saved. However, when I go to Customize and look at the list of Categories, all Hidden Categories are selected as well. If I click OK without changing anything, the transactions included within those Categories now appear in the Report.

I tried re-applying only the Categories I wanted by going through the same process of Clear All / select / save, as well as by going through the list of Categories and de-selecting all the Hidden ones and re-saving, but I saw the same behavior when I re-opened the Saved Report in each case.

And in doing some more testing it appears I don't even need to Save it. Just creating the report and going back to the Customize --> Categories list will cause Hidden Categories to be auto-selected/added to the list.

Running R45.13
Tagged:

Comments

  • bkinva said:
    Anyone seeing similar behavior?

    1. I create a new Banking --> Transaction Report
    2. Select Date Range: Custom Dates (current calendar year in this case, 1/1/22 - 12/31/22)
    3. Click Customize. Click Categories. Click Clear All [Show Hidden Categories checkbox below list of Categories was checked as well], then select the ones I want to include (2 in this case) and click Show Report
    4. Subtotal by Category
    5. Report looks just like how I want it. Save report and close.
    6. When I re-open the saved report, it appears as saved. However, when I go to Customize and look at the list of Categories, all Hidden Categories are selected as well. If I click OK without changing anything, the transactions included within those Categories now appear in the Report.

    I tried re-applying only the Categories I wanted by going through the same process of Clear All / select / save, as well as by going through the list of Categories and de-selecting all the Hidden ones and re-saving, but I saw the same behavior when I re-opened the Saved Report in each case.

    And in doing some more testing it appears I don't even need to Save it. Just creating the report and going back to the Customize --> Categories list will cause Hidden Categories to be auto-selected/added to the list.

    Running R45.13
    Hello @bkinva,  

    Thank you for letting us know about this problem with Hidden Categories appearing inappropriately in Reports. I do apologize you are being affected by this issue. 

    If you haven't already, I recommend saving a backup by navigating to File > Copy or Backup File... in the upper menu at the top of the screen, then proceeding through the instructions provided below:
    1. Navigate to File
    2. Select Validate and Repair File...
    3. Select Validate File
    4. Click OK
    5. Close the Data Log
    6. Close Quicken (leave it closed for at least 5 secs)
    7. Reopen Quicken and see if the issue persists. 

    If you are still noticing difficulties after you have attempted those recommendations, you may try the following: 

      • Navigate to File
      • Hold CTRL + Shift and click Validate and Repair File...
      • Select Super Validate File
      • Click OK
      • Close the Data Log
      • Close Quicken (leave it closed for at least 5 secs)
      • Reopen Quicken and see if the issue persists.
    Let us know about your results, if you get the chance to check back in with us. 

    Thank you,

    Quicken Jared 
This discussion has been closed.