Why are Categories with (parentheses) in Report selection included automatically? [edited]

PhilipJD
PhilipJD Member ✭✭
edited January 11 in Reports (Windows)
This is a combination question re Categories and Reports. When opening a Report previously saved, it has Categories marked to include which were not originally selected. I uncheck them, save the report, open the report again, and the same un-needed categories are checked again. This happens over and over. I noticed that it occurs with Categories that have parentheses around them (in the Categories List for Reports - Not in the main Category List). Most of them are investment categories which Quicken puts in the Category List when Investment accounts are created (start with an underscore). But it also includes a user created subcategory. Why the parentheses; and Why remarking themselves all by themselves? Obviously, skews the Report. Not good. Any ideas.

Answers

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Are you talking about parentheses or square brackets?  Square brackets around an account name in the category field means that it is a transfer to that account.
    Signature:
    This is my website: http://www.quicknperlwiz.com/
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    and (parentheses) means the Category is hidden.
    QWin Premier subscription
  • UKR
    UKR SuperUser ✭✭✭✭✭
    and (parentheses) means the Category is hidden.
    Wow! I never knew about that, despite having been around Quicken for many years!
    Goes to show how often I use report customization functions ...
    You have to look really close to see the "(" in front of the category names in the red boxes.
    Thanks, Jim, for pointing that out.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    There was a problem recently where some of the default investing reports did not include important but hidden Categories such as _RlzdGain.

    It look like there is still a problem in R45.13 with the Investment Income report. If I de-select _RlzdGain and save then reopen the report, _RlzdGain is not included. But as soon as I click on the gear to customize the report, all the hidden Categories, including _RlzdGain and Categories I have hidden myself, are selected again. 

    This seems like a bug, perhaps introduced as a sledgehammer approach to fixing the original problem. I did not check, but this may affect other investing reports as well.
    QWin Premier subscription
  • NotACPA
    NotACPA SuperUser ✭✭✭✭✭
    "a problem in R45.13"?  OH MY, Such a surprise.
    Q user since DOS version 5
    Now running Quicken Windows Subscription, Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • Ps56k2
    Ps56k2 SuperUser ✭✭✭✭✭
    edited December 2022
    Jim_Harman said: and (parentheses) means the Category is hidden.
    Interesting learning.... I just brought up our R43.26 .... Tools --> Category List --> [x] bottom Show Hidden Categories
    and then scrolled/searched the list, and I had NONE that by default were "[x] Hide" -

    QWin Deluxe Subscription - Win10
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    In a new file that has at least one investing account, if you go to the Category list, you should see that all of the Investing income categories that begin with _underscores are hidden by default. The hidden categories do not have parens in the Category list, only in the report customization dropdown.
    QWin Premier subscription
  • Ps56k2
    Ps56k2 SuperUser ✭✭✭✭✭
    Jim_Harman said: In a new file that has at least one investing account, if you go to the Category list, you should see that all of the Investing income categories that begin with _underscores are hidden by default.
    Interesting... in my Test File - they are hidden.... but in my normal file - they are not -


    QWin Deluxe Subscription - Win10
  • PhilipJD
    PhilipJD Member ✭✭
    I composed my question badly. And Jim Harman's 8Dec post about _RlzdGain is getting to the problem that I intended to address. However, like one other user, I learned stuff about Hidden Categories that I hadn't previously known, so there was some benefit to my mistake. The problem: 1. Create a Report checking certain categories. 2. Save it. 3. Reopen it, and click on Customization, and categories are now checked that wer NOT checked when originally creating the report. 4. Uncheck the unwanted categories and save it again. 5. Reopen the report. 6. The unwanted categories are now checked again as included in the report. 7. Some mysterious goblin is checking the unwanted categories after you have saved it without those categories. The reason I referenced HIDDEN categories in my first post is that the goblin is rechecking ALL, but ONLY, categories that are HIDDEN (and have the parentheses around them in the drop down categories list when creating/modifying Reports). And all those Investment Categories that start with an underscore - that are listed by Quicken itself when an Investment account is created - are HIDDEN at the outset. So goblin checks them, no matter what your report is all about. And my experience is with reports that I have created that have nothing to do with investments, so the mysterious activity is happening in more than the program included default investment reports that Quicken includes. Sorry about the long post.
  • PhilipJD
    PhilipJD Member ✭✭
    I forgot to add. This glitch was happening to me prior to my recent update to Ver. 45.13.
  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭✭
    PhilipJD said:
    I composed my question badly. And Jim Harman's 8Dec post about _RlzdGain is getting to the problem that I intended to address. However, like one other user, I learned stuff about Hidden Categories that I hadn't previously known, so there was some benefit to my mistake. The problem: 1. Create a Report checking certain categories. 2. Save it. 3. Reopen it, and click on Customization, and categories are now checked that wer NOT checked when originally creating the report. 4. Uncheck the unwanted categories and save it again. 5. Reopen the report. 6. The unwanted categories are now checked again as included in the report. 7. Some mysterious goblin is checking the unwanted categories after you have saved it without those categories. The reason I referenced HIDDEN categories in my first post is that the goblin is rechecking ALL, but ONLY, categories that are HIDDEN (and have the parentheses around them in the drop down categories list when creating/modifying Reports). And all those Investment Categories that start with an underscore - that are listed by Quicken itself when an Investment account is created - are HIDDEN at the outset. So goblin checks them, no matter what your report is all about. And my experience is with reports that I have created that have nothing to do with investments, so the mysterious activity is happening in more than the program included default investment reports that Quicken includes. Sorry about the long post.
    So customizing a Saved report and then saving it, again, does not save the new customization.  Did I get this right?

    I had an issue like that last summer after updating to R42.21.  I ended up deleting my Saved Reports and then pulling up new Standard Reports, customizing those and then saving them.  That resolved the issue for me.  Maybe it would resolve the issue for you, as well?
    (QW Premier Subscription: R44.20 on Windows 11)
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited December 2022
    @Boatnmaniac

    I edited the title to make it clearer.

    This problem also affects newly created customized reports that use selected Categories, even if you do not save them. Steps to reproduce:

    1. Go to Tools > Category list, check Show hidden categories, and mark a Category that has some income or  spending as Hidden. The investing income categories are hidden by default.
    2. Open the Spending by Category report (or I think any report that allows Category selection)
    3. Click the gear to customize and select the Categories tab. The Show hidden Categories box is selected by default.
    4. Select "Include only transactions with selected categories"
    5. Click on Clear All, observe that all the Categories ar un-selected.
    6. Select an unhidden Category that has some spending. This is what you would do if you want a report that shows just that one Category.
    7. Click OK. As expected, the report shows just the one Category
    8. Click the gear to customize again and select the Categories tab. OBSERVE THAT ALL THE HIDDEN CATEGORIES ARE NOW SELECTED.
    9. Click OK.  
    OBSERVE THAT THE REPORT NOW INCLUDES INCOME AND SPENDING FROM ALL THE HIDDEN CATEGORIES. To exclude the hidden Categories, you must explicitly de-select them.

    Update: If you add a Step 3a to un-check the Show hidden Categories box, the hidden Categories are not automatically selected.
    QWin Premier subscription
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    @PhilipJD

    In your saved report, try de-selecting the hidden Categories and then un-checking the Show (hidden Categories) box. Does that prevent the hidden Categories from being included the next time you customize the report?
    QWin Premier subscription
  • JimJ
    JimJ Member ✭✭
    thanks to both of you. I think I got it fixed. Instead of revising my existing report I started it from scratch. so far I am able to make changes to categories without unwanted Income Cat's coming in.
  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭✭
    edited December 2022
    @Boatnmaniac

    I edited the title to make it clearer.

    This problem also affects newly created customized reports that use selected Categories, even if you do not save them. Steps to reproduce:

    1. Go to Tools > Category list, check Show hidden categories, and mark a Category that has some income or  spending as Hidden. The investing income categories are hidden by default.
    2. Open the Spending by Category report (or I think any report that allows Category selection)
    3. Click the gear to customize and select the Categories tab. The Show hidden Categories box is selected by default.
    4. Select "Include only transactions with selected categories"
    5. Click on Clear All, observe that all the Categories ar un-selected.
    6. Select an unhidden Category that has some spending. This is what you would do if you want a report that shows just that one Category.
    7. Click OK. As expected, the report shows just the one Category
    8. Click the gear to customize again and select the Categories tab. OBSERVE THAT ALL THE HIDDEN CATEGORIES ARE NOW SELECTED.
    9. Click OK.  
    OBSERVE THAT THE REPORT NOW INCLUDES INCOME AND SPENDING FROM ALL THE HIDDEN CATEGORIES. To exclude the hidden Categories, you must explicitly de-select them.

    Update: If you add a Step 3a to un-check the Show hidden Categories box, the hidden Categories are not automatically selected.
    I should have been more precise about the issue I was seeing last summer: 
    • When I opened my existing Saved Reports (after updating to R42.12) they returned some unexpected, odd results.  
    • What I remember is that some of my customizations had been changed but I don't remember exactly what was changed.  
    • What I do clearly remember is that further customization of my Saved Reports would not retain that additional customization by saving the report.  When I would later reopen the Saved Reports, all the new customizations were missing and I got the same unexpected, odd results that I did earlier.
    • The only thing that fixed the problem for me was to pull new Standard Reports, customize them and save them.  The old Saved Reports were either deleted or overwritten by the new ones.
    This issue affected all of my Saved Reports, not just one or two.  All of them needed to be replaced with new reports.

    I don't recall if the box for Show Hidden Categories was checked or not but that, in my mind, was not the main issue.  The main issue is that the old Saved Reports had somehow become corrupted and would not save new customizations.  

    The only way I was able to resolve the issue was to start from scratch with new Standard Reports, customize them and then save them.  The old Saved Reports were either deleted or overwritten by the new ones.  Then everything with the Saved Reports worked correctly going forward. 

    It sounds like @JimJ took the same path as I did to resolve his issue.  I'm glad it worked for him.  Perhaps it will also work for @PhilipJD .
    (QW Premier Subscription: R44.20 on Windows 11)
This discussion has been closed.