Download fails when the number of transactions is large

darius74
darius74 Member
edited January 18 in Investing (Windows)
I have a few actively managed investment accounts that occasionally generate a very large number of transactions in a few days. E.g., from time to time, I'll have about 100-150 new transactions downloaded at a time. When this occurs, Quicken properly goes through the process of setting up new securities, and it lists the correct number of transactions in the downloaded transactions pane. However, when I click "accept all," the process breaks down. I end up with a tiny fraction of the downloaded transactions in my register -- e.g., Quicken will enter 10-15 out of 100. Quicken downloads my holdings properly, and then shows the holdings in Quicken as out of balance with its downloaded holdings, because about 90% or more of the transactions are missing.

This has happened to me about 5 times, so it is not a one-off occurrence. The only workaround I have found is to manually enter all the transactions. This is not a sustainable approach, and I am hoping there is a solution.

I am using Windows 11 Home, with the latest version of Quicken (R45.21). The prior version also had the same problem. I can't speak to earlier versions, because these managed accounts are relatively new.

Thanks

Comments

  • splasher
    splasher SuperUser ✭✭✭✭✭
    I don't have a cure/change in Quicken to fix the issue, but if you know it is going to happen, why do an "Accept All"?  Why shot yourself in the foot?  Clicking on the "Accept" button is NOT manually entering them, but if recovering from a botched "Accept All" requires a lot of manual entry, why would you ever push the "Accept All" button when there are a large number of downloaded transactions?
    -splasher  using Q continuously since 1996 -  Subscription Quicken  -  Win11
    -Questions? Check out the  Quicken Windows FAQ list
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser ✭✭✭✭✭
    You could bypass accepting the transactions by setting the preference
    Edit > Preferences > Downloaded transactions > Automatically add to investment transaction lists
    I don't know whether this takes the same code path as Accept All, but  might be worth a try to find out.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription (US) on Win10 Pro.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    The first thing I would say is that Quicken isn't geared to high volume trading, it will quickly slow down if there is a lot of investment transactions in a given register.

    On top of that I wouldn't recommend either Accept All or Automictically adding transactions to the register.

    There is a bit of a difference between the two, but I suspect the bugs that I know are in Automatically adding transactions might show up in Accept All too.

    The main difference between the two is that Accept All assumes that you have already checked all the transactions for being correct, and when they go into the register there will not be any status of what is new and what is old.  With Automatically adding transactions the new transactions will be marked as new in the status column.  The idea here is one is supposed to "review" them and mark them reviewed.  Nether mode is on supposes to blindly accept the download, especially not in an investment account.  Action coding problems from different financial institutions happen on a pretty regular basis.

    Anyways, I don't suggest the automatic transaction mode in investment accounts even though I do use it both there and in my non-investment accounts, because I know how to workaround the bugs in the investment accounts, but most might not.

    There are times where Quicken needs to prompt the user if a given investment transaction is correct.  It does that in the Downloaded Transactions tab.  If one is using the automatic transaction entry mode that "prompt" is hidden.  One has to know that the transaction is hung up in the Downloaded Transaction tab, and turn off the automatic transaction entry mode long enough to get that transaction into the register.

    I don't know if this has anything to do with Accept All missing transactions, but it might.  And more to the point anyone using Accept All is asking for trouble.  I would go to simple investment mode before I would ever do that.
    Signature:
    This is my website: http://www.quicknperlwiz.com/
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser ✭✭✭✭✭
    Chris_QPW said:
    The first thing I would say is that Quicken isn't geared to high volume trading
    I agree with this as the most important assertion in this thread.
    I had an actively-managed account once upon a time. The brokers traded virtually every day. I very quickly ended up with a lot of trades, a lot of securities, and a lot of lots.
    I hated it and called a halt to the active trading after a few months.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription (US) on Win10 Pro.
This discussion has been closed.