subcategory list showing a limited view to select from

I'm having a strange issue that is likely a bug.  I am trying to create a new category as a subcategory of an existing category.  In real life terms I purchased an ATV and want to track the insurance separate from auto insurance.  My issue is that when choosing the subcategory, it only gives me the beginning of the list (might be the first 42 items or so).  In other words, I cannot scroll enough to reach "Insurance" because it ends at the "B"'s.  Version R46.12 Build 27.1.46.12 on Windows 10. 

Comments

  • UKR
    UKR SuperUser ✭✭✭✭✭

    Sometimes a picture is worth a thousand words …
    Can you please capture one or more images of the parts of your Quicken window showing the issue, sensitive information blacked out as necessary to protect your privacy but annotated to describe the situation, and attach the image(s) here?
    How do I post a screenshot in the community from windows

    How do I post a screenshot in the community from a mac

    Please save images to files of file type PNG, JPG, or GIF only. They're easier to work with than PDF files.

  • Brian McDonald
    Brian McDonald Member ✭✭✭
    edited January 16
    :|This is the picture requested
  • UKR
    UKR SuperUser ✭✭✭✭✭
    That very much looks to me like a broken chain in your data file.
    My selection list (using R 46.12, too) scrolls through the entire list of income and then expense categories.

    If you haven't done so already, please do the following actions:

     

    Validate and Supervalidate instructions

    First save a backup file prior to performing these steps

    Validate: 

    1. Click File
    2. Select Validate and Repair File...
    3. Select Validate File
    4. If the data file contains investment accounts also select "Rebuild investing lots". If you suspect that a damaged Quotes Price History causes your problems, also select "Correct investing price history" functions "Delete" or "Repair and Rebuild".
    5. Click OK
    6. Close the Data Log
    7. Close Quicken (leave it closed for about 30 secs)
    8. Reopen Quicken and see if the issue persists.

    Super Validate:

    1. Click File
    2. Press and hold both CTRL and Shift keys while you click Validate and Repair File...
    3. Select Supervalidate File
    4. Click OK
    5. Close the Data Log
    6. Close Quicken (leave it closed for about 30 secs)
    7. Reopen Quicken and see if the issue persists.

  • Brian McDonald
    Brian McDonald Member ✭✭✭
    I've completed the mondo patch, applied current updates to said patch, closed Quicken, restarted Windows, did validation (no errors found), closed Quicken, did Super validation (no errors found), closed Quicken, tried to add a new subcategory and same results.  I'm currently hesitant to start loading older files.  I don't add subcategories often, so it could have been like this for some time.  I'll hold on for now and see if other users start reporting similar results.  Thanks for trying anyway.  I don't recall ever doing a super validate before, so I've at least learned something.    
  • UKR
    UKR SuperUser ✭✭✭✭✭
    Are you using "View / Use large Fonts"?
    If so, what happens when you turn that off, just for a test?
  • Brian McDonald
    Brian McDonald Member ✭✭✭
    I was not using large fonts.  Just for kicks I turned them on (no help), then tuned them off (same result). 
  • UKR
    UKR SuperUser ✭✭✭✭✭

    Font size problems? Display issues? (Windows)

    If you are using a version of Quicken at the Quicken 2019 US R 19.44 patch level or newer and you have previously made the following Compatibility change, please undo the change.
    Users of other Quicken versions please try the following:

    • Close Quicken !!! (This process won't work while Quicken is running!)
    • Check the Compatibility tab settings in your Quicken Desktop program icon:
    • In the Windows Start Menu right-click the Quicken icon. Select "Open File Location". This brings up a Windows File Explorer window. Right-click the highlighted Quicken shortcut line item.
      or
    • Go to the traditional Windows Desktop and right-click the Quicken program icon.
      or
    • Use Windows File Explorer, navigate to C:\Program Files (x86)\Quicken\ and right-click qw.exe
    • Now click Properties.
    • Select the Compatibility tab.
    • Uncheck all settings.
    • Windows 7, 8.1: Check "Disable display scaling on high DPI settings". 
      Windows 10, 11: Click "Change high DPI settings".  Check "Override high DPI scaling behavior. Scaling performed by:" and select "Application"  (also try the other available options repeating the entire procedure!). Click OK.
    • Be sure to uncheck the "Run this program in compatibility mode for [older Windows version]" setting.
    • Click the "Change settings for all users" button.
    • Click Apply and exit.
    • Reboot Windows.
    • Now start Quicken and see if that makes a difference.

    Some additional tuning suggestions:

    • Try this workaround for 4k monitors
      https://www.quicken.com/support/work-around-display-issues-high-resolution-monitors
    • System requirements: 1024x768 or higher screen resolution, 1280x1024 minimum for Large Fonts settings
    • Unless absolutely required, try not to use "View / Use large fonts"
    • Try setting the bank account registers to use a different font style or size: go to Edit / Preferences / Register, click the Fonts button and try different fonts.
    • Try adjusting the bank account registers' row height: go to Edit / Preferences / Register, choose among the available Row Height choices: Compact, Comfortable or Standard
    • If all else fails, try changing Windows Control Panel / Display options for "Make text and other items … smaller or larger" to use a different scaling level, but try not to exceed 125%
    • Try using the Windows Magnifier. Press the Windows logo key and the = key to open Magnifier. Customize Magnifier to increment Zoom in 25% intervals.
  • Brian McDonald
    Brian McDonald Member ✭✭✭
    Tried all steps and same issues with much harder to read (smaller interface).  My normal display is 3840 X 2160.  The only thing that seems to be malfunctioning is the scrolling on the subcategories addition.  I can add new categories just fine.  For now, I'll just add my new category as a standalone, not a subcategory.  
  • Brian McDonald
    Brian McDonald Member ✭✭✭
    I restored from a file on 1/8/2023 and the issue was not in that file.  I must have had 50+ transactions and updates to do to get caught up again, but I'm functional now.  I think that going back a week is the limit that I'd want to tackle again.  Thanks for trying UKR.  It definitely was something in the file.