Security Detail View Question.

Why do some Detail Views show the latest entry (which I prefer) and some views show the earliest entry ? Flipping the date indicator (^) has no effect. Anyway to remedy this or am I doomed to forever play with sidebar ? :/ Hoping this year is better for us investors !

Answers

  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭✭
    edited January 15
    (EDIT: It appears I might have misunderstood what the issue is.  When I first posted the response below I was thinking you were referring to how transactions are sorted in the Account Register.  I now see that you probably are referring to the Transaction History of Security Detail View and if so, disregard my comment below because it is not applicable to this.) 
    Go to Edit > Preferences > Registers.  Check the box for Remember register filters after Quicken closes if it is not already checked and then click on OK.
    Let me know whether or not this resolved the issue for you.
    Oh, yes, let's do hope that 2023 is much better for we investors!  :)
    (QW Premier Subscription: R44.20 on Windows 11)
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    Never seen that behavior in Security Detail Views. Any commonalities like security type?  Can you sort on another column and then get Date sorts to work right?
  • Gene619
    Gene619 Member ✭✭
    Maybe if I further elaborate on my dilemma : I use my Watch List as a quick reference to view my holdings as well as my watched potentials and past holdings. When I add actions such as buys,sells,divs etc., I can quickly reference my recorded actions on this screen.
    What I notice is that in the;Securities Details View-Transaction History some records read from earliest date recorded and some start at the latest entry made by me.
    I see nowhere on edit/preference options a way to make these recorded transactions be uniform,i.e. last transaction appearing first in this field. Thanks.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    Still not quite there, so I am reading between the lines. (My fill-ins putting words in your mouth bolded and underlined.  Correct me if I am wrong.)
    Gene619 said:
    Maybe if I further elaborate on my dilemma : I use my Watch List (in a portfolio view) as a quick reference to view my holdings as well as my watched potentials and past holdings. When I add actions such as buys,sells,divs etc., (in accounts) I can quickly reference my recorded actions on this (Watch list view) screen.
    (From this Watch List view, I go to specific security information.)
    What I notice is that in the Securities Details View-Transaction History some records read from earliest date recorded and some start at the latest entry made by me.
    I see nowhere on edit/preference options a way to make these recorded transactions be uniform,i.e. last transaction appearing first in this field. Thanks.
    When I open a Security Detail view for any security, the upper section of transactions are listed in whatever sort order was last used.  Date, Account, Action, etc.  and from top to bottom or bottom to top depending on which way the little arrow is pointing.  If I switch to a different security, the sort from the prior security carries over.  There is no preference setting and that should be normal behavior.  

    You are saying you are not seeing this behavior, clicking on the header does not change the field used for the sort.  Clicking a second time does not reverse the sort order.  As far as I can tell, your installed program is misbehaving.

    Has it always been this way, or is this recent new behavior?
    What program release are you running?
    If you have a second file or create a new file simply for a test case, does this other file behave the same way or the correct way?  That should indicate if it is a data file issue or a program installation issue or maybe somehow a program release issue (no one else has reported that type of behavior as far as I have seen on this site).

    The path from there depends on where those answers lead us.
  • Gene619
    Gene619 Member ✭✭
    I've been using Q Premier for years and this dilemma has existed since I can remember. When you enter data in the ledger,its always dated accordingly but when I view these entries some are dated from the oldest to the newest and some are from the newest to the oldest. I haven't seen any Quicken fixes for this,maybe I'm the only person noticing it. I will continue using Quicken ,it is still my favorite financial records program. Maybe someone in the community has had this problem and found a solution.
    Thanks to all who replied.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    You can reverse the date order by clicking on the Date column header
    QWin Premier subscription
  • Gene619
    Gene619 Member ✭✭
    Happy New Year Jim !
    I've tried that, it only changes the direction of the mouse roll (up or down). It does not go from first date entered to last or visa-versa.., thanks.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    Is this the section of the Security Detail View we are talking about?

       
    And clicking the blue triangle (highlighted) next to Date doesn't change the order of the listed transactions as

      
    Or similarly clicking headers other than Date (Account, Action, etc.) doesn't change the presentation?

    As previously asked, what version of Quicken for Windows are you running?  See Help / About Quicken.

    Are you running this on a Windows PC?  Because click on those headers should not have anything to do with "mouse roll (up or down)".