Investment button greyed out when trying to create New Scheduled Transaction Group

Quicken used to limit users to 12 investment transaction groups and I was using all of them. I recently deleted a couple groups. I expected that I would be able to use those group numbers to create new scheduled investment transactions.

I find no way to do that using the instructions provided by Quicken help and a couple discussions in this community. I'm running R48.15 Build: 27.1.48.15 on Windows 10.

I tried using Bill & Income Reminders, Add, Scheduled Transaction Group but the radio button next to "Investment" is greyed out and not selectable. I seem to remember a way around this, perhaps via the Memorized Investment Transaction view, but that was a long time ago and it doesn't work with today's Quicken.

Ideas that lead to resolution are appreciated.

Comments

  • Quicken Kristina
    Quicken Kristina Moderator mod

    Hello @cyclist65,

    Thank you for reaching out to the Community and telling us about this issue.  I'm sorry to hear you're running into this problem. Once you are in the New Scheduled Transaction group screen, are you selecting your investment account in the account dropdown? If the account is shows is not an investment account, it is normal for it to be greyed out (see sample image below).

    Once you choose the investment account, then the option should be available (see sample image below).

    Thank you.

    Quicken Kristina

  • cyclist65
    cyclist65 Member

    Thank you for pointing this out Kristina.

    Now I suspect why I did not notice this behavior before. The investment account that I'm trying to create a new scheduled transaction for is not in the drop-down list. In fact, a number of my investment accounts are not shown in the drop-down now that I look closely.

    These same accounts are displayed in the main "Accounts" list and "work" fine for creating transactions, retrieving quotes, etc. I looked at the settings of an investment account that is not shown in the drop-down and one that is shown in the drop-down and cannot see any difference, though that doesn't mean I'm not overlooking something.

    Help is appreciated,

    Paul

  • Quicken Kristina
    Quicken Kristina Moderator mod

    Thank you for your reply,

    Are the accounts that aren't showing up in the dropdown hidden accounts? You can check that by going to Tools>Manage Hidden Accounts. If they are hidden, you may need to unhide the accounts and check to see if they now show up in the dropdown.

    Thank you.

    Quicken Kristina

  • cyclist65
    cyclist65 Member

    Hello Quicken Kristina,

    No, the investment accounts failing to show in the new scheduled transaction group list are not hidden accounts.

    Paul

  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭

    Paul, in my transaction group edit screen, I can see investment accounts that are set to be hidden in the Account Bar and Account List. But the accounts that are marked "" are not shown.

    Are the missing accounts set to Keep This Account Separate? The easiest place to see all these account display settings is Tools | Manage Hidden Accounts.

    The only other variable I can think of is if the accounts are set to Simple investing.

    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the Quicken Windows FAQ list

  • cyclist65
    cyclist65 Member

    Hello mshiggins,

    I had a nice long comment describing a series of experiments I ran to debug the situation. When I selected Post Comment, it went into the bit bucket.

    So, here's the short version.

    If my investment account has "Single mutual fund account = yes", then that investment account is NOT in the list of accounts presented when using the new scheduled transaction group task. If my investment account has "Single mutual fund account = no", then that investment account IS in the list of accounts when using the new scheduled transaction group task.

    Sounds like a defect to me…

    Cheers,

    Paul

  • cyclist65
    cyclist65 Member

    Hello mshiggins and Quickent Kristina,

    I'll walk through some experiments I did, but skip to the bottom of this entry to see how I debugged what is happening.

    Under Manage Hidden Accounts, there are three columns besides the account columm and the close account column, Hide in account bar and account list, Hide in transaction entry lists, Keep this account separate. For the investment accounts that do not show up when using new scheduled transaction group, none of them have any of those three columns checked.

    Also, for the investment accounts that do not show up when using new scheduled transaction group, they are all defined with Tracking Method - Complete: Positions and Transactions.

    I did an experiment.

    I selected an investment account that did appear in the list and then chose a memorized investment transaction for the security that I is associated with the account that does not appear in the list. I saved that scheduled transaction group. I then proceded to enter that transaction. When Quicken presents the Enter Expense Transaction dialog, there is an Account field that can be scrolled through. Sure enough, the investment account that doesn't show up in the new scheduled transaction group dialog, does show up in this dialog. I chose that investment account and the transaction was indeed entered into the desired investment account.

    I did some more experiments and have figured out what's happening.

    If the investment account has "Single mutual fund account" = yes, it does NOT show up in the account list when using new scheduled transaction group. If the investment account has "Single mutual fund account" = no, then the account does show up in the account list when using new scheduled transaction group.

    Sounds like a program defect to me…😉

    Cheers,

    Paul

  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭

    Paul, good work on determine the cause of the account not appearing in the Scheduled Transaction Group account list. I can confirm the same behavior in QW2017. I am not sure if it is a defect or intentional, but this sort of inflexibility is the reason I don't use single mutual fund accounts anymore.

    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the Quicken Windows FAQ list

  • cyclist65
    cyclist65 Member

    Thank you for confirming the behavior is consistent with other Quicken version mshiggins.

    Issue resolved, now I just need to not forget this experience two years from now when I try to do this again…🙂

This discussion has been closed.