Why does Quicken now auto-enter (wrongly) scheduled transactions when they match downloaded ones.

Neil W
Neil W Member ✭✭

It used to be that downloaded transactions were matched only to transactions that had been entered into the register; scheduled transactions had to be entered into the register. I am not sure when it started, but now if a downloaded transaction matches a scheduled transaction, Quicken adds a corresponding transaction into the register and deletes that instance from the scheduled transaction list. Worse, the added transaction in the register does not completely match the scheduled transaction (missing memo, additional zero fields in paychecks). So then I have to delete the created transaction from the register, reset the date in the scheduled transaction, enter the correct transaction into the register from the scheduled list and manually check the cleared button on the corrected transaction.

Answers

  • Quicken Kristina
    Quicken Kristina Moderator mod

    Hello @Neil W,

    Thank you for reaching out to the Community and telling us about this issue.  I'm sorry to hear you're running into this problem. When did the issue start happening?  Was there anything that happened just before the issue started, such as a power surge, power outage, update, unexpected program or computer shutdown, etc?  Do you keep your Quicken file on your C drive or is it on a shared network drive?  Is your Quicken file synced with any cloud service, such as One Drive or Dropbox (if it is, you will usually see the service name listed in the file location)? 

    The simplest way to check your file location, if you have Quicken up and the file open, is to click on File, then look near the bottom of the list, just above where it says Exit.  It will list the file locations for the 4 Quicken files you have most recently accessed, with the one you are currently in at the #1 spot.

    Thank you.

    Quicken Kristina

    Make sure to sign up for the email digest to see a round up of your top posts.

  • Neil W
    Neil W Member ✭✭
    Thank you for responding.

    I am using Quicken version R49.29, Build 27.1.49.29 on Windows 11 Home. The data file is located on my local drive in Quicken's default location, which on Windows 11 means it is backed up to OneDrive. I can't pin down when it started, because I usually enter scheduled transactions into the register a few days before the transaction; this avoids the problem so I only saw it occasionally and didn't think much about it. I was recently away for two weeks and downloaded transactions before entering the scheduled ones into the register and this behavior became clear.

    I don't see how the backup/sync of the data might pertain to this activity. As a personal preference, whenever possible, I turn off any feature that provides automatic data entry without me being given the opportunity to review and deny/accept the entry. This current automatic behavior seems to be a feature/bug of the Quicken program.
  • Quicken Kristina
    Quicken Kristina Moderator mod

    Thank you for your reply,

    I ask about file location because having the file synced with a cloud service or on a shared drive can result in unwanted behaviors. You can read this article for more information.

    You said you prefer to review your transactions before they go into the register. Do you have automatic entry turned off, so that transactions go into a section below the register for you to review before accepting? To check, go to Edit>Preferences>Downloaded transactions. If "Automatically add to banking registers" has a check mark by it, then automatic entry is on.

    Thank you.

    Quicken Kristina

    Make sure to sign up for the email digest to see a round up of your top posts.

  • Neil W
    Neil W Member ✭✭
    Thank you for your response.
    1. I understand the conflicts/issues that can occur with file sharing. My data file resides on, and is accessed only on, my laptop computer. OneDrive acts only to backup the file when Quicken is closed.
    2. The checkbox for "Automatically add to banking registers" is OFF (not checked).
  • Quicken Kristina
    Quicken Kristina Moderator mod

    Thank you for your reply,

    To check for file specific issues, I suggest that you try validating and/or super validating your data file. Please save a backup file prior to performing these steps.

    Validate: 

    1. File
    2. Validate and Repair File...
    3. Validate File
    4. Click OK
    5. Close the Data Log
    6. Close Quicken (leave it closed for at least 5 secs)
    7. Reopen Quicken and see if the issue persists.

    If the issue persists, proceed to Super Validate. If the issue is resolved after performing validation, then please disregard the instructions to Super Validate.

    Super Validate:

    1. File
    2. Hold CTRL + Shift and click Validate and Repair File...
    3. Super Validate File
    4. Click OK
    5. Close the Data Log
    6. Close Quicken (leave it closed for at least 5 secs)
    7. Reopen Quicken and see if the issue persists.

    Thank you.

    Quicken Kristina

    Make sure to sign up for the email digest to see a round up of your top posts.

  • Neil W
    Neil W Member ✭✭
    I am very confused about your approach. This not a file specific issue. My question/issue is about function of the Quicken code, not a failure in the data file. If there is a flag in the data file that could trigger this automatic data entry, I would like to know how to turn it off.

    Nevertheless, I will follow your instructions (I use Validate File with some frequency, but did not know about Super Validate), but cannot "see if the issue persists" until the next time I download a bank/cc transaction that meets the specific conditions; that does not happen very often (less than monthly). I will have to contrive a test that doesn't cause other problems.
  • UKR
    UKR SuperUser ✭✭✭✭✭

    Where are the "Auto-accept downloaded transaction" settings?

    There are two places where this is controlled in Quicken for Windows:
    - Globally, for all accounts, in Edit / Preferences / Downloaded Transactions
    - For each account individually, the global setting can be overridden from the Edit Account Details screen, Online Services Tab. Look for blue text "Automatic Entry is: ON / OFF". Click the text to change the setting.

This discussion has been closed.