Problem with Investment Income Report

Options
GoChill
GoChill Member ✭✭
edited October 2023 in Reports (Windows)

I am having a problem with the Investment Income report crashing. I am currently running Version 52.20 Build 27.1.52.20 on Windows 11.

Here is a screenshot:

Pure gibberish, scoll bars don't work etc.

If I select a shorter time frame like "last week" instead of "year to date" or "quarter to date" it will work. Alternatively if I select fewer securities to include in the report it works fine. It seems like if I select fewer than about 55 securities it works.

A few versions of Quicken ago I could select all securities and any time frame including "earliest to date" and the report would work fine.

I tried calling support and it didn't go terribly well. I got disconnected from the first agent and the 2nd really didn't understand the problem

We tried:

Validate Repair the data file

Disconnect and reconnect my financial institutions. (Silly)

Use the categories report instead (That works but of course provides completely different information - so not at all helpful)

Finally, he suggested waiting 24 hours and it should start working (Uh no).

I figured maybe the next update would fix it but today I updated to 52.20 and I still have the problem.

Currently, I am working around the problem by creating 2 new reports 1 with my securities from A-M and another with securities from N-Z which is working but it would be nice to have this all in 1 report like it used to be so I could get a total dividend income for the quarter or year.

Is anyone else having this problem or able to replicate the issue?

It feels like a memory allocation error to me since it works with shorter time frames and fewer securities.

Comments

  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    Options

    What version introduced that report? I'm on 50.14 and can't seem to duplicate it, and a quick run-through of release notes from 50.14 to now doesn't seem to mention a newly introduced report

    For me the report reached by clicking on Reports > Investing > Investment by Security looks like this:

    with a pie chart and no ability to Subtotal by: Security.

    If i select Reports > Investing > Investment Income I get:

    with no graph available.

    So I'm not sure what Quicken Report you're starting with or how it's been customized. I do wonder why a Discovery Credit Card is being shown in a security income report. The only other thing I can think of off hand is that if this is a saved report then updates have, sometimes, been known to hose saved reports. In this case sometimes changing some further customization will fix the report, (and the new customization can be undone), sometimes starting from scratch with the original report will work.

  • GoChill
    GoChill Member ✭✭
    Options

    Tom, Thanks for taking the time to reply. I don't know what version the problem began with I wish I knew. I run the report fairly frequently always at quarter end so I would say it started in the last 90 days. I first noticed it with whatever version came immediately before 52.20 but it might have started one or two updates before that.

    The report is the investment income report and there is no graph. It should look something like this:

    But notice that the date range I selected is only last week. When I select a quarter or longer I have problems. Sometimes it won't scroll all the way to the right, other times it just renders total garbage like the original screenshot I included. That Discover Credit Card and the graphic were on the home screen. The report window should have covered that up but the flawed rendering let pieces of the home screen show through into the report.

    Your idea of going back to the original report is a good one but I tried it to no avail. The only customization I have done is which securities I elect to show on the report. For example, I choose not to display stocks I sold years ago. I just show current holdings. I probably have about 60 securities in the report which is too many unless I select a very short time frame. This used to work fine, in the past I could select "All Securities" and a date range of "Earliest to Date" and it would run fine.

  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    Options

    @Tom Young

    Original report via

    @GoChill

    When I see reports of screen gibberish like that, I tend to be suspicious of graphical issues like using Large fonts or increased magnification. But I don't follow those issues closely enough to offer advice.

  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    Options

    Meant to add, I am seeing things fine with my R48.8 installation.

  • GoChill
    GoChill Member ✭✭
    Options

    I was just going add that I had an idea. I have an older Microsoft Surface computer with Quicken on it. I seldom use this computer any more but it has an older copy of Quicken on it. It has R36.48 Build 27.1.36.48 running Windows 10. I made a backup of my Quicken File and then restored it on this older computer. The report works absolutely fine!

    That proves the problem is not my data file. It is either my computer, unlikely in my opinion, or the version of Quicken. I think something definitely happened between version R36.48 and the version immediately before R52.20 whatever that was. I suspect the problem began much closer to R52.20.

  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    Options

    @q_lurker

    I thought it had to be the report that you highlighted, but the snip-it of that report I posted above looks nothing like what the OP posted and it is, in fact, the standard Investment Income report. The "graph" aspect of of the original post was throwing me off.

    @GoChill

    I can report that the Investment Income report looks fine on 50.14 too.

    The problem could also be a Windows 11 update. You could try reverting to see if that's the source of the problem.

  • GoChill
    GoChill Member ✭✭
    Options

    I can't revert from Windows 11. I could upgrade the version of Quicken on the old computer and watch that likely break the report. If I do that is there any way to revert back to older versions of Quicken?

    Also when you tested on 50.14 how much data did you use? In my case it breaks at around 54 selected securities and a sufficiently long time frame. I recommend testing with a Date Range of "Earliest to Date" and All securities selected. The report also needs to be subtotaled by Security. I can't get it to fail if I subtotal by something other than security. Even then if the securities number is not large enough I doubt you will see the problem.

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited September 2023
    Options

    I ran the Investment Income report for all securities (including hidden), subtotaled by security, earliest to date with my file, R52.20, Windows 11, and it is definitely weird.

    It is also broken in R51.12 under Windows 10

    This report has fixed width wide columns, one for each security, and if there are a lot of securities the horizontal scroll bar doesn't work. If I limit the number of securities it is OK. Also with all securities enabled the column headers have big black splotches that change as I scroll vertically.

    The report only includes columns for securities that have transactions in the selected date range, so limiting the date range will also limit the number of securities it is trying to display. For me it works until the date range includes transactions for more than about 60 securities.

    Another odd thing about this report is that by default it includes a lot of non-investment income Categories and seemingly all of my expense Categories. If I limit the Categories to just the investment income ones, it still breaks in the same way.

    QWin Premier subscription
  • GoChill
    GoChill Member ✭✭
    Options

    Thanks Jim. That sounds like what I have been experiencing. Sometimes at first glance it appears to have worked until I try to scroll horizontally to the right toward the totals. I have also seen the black splotches in the column headers. Other times when I run the report it just looks totally scrambled as in the screenshot from the original post.

    I'm sorry it's not working for you either but I am glad someone else can duplicate the problem.

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Options

    Note that this is the first time I have ever run this report so it is not a big deal for me if it is broken in this way.

    QWin Premier subscription
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Options

    Further observation: when subtotaling by month, it will do 4/1/02 - 12/31/22 or 250 columns total, as expected, but when subtotaling by security, it can only do about 60. Maybe the issue when subtotaling by security has to do with the total width of the report rather than the number of columns.

    QWin Premier subscription
  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    Options

    @GoChill

    "I can't revert from Windows 11. "

    I should have been clearer. I wasn't suggesting going to Windows 10, I was suggesting undoing some or all of the Windows 11 updates from around the time the problem began.

    "Also when you tested on 50.14 how much data did you use?"

    In the post above reporting that it worked OK it was with 44 securities. I just tried again using "all dates" which swept up over 100 securities and it still works fine. I scrolled right to the end of the list.

    @Jim_Harman

    "Another odd thing about this report is that by default it includes a lot of non-investment income Categories and seemingly all of my expense Categories."

    I too saw non-investment Categories showing up. They all were entered under the "Cash" security. Clicking through on a few of them they didn't occur in the Investment Account, though Quicken said they did.

  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    Options

    @Tom Young My error on that Income by security report mention. I was matching my screen shot to your screenshot for that report, rather than comparing to the OP's screenshot.

    @GoChill @Jim_Harman

    I am now seeing the gibberish and bad scroll bars for the Investment income report subtotaled with multiple columns while using R48.8. I see this as a GUI issue associated with 'lots' of columns.

    Specifically to the bottom scroll bar — I was testing subtotaled by Month. Over 250 pops up a warning the Quicken won't do that. Between 134 months and 250, the program claims to show the data, but the bottom scroll bar does not work. Clicking on a numerical field and arrowing to the right does not work either. Up to 133 months (134 columns including the Overall Total) appears to work fine.

    Testing subtotal by security, I was able to get 132 security columns + the Overall Total column with everything working. At some number higher, it breaks.

    Another observation — with a working set, I can widen or narrow the report window and everything follows. With a non-working scroll bar, widening and narrowing the report window starts creating blacked out portions and "gibberish".

  • GoChill
    GoChill Member ✭✭
    Options

    I sure appreciate all the comments. I think there might be something to the limit on columns. On 52.20 if I run my report for selected securities for the quarter or YTD it does not work. On R36.48 using the same data file ie data set with the same selections the report works fine. However, on R36.48 when I tried all dates all securities it appeared to run normally but when I tried to scroll horizontally it did not work and vertical scrolling produced the black blocks.

    I does appear to be somewhat column or data limited. However, if that is the case R36.48 definitely supported more columns than R52.20. It seems strange that they would reduce the columns supported in newer versions.

    It still seems to me like it's related to memory allocation. Perhaps added features to newer versions consume more memory therefore allowing fewer columns before an issue arises.

    Regardless something isn't right. I should be able to run the same report in R52.20 with the same data selected that works in R36.48. Additionally, if I have exceeded some limit with my selected data Quicken sure isn't handling it very gracefully. It should give me an error message rather than just displaying a malfunctioning report window.

    Hopefully in future versions of Quicken they can fix this. I'm currently trying to run the report with 75 securities selected which doesn't seem to excessive especially since R36.48 can handle it.

    Thanks again for everyone testing and sharing their results.

  • Phil
    Phil Member ✭✭✭
    edited September 2023
    Options

    @GoChill

    I have had the same problem for some time. In my case, I find that 72 securities is the limit. I have a total of 202 securities accumulated over the years. If I include more than 72 in my Investment income report, I see behavior similar to what you describe.

    The worst part is that only the first two securities appear in the "over 72" report. There is no ability to scroll horizontally. I do not include the graph, so the gibberish is more limited than yours.

    I'm not sure exactly when this started, but I would guess within the last year.

    This is obviously a Quicken problem and should be looked into by the right people at Quicken.

  • GoChill
    GoChill Member ✭✭
    Options

    @ Phil

    Thanks for sharing. I don't use the graph either, in the screenshot I believe that is show thru of a graph that was on the home screen under the report window.

    I wish someone from Quicken would comment on this, as near as I can tell no one from Quicken has even bothered to look at this thread. I wish I knew how to get it in front of the right people at Quicken - support clearly isn't the right place.

  • Phil
    Phil Member ✭✭✭
    Options

    I did use the Help> Report a Problem function in Quicken, describing the issue and including a link to this thread. Of course, they do not respond to the user from there.

This discussion has been closed.