BUG: Newly added Securities are not added to Portfolio views if Watch List box is un-checked

Options
Jim_Harman
Jim_Harman SuperUser ✭✭✭✭✭
edited October 2023 in Investing (Windows)

The note to the left of the Securities customization for Investing > Portfolio views says that newly added securities will be automatically added to the view, but this is not always the case.

If you add a new security via the Add Security button in the Security List and you leave the Watch list box checked, the Security's box gets checked automatically in the Portfolio view Security customization, as it should.

BUT if you un-check the Watch List box when adding the security, the security is NOT automatically added to the portfolio views and thus is not shown after buying the security.

This also applies if you un-check the Watch List box when adding the security via Enter Transactions/Bought. It may also occur when a new security is added during a transaction download; I was not able to test this.

A workaround, once you realize what has happened, is to click on Customize in each Portfolio view where you want the security to be included, select the Securities tab, and check its box.

This issue has confused several users and Quicken Support, for example see this discussion

This bug may have been introduced when the Watch List checkbox was added to the Add Security process in R34.13.

QWin Premier subscription

Comments

  • Ps56k2
    Ps56k2 SuperUser ✭✭✭✭✭
    Options

    interesting….. as we saw in the other discussion - and you think this has been going on since R34 -

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Options

    I don't have a version that old, but I have have seen several users whose new securities were not appearing in the Portfolio views. The fix was always to customize the view and check the security's box on the Security tab.

    Prior to R34, new securities were always added to the Watch list, so this issue would not have come up.

    QWin Premier subscription
This discussion has been closed.