Investment Accounts take too long to open and too long to update

rbienenfeld
rbienenfeld Windows Beta Beta
edited March 17 in Investing (Windows)

I have a few investment accounts. Just clicking from any account to an investment account, it takes a long time to transition. Then, if I have downloaded transactions, it takes a long time to accept the transactions. Very simple processes! I don't have problems with the downloads. But there is a significant delay in just opening investment accounts and updating the downloaded transactions. This has been going on for more than a year, and I keep hoping that a new release will significantly shorten the time.

Tagged:

Comments

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭

    Do you have an old, slow computer? How much memory does it have?

    How long is long?

    Go to Tools > Account list. How many transactions are in each of the investing accounts? If you don't see the number of transactions, click on Options at the bottom of the Account List and Select Show number of transactions.

    QWin Premier subscription
  • rbienenfeld
    rbienenfeld Windows Beta Beta

    Thanks for the quick response and suggestions!

    1. I have a pretty new computer with tons of memory.
    2. My bank accounts and credit card accounts open in ~1 seconds when I click on them, and some of them have +5,000 transacations.
    3. The investment accounts all take 5+ seconds to open when I click on them and their transactions range from ~25 to +1,000.
    4. The number of transactions seems to bear no relationship to how long it takes to open the investment accounts.
    5. If I download 10 transactions to my checking account and click "accept all" it takes only a second or two to update.
    6. Whether I have 1 or 10 transactions downloaded to an investment account it takes 6+ seconds to update, if I click "accept all." It is kind of irritating. On the date when my investment accounts post interest on the cash balances, I might have 7 accounts with one transaction each. +5 seconds to click to open the account, +5 seconds to update the transactions, it seems long and laborious. Click, read the newspaper, click, read the newspaper, lol.

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭

    Sorry, but the performance you are seeing is "normal" for Quicken. The investment account data is more complicated than the banking transactions and that is part of the problem, but also then GUI for investment account is pretty bad and it seems like Quicken is also doing on the fly calculations of the security lots. So, depending on how many securities/security lots you have, the performance goes down. The 5 seconds to open is never going to go below that, at least not for the first time you open it per session. The importing of the transactions also seems "OK" as long as you aren't talking say 15 or more per transaction. If it gets really high the only option is to see if you can archive the closed lots to another account.

    Signature:
    This is my website: http://www.quicknperlwiz.com/
  • rbienenfeld
    rbienenfeld Windows Beta Beta

    Thanks, Chris. Still, with all this processing power, disappointing.

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited February 17

    You might try these tips. Please let us know if any are effective for you.

    Does your computer have an SSD drive? If so, make sure your data file is on that drive.

    Also make sure your data file is not on in a folder managed by Microsoft OneDrive. Windows now tries to move your entire Documents folder to OneDrive, and Documents\Quicken is the default location for QDF files. To check, click on File and look at the path for the current data file, which will be the top entry in the list at the bottom of the menu. You don't want OneDrive in that path. Storing your data file elsewhere, in a folder under Downloads for example, may give you better performance, particularly when first opening the file. An alternative is to pause OneDrive before starting Quicken.

    Again, please let us know if any of this improves your performance.

    QWin Premier subscription
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭

    It is ironic that many the times that the people that have "real performance problems" have some of the newest/fastest machines. By "real performance problems" I'm talking something pretty much longer than "trivial". I suspect that it has to do with the fact that Quicken tends to find all the possible holes in the compatibility of things like the graphics drivers and such.

    During my career I person stayed as much as possible away from GUI development (system developer). Here is something that doesn't seem to have changed since back in Unix in the 80s. I can read a million records out of a data base in a blink of an eye. But if you put more than a thousand things in a GUI list each line of scrolling will be something like a 1/2 of a second. The only reason you can scroll quickly is because other than a very short list the programmer has to go to a "virtualized list". As in the "GUI list" is not much bigger than what can be seen. And as you scroll then shift the data in from either the database or some other "non GUI" RAM storage.

    A couple of additional statements on #5 you mentioned that Accept All takes a second or two to update. I hope that before you select that you made sure all the transactions were correct, or that you are just stating it as a "timing". Accept All is one of the worst things they have put in Quicken in my opinion. It allows a person to enter transactions without any kind of review, and once done you there isn't any indication of which transactions have been changed. If this is one's process to just hit Accept All they are MUCH better off using the preference to automatic enter the transactions into the register, because it will mark the transactions with New or New Match, and the person can mark them reviewed.

    Note I usually don't really recommend automatic transaction entry mode for investment accounts because of some bugs in it that they have never fixed. Basically, if there is any time Quicken needs to prompt, like say a "partial match" to an existing transaction, it will not do that prompting if you are in automatic transaction entry mode. If you aren't pre-entering anything though it usually is fine. If something like this happens (and you know because you either get a red flag or the blue dot doesn't go away) then you have to switch back to non automatic transaction entry mode, answer the prompts and such and then switch back.

    But given #6 complaint, you might just want to try it. At least when you go to open the investment account the transactions will already be in the register. You just have to decide if you want to mark them reviewed or not. Personally, in both banking accounts and investment accounts what I do is visually look at them to make sure they are correct and then do a reconcile which will mark them reviewed.

    I the case of investment account so that I make sure that I have the shares right I have these action buttons setup.

    So, after looking at the transactions and seeing that they look right, I select Reconcile Shares.. This is the compare between Quicken and "summary information" downloaded with the transactions. If that matched (never accept a placeholder) then I go on to Update cash balance.. I'm not doing this to actually update the cash balance, what I'm doing is it will give me the current cash balance as downloaded from the financial institution and what Quicken has. Provided that is OK, I copy the new cash balance from there. Next, I hit reconcile and then paste in the new balance and finish the reconcile.

    Signature:
    This is my website: http://www.quicknperlwiz.com/
This discussion has been closed.