Unknown Error Popup after Help-->Check for updates


Hello, I am running Quicken Classic for Windows R55.26 on Windows 10 with Window Update indicating I am up to date. In the Help menu, Download latest version no longer appears, and Check for updates has always given me a popup error

I read another community post and followed the recommended procedure to uninstall, delete the Quicken folder in Program Files (x86), and reinstall, followed by a reboot of my computer. I can start Quicken and access my data, however, Help—>Check for updates still gives this popup error.


  • Quicken Jasmine
    Quicken Jasmine Moderator mod

    Hello @maestrovt,

    Are you running Quicken using ethernet or wifi? Do you use an antivirus or any malware program? Could you explain why you are checking for updates?


    -Quicken Jasmine

    Make sure to sign up for the email digest to see a round-up of your top posts.

  • maestrovt
    maestrovt Member ✭✭

    Hi, over ethernet. No antivirus or malware other than what is included in Windows 10. I am checking for updates to make sure I am running the latest version.

  • UKR
    UKR SuperUser ✭✭✭✭✭

    Unless we can get a programmer to tell us exactly what triggers this "catch-all" error popup and how to go about troubleshooting it, here are a few "shots fired into the dark, listening for an 'Ouch!'":

    • Your browser must allow popups from https://www.quicken.com for chat/phone support selections to function.
    • To make sure that Quicken is allowed to update and save its configuration files please check if Windows Defender Controlled Folder Access feature Ransomware protection is enabled.
    If it is, configure it to add Quicken as an "allowed app" without turning off Ransomware protection. Perform the last step in https://community.quicken.com/discussion/7857675/faq-windows-defender-controlled-folder-access
    • Have you recently enabled a VPN?
    If so, this might be the problem. Try turning the VPN off, reboot with VPN disabled and see if that helps.
    • Is there a corporate or otherwise external firewall getting in the way? Contact the IT people maintaining the firewall and ask for permission.
    • If you're running Quicken and Windows under a VM, ensure that the VM does not block any incoming or outgoing IP ports.
    • Does your Antivirus software allow Quicken to connect to the Internet?
    Quicken needs to be able to establish outbound Internet connections for the program to work.
    For example, in McAfee Firewall, one user states "By editing the Quicken Firewall entry Selecting Incoming and Outgoing, and changing it from "Default" to "Open to all devices" it now works without having to turn off the entire firewall!"
    See https://www.quicken.com/support/configuring-firewalls
    Check your firewall settings and ensure the following three entries are present, pointing to the Program Files folder that you actually installed Quicken in:

    If necessary, contact the Antivirus / Firewall vendor's Support Center for assistance.
    • In Windows 11 or older Windows systems go to Windows Control Panel and select Internet Options (or in Internet Explorer, click on Tools / Internet options.)
    Click the Advanced tab.
    Scroll down the list to "Use TLS 1.x" and click to put checkmarks on all available choices even though some of them are no longer supported: "Use TLS 1.0, 1.1, 1.2 and 1.3 (if available)"
    Turn off "Use SSL 3.0"
    Click Apply. Reboot.
    • If all else fails: Try rebooting your network router. When done reboot your PC
    • Please let us know which of the above solved your problem.

  • maestrovt
    maestrovt Member ✭✭

    Thanks @UKR for the various suggestions. Maybe I can narrow down the possibilities with this observation. I usually was able to workaround this problem because the Help Menu had something like "Download latest version". This always worked with no problem. Recently, though, for some reason, this option was removed from the Help Menu. If the previous "Download latest version" worked, does that narrow down the possibilities addressed by your message? Thanks, Ed

This discussion has been closed.