Home Quicken for Windows Investing (Windows)

DRIP Fees Where/How to Record

UnknownUnknown Member
edited January 2019 in Investing (Windows)
Re: entering dividend reinvestments: where do I record the commissions/fees correctly? Currently, when you enter a fee amount under the commissions transaction field it gets recorded as "Inc-Income (Div,Int, etc). It is not income and will cause the cost basis to be inaccurate.  

Comments

  • NotACPANotACPA SuperUser ✭✭✭✭✭
    edited October 2018
    Which Q product are you running?  Win or Mac?
    Also, what type of account is this occurring in?  Taxable or retirement (401k, IRA, etc) account?

    Please give an example of what's happening ... so that we can provide informed advice.
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • UKRUKR SuperUser ✭✭✭✭✭
    edited January 2019

    Assuming Quicken for Windows:

    If you're manually entering Reinvest Dividend transactions use the Enter Transactions dialog instead of trying to enter this directly in the new transaction line.
    Here's an example, with commission:

    image

  • NotACPANotACPA SuperUser ✭✭✭✭✭
    edited April 2018
    UKR said:

    Assuming Quicken for Windows:

    If you're manually entering Reinvest Dividend transactions use the Enter Transactions dialog instead of trying to enter this directly in the new transaction line.
    Here's an example, with commission:

    image

    The OP MAY be saying that a $50 div is received ... but only $45.01 gets reinvested.

    In your example, $54.99 is recorded as being received.
    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • UKRUKR SuperUser ✭✭✭✭✭
    edited April 2018
    UKR said:

    Assuming Quicken for Windows:

    If you're manually entering Reinvest Dividend transactions use the Enter Transactions dialog instead of trying to enter this directly in the new transaction line.
    Here's an example, with commission:

    image

    Could you have discovered a potential bug in Quicken 2018?
    I just hacked this picture together real quick so I had an example to show, without recording it or looking at the bottom line or thinking about how much was actually received as dividend.
  • Monica107Monica107 Member
    edited November 2018
    UKR said:

    Assuming Quicken for Windows:

    If you're manually entering Reinvest Dividend transactions use the Enter Transactions dialog instead of trying to enter this directly in the new transaction line.
    Here's an example, with commission:

    image

    They removed the commission  box - I'm in 2019 AND they removed the option to enter a miscellaneous expense..
  • GeoffGGeoffG SuperUser ✭✭✭✭✭
    edited December 2018
    UKR said:

    Assuming Quicken for Windows:

    If you're manually entering Reinvest Dividend transactions use the Enter Transactions dialog instead of trying to enter this directly in the new transaction line.
    Here's an example, with commission:

    image

    Not sure which version you are using, but I see both using 2019 Premier.
    user since '92 | Quicken Windows Premier - Subscription | Windows 10 Pro version 2004
  • Monica107Monica107 Member
    edited December 2018
    UKR said:

    Assuming Quicken for Windows:

    If you're manually entering Reinvest Dividend transactions use the Enter Transactions dialog instead of trying to enter this directly in the new transaction line.
    Here's an example, with commission:

    image

    I'm in 2019 Home & Business.  When I choose the Reinvest - Income Reinvested, there is no place to put the fees other than in the memo.  I'm in version R15.18, build 27.1.15.18.  I was able to use the commission box or miscellaneous exp earlier this year.  
  • Jim_HarmanJim_Harman SuperUser ✭✭✭✭✭
    edited December 2018
    Is this perhaps a "Single Mutual Fund" account? That would explain the lack of a Commission option.
    -- Jim QWin Premier subscription
  • Monica107Monica107 Member
    edited December 2018
    It's a stock, not a mutual fund
  • Jim_HarmanJim_Harman SuperUser ✭✭✭✭✭
    edited December 2018
    Is there more than one security in the account?

    If you look at the transaction list (register) for the account, do you see Cash Amt. and Cash Bal. columns?
    -- Jim QWin Premier subscription
  • Monica107Monica107 Member
    edited December 2018

    Is there more than one security in the account?

    If you look at the transaction list (register) for the account, do you see Cash Amt. and Cash Bal. columns?

    just the 1 stock and no cash account.  I decided just to use the full dividend (before fees) and let quicken adjust the share price. So it doesn't match the statement, it does go to to the cost of the security.  But I did notice that in my investment accounts where I have more than 1 security, the commission is an option. So perhaps it's how I set up the account type or that there's only 1 security (which is being "housed" by an organization like computershare).
  • Jim_HarmanJim_Harman SuperUser ✭✭✭✭✭
    edited December 2018

    Is there more than one security in the account?

    If you look at the transaction list (register) for the account, do you see Cash Amt. and Cash Bal. columns?

    OK, and are you downloading transactions into this account or entering them manually?
    -- Jim QWin Premier subscription
  • Jim_HarmanJim_Harman SuperUser ✭✭✭✭✭
    edited December 2018
    It appears that this account is currently a "single mutual fund" account. I suggest the following to change it to a regular brokerage account:

    1) back up your data file in case something goes wrong

    2) go to Tools > Security List, select the stock that is in your account, and click on Edit

    3) change the Type to Mutual Fund (this is temporary). Click OK and Done to exit the security list 

    4) go to Tools > Account list, select the account, and click on Edit.

    5) On the Account Details you should now see "Single mutual fund account" with Yes selected. Change this to No and click OK and Done to close the Account list

    6) select the account and verify that it now has Cash Amt and Cash Bal columns and that the Commission box is now visible in the Reinvest dialog and MiscExp is in the list of available transactions.

    7) go back to Tools > Security list, select the security in your account, click on Edit and change the type back to Stock. 

    Please post back to verify that this fixes the problem, or let us know which step doesn't work.

    -- Jim QWin Premier subscription
  • Quicken_TykaQuicken_Tyka Moderator mod
    edited December 2018
    Hey there,

    I have the 2019 Home and Bussiness and I have the Commission box when I enter a Reinvest Dividend. 

    image

    I don't believe that this has been removed from the program.

    -Quicken Tyka
    -Quicken Tyka
  • Jim_HarmanJim_Harman SuperUser ✭✭✭✭✭
    edited December 2018

    Hey there,

    I have the 2019 Home and Bussiness and I have the Commission box when I enter a Reinvest Dividend. 

    image

    I don't believe that this has been removed from the program.

    -Quicken Tyka

    Hi Tyka,

    Take a look at my reply above. I think this account is mistakenly set up as a SMF account, which does not have the commission box, and she needs to convert it to a brokerage account.
    -- Jim QWin Premier subscription
  • Quicken_TykaQuicken_Tyka Moderator mod
    edited December 2018

    Hey there,

    I have the 2019 Home and Bussiness and I have the Commission box when I enter a Reinvest Dividend. 

    image

    I don't believe that this has been removed from the program.

    -Quicken Tyka

    I believe you are correct!

    I set up a SMF account and don't have the commission box listed below.

    image

    Thank you

    -Quicken Tyka
    -Quicken Tyka
  • Jim_HarmanJim_Harman SuperUser ✭✭✭✭✭
    edited December 2018

    Hey there,

    I have the 2019 Home and Bussiness and I have the Commission box when I enter a Reinvest Dividend. 

    image

    I don't believe that this has been removed from the program.

    -Quicken Tyka

    The thing that makes this extra confusing is that Quicken lets you put a stock rather than a mutual fund in the account but once the stock is there you can't convert it to a regular brokerage account.

    Thus my instructions to temporarily change the stock to a mutual fund then switch the account type then switch the security back.
    -- Jim QWin Premier subscription
This discussion has been closed.