Home Quicken for Mac Errors and Troubleshooting (Mac)
Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Payee Quickfill problem if Hidden or transaction is a Transfer (Q Mac)

Joerf3Joerf3 Member
Hello,

I'm using Quicken 2020 v5.16.1 and having a problem with payee autofilling.

This problem just started happening after a recent Mac OS update (I'm now on Mac OS 10.15.5).

For example, (prior to the update) if I want to enter the payee as "Transfer to Personal", Quicken would automatically enter the full payee name as soon as I type in "Tran". Now, when I start typing in this payee, Quicken is displaying old payee names I haven't used in years.

These old payee names are NOT in any of my payee or QuickFill lists. It's almost seems like Mac OS is autofilling these in.

I'm trying to figure out how to stop Quicken from showing me this old payee names.

I contacted Quicken support and after 30 minutes of trying a few things, the problem still remains. The rep also thought it could be Mac OS related.

Is anyone else having this problem and if so, have you found a solution?

Thanks,

Joe

Best Answers

  • Joerf3Joerf3 Member
    Accepted Answer
    Thanks for the response! Hopefully the next update comes soon.
«1

Answers

  • Joerf3Joerf3 Member
    Accepted Answer
    Thanks for the response! Hopefully the next update comes soon.
  • Tim WTim W Member ✭✭✭
    I just upgraded to Quicken 5.18.0, running on MacOS 10.15.6, and quick fill transactions are now only partially completing. When I begin entering a payee, the quick fill list appears as usual. However, when I then select the correct payee and category, only the payee gets filled in, not the category. Has anyone else run into this issue?
  • jacobsjacobs SuperUser, Mac Beta Beta
    @Tim W  what you're describing sounds like an issue with your saved QuickFill transactions. When you start typing and Quicken offers its list of "Best Matches", do you see your intended Payee one time in the list -- with just the name -- or do you see it two or more times (the first just the name, and the second showing more information)? Let me illustrate…

    Let's say I want to enter a transaction for Home Depot. I type "home" and Quicken might show me this:



    It's a list of Payees which start with "home", and it has highlighted the first one in the list -- which is the one I want. If I allow it to select this Payee, the name will be Home Depot and the rest of the transaction will be blank. Why blank? Because Quicken doesn't have a QuickFill rule saved for Home Depot.

    So now, I've been sure to save a QuickFill rule for a Home Depot transaction, and I again start to enter a transaction typing "home":



    Notice a few things. Home Depot shows up twice in the list: Once just with the name (what I call the "naked" Payee), and the second time showing a saved QuickFill entry that has my Lawn & Garden category, a $43.21 amount, and a Memo of "Stuff". Quicken automatically highlights this Payee with the QuickFill, so if I select that, it will auto-populate those fields.

    If you don't have saved QuickFill transactions for some of your Payees, you will have to build them up over time, making sure you either have the global preference (Preferences > Register > Automatically create rule when I edit a transaction) turned on, or you click the pop-up box above the Category field when you enter a transaction:



    Or you can go to Window > Payees & Rules, click on the QuickFill Rules tab, and click the "+" icon to manually create QuickFill rules.

    When creating QuickFill rules, you need to decide if you want it to save Category only or All Fields. All fields will store the Category, Memo, Tags, Amount, and split lines.

    Quicken Mac Subscription • Quicken user since 1993
  • Tim WTim W Member ✭✭✭
    Perhaps I was not clear. Quick fill transactions selected with the proper category used to work fine until version 5.18.0. I did indeed view multiple instances of the payee and I selected the one with the desired category; Quicken simply did not fill the category in.

    Since my initial post, I've discovered that many transactions do still quick fill correctly. Ones that do not at all are ones where the category is a transfer to another Quicken account. Quicken 5.18.1 exhibits the same problem.
  • jacobsjacobs SuperUser, Mac Beta Beta
    @Tim W  I'm unable to replicate a problem with QuickFill for transfer transactions. 

    Here's an example. I have a CapitalOne account called "6-Visa {CapitalOne}". Here's the QuickFill rule for the monthly payment in my checking account to pay the credit card:



    This shows the Category field is a Transfer to the credit card account. So now I create a new transaction in my checking account and start typing in the Payee field until I get a match:



    Note that there are two matching transactions: the first one is the "naked" Payee, and the second, which Quicken automatically highlighted, is the one with the transfer. And if I select that, Quicken does indeed fill in the transfer field:



    Note that the Category field remains blank during entry; once you save the transaction, the transfer also appears in the Category field:



    If you're experiencing something different, please post back and detail what you're seeing.
    Quicken Mac Subscription • Quicken user since 1993
  • Tim WTim W Member ✭✭✭
    Well, this is interesting.

    I followed the steps you outline above, which is what I've always done. I selected the payee entry with the correct transfer information and entered the transaction amount. Prior to version 5.18.0, the Category would fill in before I saved the transaction, but based on what you said above, I hit Enter to save the transaction even though the Category column was blank. The category filled in with "Uncategorized."

    Here's where things got weird. I had never made the Transfer column visible before, as that information is redundant with the Category information. When I made that column visible in one account and initiated a test transfer transaction, the behavior changed to be exactly as you describe: the Transfer column showed the correct transfer even though the Category column was blank, and the category filled in properly when the transaction was saved.

    Thinking that this meant that the Transfer column needed to be visible for the quick fill to operate correctly, I went back to hiding the column. However, even after doing so, the Category column filled in properly for tests in that account. Furthermore, the problem was fixed in all other accounts, even though I had never toggled the Transfer column to visible status in those accounts.

    So, clearly some global parameter must have been reset by toggling the Transfer column in one account between visible and hidden. Weird as that seems, I'm glad to have the functionality back, even though the visible behavior now differs from what it had been for me.
  • kitcmackitcmac Member
    edited October 2020
    In a recent update to quicken 2020 for MAC, the autofill feature does not work if the category is a transfer to another account :(
  • jacobsjacobs SuperUser, Mac Beta Beta
    It works properly for me. Do you have the Transfer column visible, or are you just looking at the Category field? The auto-fill goes into the Transfer field initially; it shows up in the Category field as well when you save the transaction.
    Quicken Mac Subscription • Quicken user since 1993
  • kitcmackitcmac Member
    I do have the Transfer column visible. When the autofill first happens I can see the right fill in the transfer column but not the category column. Then when I push tab or enter it disappears and the entry is uncategorized. It used to work perfectly before the latest updates...
  • kitcmackitcmac Member
    I did some experimenting and if I place the transfer column physically in FRONT of the Category column then the auto fill works as it is supposed to, but if the category comes first, then it doesn't work. jacobs, could you confirm this on your end?
  • Quicken_TykaQuicken_Tyka Moderator mod
    Hello @kitcmac

    Thank you for taking the time to visit the Community to report this issue. 

    I was able to recreate the issue of autofill not applying the transfer category, I was not able to recreate the workaround of moving the transfer column. 

    I have gone ahead and reported this issue and will post back more once a ticket has been officially opened.

    Thank you,
    -Quicken
    ~~~***~~~
  • jacobsjacobs SuperUser, Mac Beta Beta
    edited October 2020
    @kitcmac  Nope. ;) On my registers, I always have Category before Transfer.

    But I found an interesting issue after more testing. After you type in the Payee name field and the Best Matches list comes up, the program behaves differently depending on whether you press Enter to select the highlighted Best Match or you click on the highlighted Best Match.

    If you click on the highlighted Best match, this doesn't happen; the Transfer field stays filled as you enter other fields, and when you save the transaction, the Transfer field populates the Category field automatically. This is the "expected behavior".

    If you press Enter, then the Transfer field auto-fills, but unless the cursor is in the Transfer field (e.g. Transfer field follows Payee), then the Transfer field blanks itself as soon as you tab to or click in another field. This seems to me to be a bug.
    Quicken Mac Subscription • Quicken user since 1993
  • lemondjefflemondjeff Member ✭✭
    I can confirm that this broke for me as well after a recent update.
  • lemondjefflemondjeff Member ✭✭
    Specifically, if I Quickfill a transfer transaction from the Payee field and then use the tab key to move the focus to the Amount column, the account I'm transferring to is cleared as the focus passes through the Transfer column.
  • jacobsjacobs SuperUser, Mac Beta Beta
    @lemondjeff  Yes, as noted above by Quicken_Tyka, this has been reported to the developers as a bug in the current release. And as I also noted above, a workaround for the time being is to click on the highlighted Best Match in the pop-up Payee list instead of pressing Tab or Enter. 
    Quicken Mac Subscription • Quicken user since 1993
  • Hydra-GlideHydra-Glide Member ✭✭
    > @jacobs said:
    > @lemondjeff  Yes, as noted above by Quicken_Tyka, this has been reported to the developers as a bug in the current release. And as I also noted above, a workaround for the time being is to click on the highlighted Best Match in the pop-up Payee list instead of pressing Tab or Enter. 

    Just my experience with this issue... this work around doesn't work for me. When I select the highlighted entry, nothing populates into the category field.
  • Quicken_TykaQuicken_Tyka Moderator mod
    Hello @Hydra-Glide

    Thank you for taking the time to visit the Community to report this issue.

    May I ask that you navigate to Help > Report a Problem to submit a report to help contribute to the research of this issue.

    Please include the logs and sanitized data file if comfortable, this report will not receive a direct response but will give our teams more information to investigate.

    -Quicken Tyka
    ~~~***~~~
  • Scott RoseScott Rose Mac Beta Beta
    I am having this same QuickFill problem with transfers, and the workaround doesn't work for me either.
  • jacobsjacobs SuperUser, Mac Beta Beta
    edited October 2020
    @Scott Rose  For the work-around to work, when the Best Match list comes up, are you seeing both the "naked" Payee as one choice and the Payee with the transfer as another choice? Here's an example:



    The first is what I call the "naked" Payee; the second shows a QuickFill rules for the same Payee, with a saved Transfer to a credit card account called "6-Visa {Capital One}". If I then click (not Tab; it has to be a click) on the one that's highlighted, the QuickFill rule is applied:



    Notice that the Transfer account is showing only in the Transfer column at the point the rule is applied; the Category column is blank at this moment. Then click (not Tab) into a column such as Memo/Notes or Payment (or Amount) to complete the transaction:



    Notice those fields are filled in, and Category remains blank. Now press Enter to save the transaction:



    And see that the Category field has been auto-populated by the Transfer.

    This sequence works for me consistently. The keys to makeing this work are (1) making sure you're selecting a Payee with a Transfer, (2) clicking on it in the Best Matches listrather than pressing Tab, (3) clicking into another field(s) to fill the rest of  the transaction, and then saving the transaction.
    Quicken Mac Subscription • Quicken user since 1993
  • Scott RoseScott Rose Mac Beta Beta
    Hi @jacobs,

    Thanks! Oh, I see, when following your 3 steps, it DOES show up in the Category field — but not until after saving the transaction, as you said.

    (I normally have the "Transfer" column hidden, so I never see it auto-populate there, but it also auto-populates the Transfer column as well.)

    Thanks for clarifying the workaround for me. Hopefully, they'll fix this issue soon, so we don't have to jump through all those steps.
  • jacobsjacobs SuperUser, Mac Beta Beta
    @Scott Rose I showed the Transfer column to illustrate what's happening, but you can actually have it hidden as you usually do and the same workaround still works. It's tricky, because you don't see the Category field populate right away -- but if you know you're working around this bug, you know you've selected a Payee with a transfer rule, and you remember to click rather than tab, it works fine. 
    Quicken Mac Subscription • Quicken user since 1993
  • Scott RoseScott Rose Mac Beta Beta
    edited October 2020
    @jacobs Yes, thank you. I knew that you were just doing it for illustrative purposes and that it still works with the transfer column hidden.

    It's still a bit of a clunky workaround that I probably won't end up using because:

    (a) I'm a keyboard shortcut type of guy. (In fact, I'd love to be able to use a keyboard shortcut to go to the "Bills & Income" screen, and I'd love to be able to use a keyboard shortcut to switch to different accounts. Those 2 things prevent me from being "all keyboard all the time" in Quicken.)

    and
      
    (b) I actually like seeing all my columns with the right data in them BEFORE I save the transaction! :) Lol.

    But I definitely appreciate you spelling out the workaround to me step-by-step! At least I have that option to fall back on! :)
  • Hydra-GlideHydra-Glide Member ✭✭
    Got the workaround to work, thanks jacobs for the step by step, but agree, it's clunky not being able to use the tab key. Appreciate the tip... looking forward to the fix. Hopeful something else doesn't go south with the next update. Check numbers not populating correctly earlier this summer, then this bizarre transfer only glitch.. :-)
  • echiapechiap Member
    I am having a similar problem. I'm finding that unless a transfer amount is listed, the category field does not fill in. Then if I tab over to the amount field to enter an amount the transfer field goes blank. Previously the category field would fill in with the transfer category regardless.
  • echiapechiap Member
    edited October 2020
    [Removed-Language] 
  • echiapechiap Member
    I am experiencing the same issue and indeed it is a cumbersome workaround.
  • kitcmackitcmac Member
    I still say for all of you experiencing this problem, If I reorder the columns of my register so that the transfer column comes before the category column you can just tab through the choices and the category is filled in after you tab through the transfer column. At least then you can do all the entering through the keyboard. I still have to manually enter the memo column and the amount, but at least I don't have to re-enter the category each time. I still hope they fix this bug soon...
  • Scott RoseScott Rose Mac Beta Beta
    Nice!! That is a very cool fix that you found there!

    Simply moving the transfer column before the category column does, indeed, fix this problem!

    I actually prefer to hide my transfer column altogether, but I've noticed that the transfer column adds this cool little arrow icon to jump you to the other side of the transfer.

    Is there any way to jump to the other side of the transfer if the transfer column is hidden?
  • Hydra-GlideHydra-Glide Member ✭✭
    > @kitcmac said:
    > I still say for all of you experiencing this problem, If I reorder the columns of my register so that the transfer column comes before the category column you can just tab through the choices and the category is filled in after you tab through the transfer column. At least then you can do all the entering through the keyboard. I still have to manually enter the memo column and the amount, but at least I don't have to re-enter the category each time. I still hope they fix this bug soon...

    Thanks... I never even knew there was a separate column for "transfer", mine had been forever a sub selection within "categories". Now that I've added it and placed it as suggested... all is well (enough).
This discussion has been closed.