account balance report shows different balances based on interval selected

LoneJohnny5
LoneJohnny5 Member ✭✭
edited January 2019 in Reports (Windows)
2019 Version R16.14 Build 27.1.16.14. Interval "None" is correct, the others aren't (and differ as well). Note all displayed balances are wrong when interval is other than "None". imageimageimageimageimage

Comments

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited January 2019
    Do you have All securities selected? There may be some confusing numbers if not, especially "No Security (includes cash)"
    QWin Premier subscription
  • LoneJohnny5
    LoneJohnny5 Member ✭✭
    edited December 2019

    Do you have All securities selected? There may be some confusing numbers if not, especially "No Security (includes cash)"

    Yes, I do have all securities selected. However, IMHO, that should make no difference so long as the selection is identical across all the selected intervals.
  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    edited January 2019
    I just tried this using my Quicken (same version) and didn't see what you're reporting.  Does this report happen to be a saved report that you saved in a previous version of Quicken?  For whatever reason "upgrading" has been know to make saved reports go bad.  If that's the case then re-do the report using your current version.

    And, the old standby: File > File operations... > Copy, then validate the copied file.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    edited January 2019
    There should be a checkbox in the Customize dialog / Advanced tab to "include unrealized gains".
    Uncheck that and see what that does ...
  • LoneJohnny5
    LoneJohnny5 Member ✭✭
    edited December 2019

    I just tried this using my Quicken (same version) and didn't see what you're reporting.  Does this report happen to be a saved report that you saved in a previous version of Quicken?  For whatever reason "upgrading" has been know to make saved reports go bad.  If that's the case then re-do the report using your current version.

    And, the old standby: File > File operations... > Copy, then validate the copied file.

    It's a new report. The old one (12-month date range with monthly interval showed wrong data, so I did some investigation). BTW, the file validates with no errors. Validation reports investment register entries more than 10 days in the future (all intended to be there) and possible missing stock splits from well before when I purchased the stocks involved. 
  • LoneJohnny5
    LoneJohnny5 Member ✭✭
    edited December 2019

    There should be a checkbox in the Customize dialog / Advanced tab to "include unrealized gains".
    Uncheck that and see what that does ...

    You may be on to something. Unchecking the "Include unrealized gains" box makes the balance consistent regardless of interval selected. Incorrect, as compared to the Investing tab display, but consistent.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    edited December 2019

    There should be a checkbox in the Customize dialog / Advanced tab to "include unrealized gains".
    Uncheck that and see what that does ...

    So, now that we've got that out of the way, please show and tell us more about this discrepancy.
  • LoneJohnny5
    LoneJohnny5 Member ✭✭
    edited December 2019

    There should be a checkbox in the Customize dialog / Advanced tab to "include unrealized gains".
    Uncheck that and see what that does ...

    Nothing to add except, per another suggestion, I validated the file with no errors. The validation did report investment register transactions more than 10 days in the future, which I expected as I use future-dated entries in both banking and investment registers to identify needed fund transfers. It also reported possible missing stock splits, all for stocks I didn't own at the time of the split. 
  • LoneJohnny5
    LoneJohnny5 Member ✭✭
    edited December 2019

    There should be a checkbox in the Customize dialog / Advanced tab to "include unrealized gains".
    Uncheck that and see what that does ...

    EUREKA, or perhaps more appropriately, "I see said the blind man". For giggles, I deleted the future transactions in the account, and the problem disappeared. I then checked using other investment accounts with future transactions, and they didn't show the problem. So...I don't consider this "solved" as I don't understand why a future transaction would affect a past balance.
  • LoneJohnny5
    LoneJohnny5 Member ✭✭
    edited December 2019

    I just tried this using my Quicken (same version) and didn't see what you're reporting.  Does this report happen to be a saved report that you saved in a previous version of Quicken?  For whatever reason "upgrading" has been know to make saved reports go bad.  If that's the case then re-do the report using your current version.

    And, the old standby: File > File operations... > Copy, then validate the copied file.

    For giggles, I deleted the future transactions in the account, and the problem disappeared. I then checked using other investment accounts with future transactions, and they didn't show the problem. So...I don't consider this "solved" as I don't understand why a future transaction would affect a past balance.
  • mshiggins
    mshiggins SuperUser ✭✭✭✭✭
    edited December 2019

    There should be a checkbox in the Customize dialog / Advanced tab to "include unrealized gains".
    Uncheck that and see what that does ...

    What were the future transactions?
    Quicken user since Q1999. Currently using QW2017.
    Questions? Check out the  Quicken Windows FAQ list
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited December 2019

    I just tried this using my Quicken (same version) and didn't see what you're reporting.  Does this report happen to be a saved report that you saved in a previous version of Quicken?  For whatever reason "upgrading" has been know to make saved reports go bad.  If that's the case then re-do the report using your current version.

    And, the old standby: File > File operations... > Copy, then validate the copied file.

    Aha! That's interesting

    BTW monthly interval is definitely a bad idea for the Investment Performance report, because it presents ANNUALIZED numbers, i.e. the 1-month performance will be multiplied by about 12.
    QWin Premier subscription
  • splasher
    splasher SuperUser ✭✭✭✭
    edited January 2019
    I have seen this in the Networth report every year that I have beta tested.  I never have future transactions in my investment accounts, so that is not it in my data file.  There are no placeholders.

    Dev has gotten copies of my file in years past (not lately) and never get back with me as to what the issue is and have never cured it.
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • LoneJohnny5
    LoneJohnny5 Member ✭✭
    edited December 2019

    There should be a checkbox in the Customize dialog / Advanced tab to "include unrealized gains".
    Uncheck that and see what that does ...

    Split withdrawals with state tax, federal tax, and a transfer to another account.
  • LoneJohnny5
    LoneJohnny5 Member ✭✭
    edited December 2019

    I just tried this using my Quicken (same version) and didn't see what you're reporting.  Does this report happen to be a saved report that you saved in a previous version of Quicken?  For whatever reason "upgrading" has been know to make saved reports go bad.  If that's the case then re-do the report using your current version.

    And, the old standby: File > File operations... > Copy, then validate the copied file.

    This is a simple "Account Balances" report; no annualization involved. IHMO should be accurate regardless of interval.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited December 2019

    I just tried this using my Quicken (same version) and didn't see what you're reporting.  Does this report happen to be a saved report that you saved in a previous version of Quicken?  For whatever reason "upgrading" has been know to make saved reports go bad.  If that's the case then re-do the report using your current version.

    And, the old standby: File > File operations... > Copy, then validate the copied file.

    Oh sorry, wrong discussion
    QWin Premier subscription
  • splasher
    splasher SuperUser ✭✭✭✭
    edited December 2019

    I have seen this in the Networth report every year that I have beta tested.  I never have future transactions in my investment accounts, so that is not it in my data file.  There are no placeholders.

    Dev has gotten copies of my file in years past (not lately) and never get back with me as to what the issue is and have never cured it.

    Also, it never agrees with what the Account Bar shows either.
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
This discussion has been closed.