Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Transactions in an investment account do not appear in the cash account

I do things the old fashioned way and hand enter data,  When I went to reconcile January, I found several transactions that did not appear in the cash account.  I copied them, deleted them and pasted them back into the investment account.  That worked and they appeared in the cash account.
 
I still had a big discrepancy between todays' balance and my Quicken balance.  February transactions were missing from the cash account. I copied/deleted/pasted 4 transactions, only one appeared in the cash account.  I had to do it again for the other 3 and this time it worked.

Answers

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Is your investing account set up with a "Linked checking account" so that cash transactions in the investing account are recorded in a banking account?
    QWin Premier subscription
  • Hen
    Hen Member ✭✭
    I think that's the way I did it.  I've been using Quicken for more than 10 years.  My brokerage accounts have a linked cash account, which appears under the Banking heading on the left side  and the only thing that changed was I upgraded to Quicken 2019 on Jan 7th.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    OK, just to verify, if you go to the Account Details is "Yes" selected next to Show cash in a checking account?

    Can you explain what you did when you "copied/pasted/deleted" the transactions?

    With a linked checking account, you should be entering cash transactions (deposits, checks, etc.) in the checking account and  investing transactions that produce or use cash (Buy, Sell, Div, etc.) should automatically transfer the needed cash to/from the linked account.
    QWin Premier subscription
  • Hen
    Hen Member ✭✭
    Yes it does show in checking account.  I didn't know where to find it without your help.

    I go to the Investment account, I highlight the missing transaction, right click, and select copy transaction, I then delete the transaction, go to a new line and right click paste transaction. Then enter.

    In between these posts, I found more stock sales that did not appear as cash in the checking account.  The copy/delete/paste did not work for some and I had to delete those entirely from the brokerage account and enter them entirely from scratch. 

    If I click on edit details, the correct account is listed, so the transaction isn't going to a different brokerage account.

    Re you last paragraph, yes that's the way I've always entered data, cash goes to the checking account, dividends and stock transactions in the brokerage account and everything has worked for years, up until upgrading to 2019.


  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    "Yes it does show in checking account.  I didn't know where to find it without your help."
    Show cash in a linked checking account can't possibly show in the Account Details for the checking account ... it would be in the brokerage account.
    AND, in QWin, only a taxable account has this feature ... no retirement type accounts.

    Q user since DOS version 5
    Now running Quicken Windows Subscription,  Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • Hen
    Hen Member ✭✭
    edited February 2019
    The "yes show in checking account" is when I right click the brokerage account,. We are talking about a non retirement account and Windows

    However I have two IRA's.  They were set up years apart.   1 IRA must have been set up as a brokerage account and one was set up as a Retirement account. 

    The later is the one that lives below the line and one lives below a solid line in my list of accounts.  In the account details, both have the tax deferred account checked and both have yes, show in checking account checked.  These and all of my accounts have functioned, as Jim described in his 3rd paragraph for years. flawlessly if I didn't fat finger the data, until the 2019 upgrade.



  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    I suspect there are hidden placeholders in your account that are messing with your cash balances.

    Go to Edit > Preferences > Investing transactions and make sure Show hidden transactions is checked.

    Placeholders will have a gray background even if they are not selected and an Action type of Entry.

    Please let us know if that is the case.
    QWin Premier subscription
  • Hen
    Hen Member ✭✭
    Show hidden transactions was already checked
    I do not see any gray backgrounds in either the brokerage or checking side of the account.  I don't think I could have missed a gray background in the transactions I had to delete and re-enter.  We will see what happens going forward.

    Thanks for you advice
    You don't think I need to reinstall quicken, do you?
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited February 2019
    OK, let's summarize:
    -- If you go to Edit account details for the problem account, it says the account is a Brokerage account and both tax deferred and Show cash in a checking account are selected.
    -- there are no Placeholders in the account.

    Do I have this correct?

    When you enter a Sell transaction, are all the options under Record Proceeds grayed out? They should be, because when there is a linked account that is the only place the proceeds can go.

    But when you sell, the proceeds do not show up in the linked account?

    I don't think it is a good idea to cut and paste transactions when there are transfers, because you may get broken transfers.. It is cleaner to delete a problem transaction and re-enter it.
    QWin Premier subscription
  • Hen
    Hen Member ✭✭
    This is not a retirement account,  someone else introduced the idea of retirement accounts.  For now, the problem is in a regular brokerage account.  That one is not tax deferred (and not checked) but the Show Cash in Checking Account is checked:
    There are no placeholders.
    Yes the options are grayed out.

    When I sell the proceeds sometimes do not show up in the linked account.  It does not matter whether I click on the Enter Transaction radio button, or enter the transaction at the bottom of the brokerage account register.  At the moment I cannot reproduce the behavior.

  • wbone
    wbone Member ✭✭
    Hen,
    The placeholders have created MAJOR work for anyone that has a linked cash account.  I have spent days and hours correcting and solving the issue with them.  Coping and pasting will not solve your issue.  Going into the preferences and unchecking or checking in placeholders will not solve your problem.  There are 4 steps you have to take in order to get rid of the placeholder.  I truly hope Quicken finds a solution to this issue because it is time consuming and your account will never be accurate.  Will try and walk you through the 4 steps
    1.  Go into the Security Detail View - you will see a Placeholder in this view (this is the only place you will find this placeholder.  This placeholder is the cause for why your transaction is not linking to your cash account)
    2.  Click into the Placeholder.  Where it asks you how many shares do you own of this security, type in your ownership.
    3.  Delete and reenter the security that you need to link to your cash account.  You will see that it still doesn't indicate it will go to you cash account but that is ok because you have more steps to take.
    4.  Find the security transaction that you just created.  Go to the Action column, click into it and select the action you need that has an "X".  All actions must have an "X" or else they will not transfer into your cash account.  If you can't click into the Action column, go to the Placeholder entries.....more than likely you will see the Placeholder that you removed from step one, now has popped up in the Placeholder entries (initally it was not there).  Delete this placeholder.  Go back to the action column and now you will be able to change the action to make sure it has an "X" as the last letter of the action taken.

    Hope this makes sense to you.  As I said in the beginning, it took me hours and days to solve this issue.  I have been using Quicken since 1996.  This Placeholder issue is huge and if Quicken doesn't find a fix for it before my subscription expires, I will not be going forward with them!

  • Hen
    Hen Member ✭✭
    Wbone, you lost me at #4  Where is the action column? The buy, sell column?
    At present, I have no placeholders and everything is as it should be.  I've been using Quicken for at least 10 years and am doing nothing differently when these placeholders appeared all in the last month. 

    I have entered 4 new transactions since I started this thread, and everything appeared in the appropriate accounts.
    If I wanted to cause placeholders to appear, what would I do?
  • wbone
    wbone Member ✭✭
    Hen,  wish I could screen print and send to you...it would be easier to show.  Yes, it is the buy, sell column.  You should be able to click into it and change it to an action that has the "X" at the end of the action.  When you have a linked cash account, all transactions in your investment account must have the X at the end of the action ie....broughtX, Soldx, shtsellX, cvshrtX.  The X means it will be transferred into your cash account.  If it doesn't have an X, it means it stays in the account it's in, hence it doesn't get transferred and your cash account will not equal what your institutional account has in cash.

    You really don't want placeholders to appear.....they are a pain to deal with and to get rid of.  So if you don't have any and your transactions are downloading properly and transferring to your cash account then you are in good shape.
  • Hen
    Hen Member ✭✭
    For now the error has not reappeared.  As I said in the beginning, I am manually entering transactions and have been doing so for 10+ years the same way.
    Thanks everyone.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    wbone said:
    Hen,  wish I could screen print and send to you...it would be easier to show. 
    Here's how you can capture screen image snapshots and post them in your discussions:
    The Windows Snipping Tool (available with Windows 7 and up) can be used to capture a partial screen image and save it to a file.  Microsoft Paint can be used to annotate the image.
    https://support.microsoft.com/en-us/help/13776/windows-use-snipping-tool-to-capture-screenshots
    To take a screenshot in Mac please see https://support.apple.com/en-us/HT201361
    Please create image files of type PNG, JPG or GIF only.
    To attach the image here, start composing your reply in the "Type your comment" box at the bottom of the webpage. At the top of the text entry window  you'll see a row of icons beginning with B I S
    Click the "Attach image" icon (the one that looks like a landscape with mountain and sun). It will allow you to select and upload the captured image file(s) from your computer. The captured image(s) will be inserted at wherever the cursor is located in the text.
This discussion has been closed.