Is there a way to correct the tax treament of the _DivInc Category

For some reason the Tax Line Item for the _DivInc Category is showing up as ScheduleB:Div Income, non-taxable. This causes all Dividend Income (including Dividends for Taxable Accounts) to not show up correctly on Tax Planner. Is there a way to correct this?

Best Answer

  • markus1957
    markus1957 SuperUser, Windows Beta Beta
    Accepted Answer
    This would all be so much easier if Q would simply let us edit the built-in "_" categories. 
    As reported by RJS in another thread-

    "Good news! It appears that it is once again possible to edit the "_" investment categories in QWin R30.14.
    Hold down CTRL and SHIFT and right-click the category. You should see Edit in the resulting menu. Then you can go to the Tax Reporting tab of the resulting dialog and correct the tax line item."

    Side Note- I was also able to delete my orphan category by creating a new Test category and then editing the orphan to make it a sub-category of the new Test category.  Deleting the Test category also deleted the orphan. Super-validate showed no errors in the file.
«1

Answers

  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    When you were creating this/these securities, did you mark them as "Non-Taxable"?
    OR, are these securities held in a Retirement type account, such as a 401k or an IRA?
    Q user since DOS version 5
    Now running Quicken Windows Subscription, Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • raa0428
    raa0428 Member ✭✭
    Thanks for your response. None of the securities are marked as Tax Free and these securities are not held in a retirement type account.

    The issue seems to be the _DivInc income category (which is not editable from within the program.

    There is another _DivInc Tax Free Category which is also showing the same Tax Line item of ScheduleB:Div Income, non-taxable.

    You would think the main _DivInc income category under Investments would show Tax Line Item as: ScheduleB:Div Income, similar to _IntInc.

    Would love to be able to fix this.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    I suggest you create a new file for testing purposes, and see how that shows for that category.  I am afraid your current file may be corrupted.  Maybe a reinstall of the program will correct it (if the test file shows the problem), but I sort of doubt it. 

    Another direction is to copy your existing file from within Quicken and then validate that copy.  

  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    I concur with q_lurker, that this is sounding like a corrupted data file issue.
    Q user since DOS version 5
    Now running Quicken Windows Subscription, Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • raa0428
    raa0428 Member ✭✭
    Thank you for the responses. You're absolutely correct. I created a new test file and it does show the category as correct. I will try the file copy. If that doesn't work than I guess I would have to live with this as starting a new file from scratch isn't really an option for me. Appreciate the comments.
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    edited September 2020
    There appears to be a way to fix it. This is experimental, so be sure to follow Step 1.
    1. Back up your Quicken data file.
    2. Open the Category List.
    3. Create a new income category, e.g., "_DivIncNew" and assign it the correct tax line item "Schedule B:Dividend Income".
    4. In the Category List, hold CTRL+SHIFT and right-click the old _DivInc category.
    5. Select Delete from the resulting menu.
    6. Quicken will ask you to confirm and what category to reassign the transactions to. Tell it to use your new category _DivIncNew. Do not allow the transactions to become uncategorized.
    7. Quicken will reassign all _DivInc transactions to use _DivIncNew as you will be able to see in your investment transaction list for Div transactions.
    8. Back in the category list, rename _DivIncNew to be _DivInc.
    Now all your Div transactions should be properly categorized as _DivInc with the correct tax line item. Note that the _DivInc category is no longer the original built-in category but is now a user category like any other you create. So transactions won't look the same but should (hopefully) behave correctly.
    Please let me know whether this works out for you. You can always revert to your backup if anything seems amiss.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • raa0428
    raa0428 Member ✭✭
    Thanks you!!! The only additional step I had to follow was Quicken immediately created a new _DivInc category (with no tax reporting line at all), but once I deleted it again (and since I had re-categorized everything during Step 6 the second time I deleted the old _DivInc it gave no warning since no transactions were using it). I then renamed the _DivIncNew to _DivInc and everything was corrected and now both the reporting and the Tax Planner works perfectly and the file validated with no errors. Unbelievable!!

    Thank you so much!!!
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    edited September 2020
    raa0428 said:
    Quicken immediately created a new _DivInc category (with no tax reporting line at all)
    Hmm, this behavior is different than when I tried this on a copy of my data file. I did not see Q create a new _DivInc. I hope this means that your data corruption is different enough from my own data corruption that this technique will work better for you.
    Before getting too excited, test whether any new Div transactions get categorized correctly. Upon further experimentation, I am finding that they do not in my own file. In my file, a new Div transaction appears as Uncategorized rather than as _DivInc in the Investment Income report, and does not appear properly in the Tax Planner, which is a bummer.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • raa0428
    raa0428 Member ✭✭
    You're right. All of the existing transactions are fine, but if I enter any new Dividend it is not categorized correctly. What a bummer. It seems the new category is not linked to the "Investment" categories. In the new transactions the "category" field is blank (and not editable) which is where the _DivInc category would appear and I assume what drives the data to the proper investment category. If you come up with any new ideas please post. I will continue to use my old file, but can use the new file to test any other workarounds.

    The last thing I want to do is create a new data file and lose all of my history. Been using this file since 94. Appreciate your help!
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    edited September 2020
    [EDIT: before trying this, see my following post.]
    I think I have an even better solution to this problem which is much less of a hack because it uses a real feature which has been subsequently disabled. It just nagged at me until I couldn't stand it any more.
    Back in release R26.23, there existed a loophole or "back door" which allowed users to change the Tax Line Item associated with built-in "_" categories. This was in the Tax Planner, where you could click "View tax form line items used here" and then "Change" the TLI associated with a category. This loophole was plugged in subsequent releases because it is actually too dangerous for casual users to stumble upon.
    Using a copy of that backup file you prudently created earlier,
    1. Revert to R26.23 by running its mondo patch copied from here:
      https://1drv.ms/u/s!AkC-7jZCgVToiwSE0KxXuqdnR3KP?e=GOBvfD
    2. Open Tax Planner.
    3. Go to Interest/Dividend Inc.
    4. Click on Dividends.
    5. Click on View tax form line items used here.
    6. Next to _DivInc, click Change. (This is the feature that was later removed.)
    7. Click Tax Reporting and change the TLI to the correct one.
    8. Check that things look good.
    9. Restore the latest version, R28.28, or whatever it may be at the time you read this by running the latest mondo patch.


    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    edited September 2020
    This may require more luck than skill. If _DivInc doesn't appear in the list of categories in the middle dialog - and I now believe it won't - this won't work. This leaves you with the only remedy being to reclassify all future dividends as MiscInc transactions with category _DivInc instead of as Div transactions.

    Sorry for sending you down the rabbit hole.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • raa0428
    raa0428 Member ✭✭
    Thanks for all of your help. You're right, since the category is set as Schedule B, Div Inc, non-taxable it didn't show up in the list of categories used in the Dividend section of the tax planner. I could see that other investment categories could be adjusted using the previous version you provided. It's so frustrating that this is hard-coded and cannot be fixed. This hadn't been such an issue for me previously as I pretty much only had tax-deferred accounts, but now it has become a bigger issue. For now I will be using my original file and setup to see if some quicken comes up with a permanent fix.

    Really appreciate all of your suggestions.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited September 2020
    Before making any significant changes to the Quicken file, always save a backup: press Ctrl + B
    1. Open the Category List: press Ctrl + Shift + C
    2. Create a temporary income category _DivIncTemp 
    3. Press CTRL + SHIFT and right-click on _DivInc and select Delete
    4. Confirm and use _DivIncTemp
    5. Select Options > Manage Categories, Investment in the pull-down menu, _DivInc, Add, and OK
    6. Press CTRL + SHIFT and right-click on _DivIncTemp and select Delete
    7. Confirm and use _DivInc
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    Sherlock said:
    6. Press CTRL + SHIFT and right-click on _DivIncTemp and select Delete
    7.Confirm and use _DivInc
    I have been trying this and cannot accomplish step 7. _DivInc does not appear in the list of available categories. I can repeatedly type "_" into the box and get several other categories, but not this one. I have made sure _DivInc is not hidden. What am I missing, @Sherlock ?
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited September 2020
    Sherlock said:
    6. Press CTRL + SHIFT and right-click on _DivIncTemp and select Delete
    7.Confirm and use _DivInc
    I have been trying this and cannot accomplish step 7. _DivInc does not appear in the list of available categories. I can repeatedly type "_" into the box and get several other categories, but not this one. I have made sure _DivInc is not hidden. What am I missing, @Sherlock ?
    If you do not see _DivInc in step 7, instead of immediately deleting the temporary category, I suggest you first select Tools > Recategorize... , find the transactions, memorized payees, and reminders with _DivIncTemp as the category, Select All, and recategorize as _DivInc. 
  • markus1957
    markus1957 SuperUser, Windows Beta Beta
    Or maybe since Quicken doesn't always refresh tables like it should, close & re-open Quicken.

    Side note- I have an orphan category that will not display Delete option using Ctrl + Shift.  Any other suggestions to get rid of it?
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited September 2020
    Or maybe since Quicken doesn't always refresh tables like it should, close & re-open Quicken.

    Side note- I have an orphan category that will not display Delete option using Ctrl + Shift.  Any other suggestions to get rid of it?
    What is the type of the orphan category?

    One thought would be to see if you can use the orphaned category.  In other words, if it is otherwise editable, you might recategorize to the orphaned category and delete the original.  
  • markus1957
    markus1957 SuperUser, Windows Beta Beta
    Investment, Personal Expense Group. But even though it displays in the Investment filter, it is the only one that allows an edit.  I can edit it, use it for a register entry. Behaves normally except it will not delete and allows editing.
  • NotACPA
    NotACPA SuperUser, Windows Beta Beta
    For the stocks in my taxable account, I use the _MiscInc category ... so that I can direct those dividends to the _QualDivInc category.
    I don't have funds in the taxable account ... so this works.
    Q user since DOS version 5
    Now running Quicken Windows Subscription, Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • raa0428
    raa0428 Member ✭✭
    Appreciate the discussion. I attempted creating the temp category based on the suggestion from last night, but doesn’t appear you can re-categorize investment transactions. The new _DivIncTemp account also does not show up as an investment category despite the _.

    I updated my 2020 transactions using the MiscIncome and a new regular (non-investment category) that I created. Not ideal but at least the reports and tax planner reflects accurate information.

    Thanks again for all of the suggestions!
  • markus1957
    markus1957 SuperUser, Windows Beta Beta
    edited September 2020
    Adding- I did some testing with the Ctrl + Shift delete process in a test file.  It corrupts the reporting and Tax Planner output for the Income transaction window input boxes. There is no way to restore functionality once a category associated with the specific input is force deleted. Recreating the category using the Manage function does not work.  The input values appear to be hard-coded to an indexed field.

    I would advise not recommending this process as the corruption is unrepairable.  The only workaround is as @raa0428 has described.

    Adding further- If it would be helpful, I would send a sanitized version of the test file to Quicken Developers so they could analyze & fix the problem.  They should deactivate the force delete in the interim as there is no current benefit to using it.
  • markus1957
    markus1957 SuperUser, Windows Beta Beta
    edited September 2020
    @raa0428 - I may have a workaround for you after doing some testing.  I'm running the beta version but I believe it matches up with the staged R29.9 release just announced.  It will probably work with the current R28.28 release also.

    I created a new file to try and discover how hidden categories are created.  From previous testing I knew that hidden categories associated with 401k accounts are not created until the first 401k account is added in Quicken.  I confirmed this is also the case with investment accounts.  A new Quicken file created with only a cash account has No hidden categories.

    The first investment account established in a Quicken file spawns all of the investment related hidden categories and associated tax lines.  There are some under-the-hood connections tied to the Action column and the Enter Transaction Income window that impact how Tax Planner and some Reports query and display investment transactions.  These connections get broken when a hidden category is force deleted. For example, if the "_DivInc" category is force deleted, dividend income entered in the Enter Transaction Income window will not show up in Tax Planner.

    The Manage Categories process of adding the Category back does Not reestablish the broken connections critical for Tax Planner and some Reports to operate properly.

    I found that the connections could be reestablished by creating a new manual investment account (it can be deleted later).  Any force deleted and missing hidden investment category is restored with the proper under-the-hood connections when the new account is added.  Manually created or Manage Categories produced categories (with the same name as the force deleted category) will prevent this restore; the category must not be present for this to work.  The result is any future transactions entered or downloaded will show up properly in Tax Planner and Reports.

    I think you will still be faced with a lesser of evils choice; old entries work or future entries work. Maybe someone brighter than me can figure it out to easily get both to work.  You can go back thru old transactions and in the Income input window, cut/paste them to interest, save and cut/paste back to Dividend and they will get restored.

    Since you indicated you don't have too many taxable old dividends, going back and editing one by one might be an option.

    Hope this helps.

  • raa0428
    raa0428 Member ✭✭
    You're right, doing this definitely added back the _DivInc with the correct tax category and tax planner works. But all of the Dividends in the tax-deferred accounts now show up as uncategorized in the investment reports. I tried to do what you suggested and go back thru of the uncategorized transactions (cut/paste them to interest), but even when I cut/paste back to dividend they still show up a uncategorized in the reports.

    At this point I did reclassify all of the taxable dividends as miscinc linked to a non-investment dividend category I created. Will see what happens once new transactions are downloaded. I guess will be a couple of extra steps to get the transaction classified correctly.

    Appreciate all of the ideas though.
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser, Windows Beta ✭✭✭✭✭
    This would all be so much easier if Q would simply let us edit the built-in "_" categories. 
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • markus1957
    markus1957 SuperUser, Windows Beta Beta
    In my test, when I deleted _DivInc, I chose to recategorize the existing transactions to the default system generated unhidden "Div Income" category.  They then still appeared in the Dividend input box of the Income Window.  I'm guessing yours appeared in the Miscellaneous box?  Did you try deleting and re-entering the older transactions? 

    There is a lot going on under-the-hood; a reset to default Categories would be nice along with the ability to edit and recategorize investment transactions.  
  • raa0428
    raa0428 Member ✭✭
    The old transactions did default back to the new DivInc category, but despite that all those transactions still reported as uncategorized. So I went to some of those old transactions to edit change save and then edit again to use the DivInc again and they still showed up as uncategorized.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    raa0428 said:
    The old transactions did default back to the new DivInc category, but despite that all those transactions still reported as uncategorized. So I went to some of those old transactions to edit change save and then edit again to use the DivInc again and they still showed up as uncategorized.
    Any possibility of cutting out the old transaction and pasting it back in?  (Rt Click option on each, one at a time).  Hoping that paste might be taken as a new transaction.   
  • Quicken Sarah
    Quicken Sarah Administrator, Moderator mod
    Hello @raa0428

    Thank you for taking the time to share the details of this issue with the community, although I apologize for any frustration or inconvenience experienced.

    Our Teams would like to investigate this matter further and wanted to know if you would be willing to share a sanitized copy of both the original data file and the new copied file that is working correctly.

    Sanitizing the file removes all personally identifiable information, including financial institution/online biller login credentials and obfuscates the transaction details to ensure your privacy remains intact.

    If you are willing to assist, please open a copy of the original data file where this behavior can be viewed and go to the Help menu > Report a Problem option.

    In the window that opens, please enter "Attn: Sarah Original File" in the subject line, mark the Sanitized Data file copy box and when ready click Send to Quicken.

    Once sent, please open the new copy of the file where the category is working correctly and repeat the steps to Report a Problem, entering "Attn: Sarah New File" in the subject line.

    When both file have been submitted, please reply here to let me know so I can retrieve the reports from the system.

    Thank you in advance,

    Sarah
  • Quicken Sarah
    Quicken Sarah Administrator, Moderator mod
    Adding further- If it would be helpful, I would send a sanitized version of the test file to Quicken Developers so they could analyze & fix the problem.  They should deactivate the force delete in the interim as there is no current benefit to using it.
    Hello @markus1957

    It would be extremely helpful to receive a sanitized version of the test file where you were able to replicate this behavior.

    If you are still willing to assist, please submit the sanitized file through the Report a Problem option, entering "Attn: Sarah" in the subject line, and as always, please just let me know once it has been sent.

    Thank you,

    Sarah
  • raa0428
    raa0428 Member ✭✭
    Hi Sara, appreciate the follow-up, however, just to clarify while the new file did correct the issue with the _DivInc (corrected to taxable) all of the old transactions using that category all changed to uncategorized in the reporting so the fix didn’t really work other than correcting the category for future transactions. I will attempt to create the sanitized files in the next few days.



    > @"Quicken Sarah" said:
    > Hello @raa0428
    >
    > Thank you for taking the time to share the details of this issue with the community, although I apologize for any frustration or inconvenience experienced.
    >
    > Our Teams would like to investigate this matter further and wanted to know if you would be willing to share a sanitized copy of both the original data file and the new copied file that is working correctly.
    >
    > Sanitizing the file removes all personally identifiable information, including financial institution/online biller login credentials and obfuscates the transaction details to ensure your privacy remains intact.
    >
    > If you are willing to assist, please open a copy of the original data file where this behavior can be viewed and go to the Help menu > Report a Problem option.
    >
    > In the window that opens, please enter "Attn: Sarah Original File" in the subject line, mark the Sanitized Data file copy box and when ready click Send to Quicken.
    >
    > Once sent, please open the new copy of the file where the category is working correctly and repeat the steps to Report a Problem, entering "Attn: Sarah New File" in the subject line.
    >
    > When both file have been submitted, please reply here to let me know so I can retrieve the reports from the system.
    >
    > Thank you in advance,
    >
    > Sarah
This discussion has been closed.