Exported QXF file from MAC imported it on Windows and all transactions are 100X larger

Hi, I am moving from Mac to Windows Quicken. I exported all my data from Mac to a QXF file and then imported it on Windows. However all transactions on Windows are 100X larger than its original value. Simply 00 (two zeros) have been added to all transactions. Does anyone know how I can get this fixed. I still have the Mac data file so I can do new extractions if needed. Thank you.

Answers

  • Quicken Anja
    Quicken Anja Moderator mod
    Hello @g.cerqueira,

    Thank you for reaching out to the Community about your issue, though I'm sorry to hear that you are experiencing this.

    First, could you please provide which version release of Quicken Windows and Quicken Mac you currently have running?
    • WindowsHelp > About Quicken
    • MacQuicken > About Quicken
    To start with, I do recommend that you export a new QXF file as you said and import it into a new Windows data file to see if it will come through correctly. 

    Let us know how it goes!
    -Quicken Anja
  • Hello 👋 Anja. Thanks for reaching out. Both versions are the cloud subscription version, for Mac and Windows. This means I am always using the latest version of both, through my cloud subscription of Quicken. I ran the migration two times now and received the same 100X results. I hope you can help me?
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    Just a W.A.G. since I know so little -- are both files Windows and Mac files set up using USDollars?
  • Hello 👋 the target Windows data file is a new one. I create it brand new then I import the QIX data file extracted from Mac Quicken. Therefore I would expect the new file to inherit all currency config of the original file. I have accounts in CHF, EUR and BRL. All of them are correct after import, with the exception that the transactional values are all multiplied by 100. This is clearly a formatting issue faced during the export/import process. Is there a way I can run a script to divide all transactional data by 100? This would solve the problem.
  • Quicken Anja
    Quicken Anja Moderator mod
    Thank you for the update, though I apologize that you have not yet received a follow-up response.

    If you haven't already, I suggest you try is to validate your data file by following the steps below--
    1. First Save a backup of your data file (just in case) 
    2. Go to File
    3. File Operations
    4. Validate and Repair
    5. Validate File
    6. Ok
    7. Close the data log that will pop-up after the validation has completed
    8. Close Quicken
    9. Wait at least 5 seconds
    10. Reopen Quicken
    11. Try again to see if the issue reoccurs/remains the same or gets corrected
    You can also try super validating which are the same steps as above except that you will hold Ctrl and Shift on your keyboard when clicking on Validate and Repair in order to get the option for Super Validate.

    Let us know how it goes!
    -Quicken Anja
  • g.cerqueira
    g.cerqueira Member
    edited October 2020
    Solved the issue myself. In Mac the decimals separator was "," and in windows it was "." simple as that. The quicken agent in the live chat support told me quicken was not design to accept "," as decimals separator. I asked him "how come" since in my Mac it was exactly like that. He replied that the chat support I was logged on to was for windows not for mac! I asked him what he would advise me as a next step and he promptly answered: "go back to work on Mac", [removed-disruptive] unbelievable!
  • Quicken Anja
    Quicken Anja Moderator mod
    @g.cerqueira, thank you for following up and providing an update.

    I'm happy to hear that you were able to resolve this, though I sincerely apologize for the unpleasant experience with support! Were you given a ticket number by chance? I would like to review the interaction and forward it to the proper channel so we can provide the agent with appropriate coaching to avoid this from happening in the future.

    Thank you!
    -Quicken Anja
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    Solved the issue myself. In Mac the decimals separator was "," and in windows it was "." simple as that. ...
    I believe on the WIndows side, Quicken uses the Windows setting for regional preferences to manage the comma versus period designation.  How are those set on your Win OS?  You might be able to change that setting, make the import, then change it back.

    Or you would need to change the Mac setup to use the period delimiter, make the QXF for import into Q-Windows, then change it back.    
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    I asked him "how come" since in my Mac it was exactly like that.
    But it isn't like that on all Macs.  Quicken Mac takes these settings from what regional settings you have on your machine.

    q_lurker said:
    I believe on the WIndows side, Quicken uses the Windows setting for regional preferences to manage the comma versus period designation.  How are those set on your Win OS?  You might be able to change that setting, make the import, then change it back.
    In Quicken Windows doesn't use the Windows regional settings for this.
    Instead it uses the sDecimal and sThousand settings in:
    C:\ProgramData\Quicken\Config\Quicken.ini

    This definitely a bug that needs to be fixed in the QXF export/import.  They should have used a standardized format in the QXF instead of it taking on the format of what the machine is set to.  Of course this now leads to a mess where they have QXF files out there with different formats for this.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    @QuickStudy Please note that the newer versions of Quicken Mac don't export QIF files, so you method would only apply to people using Quicken Mac 2007 or below.

    But thanks for posting this procedure that worked for you.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/