Home Quicken for Windows All Things Canadian (Windows)
Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Delete Foreign Currency

ceschnurrceschnurr Member ✭✭
I am using Quicken Deluxe
Year: 2020,
Version: R28.15
Build: 28.1.28.15
Edition: Canada

I use two currencies $US and $Cdn. When I look at my Portfolios, I have to use the dropdown to select Portfolio currency list, which means scrolling down the long list to find $US. Quicken help says I can delete currency, but going to Tools, Currency list, selecting the currency and click 'DELETE'
https://help.quicken.com/pages/viewpage.action?pageId=3216394

I don't see a DELETE button. What am I missing?
Tagged:

Best Answer

  • UKRUKR SuperUser ✭✭✭✭✭
    Accepted Answer
    Allow me to go back to your initial question.
    Your issue has to do with switching Currency in the Portfolio View, correct?
    The pulldown selection list in the Currency field is
    • long and requires scrolling to get from top to bottom
    • (in my case) is not consistently alpha-sorted. Currencies added to the list appear at the bottom, in the order that they were added, instead of being properly alpha-sorted. (I added a corrected Euro entry to replace an incorrect one created years before the Euro conversion in 2001. And I added a few other entries while working with Community user questions)
    Personally, I would like to see the list fully sorted A-Z.
    As far as your issue about scrolling the list is concerned ... have you tried this?
    Mouse click or Tab into the Currency field so it's activated.
    Press the first letter of the currency you're trying to switch to, "U" or "C", and the list should scroll to the first entry beginning with "U" or "C". If there are multiple entries beginning with the same first letter, like "U" above, press "U" again until you get to the desired currency. The entries shown will immediately recalculate to the selected currency.
    Tab away from the Currency field or click on a line item so that scrolling the mouse scrolls the view, not the Currency field.
    How's that?

Answers

  • Quicken AnjaQuicken Anja Moderator mod
    Hello @ceschnurr,

    Thank you for reaching out to the Community to tell us about your issue, though I apologize that you are experiencing this.

    I believe the instructions provided in the Help article are based on the US model as the US version does feature a Delete button, unlike the Canada version (see example below).



    Have you tried right-clicking to see if you receive the option to delete, or using Ctrl D keyboard shortcut?
    -Quicken Anja
  • ceschnurrceschnurr Member ✭✭
    I had tried those already.
    Including selecting the currency and using SHIFT +D, CTRL+D, FN +D, WINDOWS +D, Right Click. None provided an opportunity to delete the currency.

    It's only became problematic for me recently because I split my accounts to separate the $US from $Cdn investments in order to provide accurate real time quotes. This resulted in my Portfolio View being split into a different portfolios for each currency. Which I selected in one of the Portfolio drop down boxes. Scrolling down the $US was cumbersome and I thought if I deleted the unnecessary currencies, it would simplify my problem.

    I've since realized that I an set my Portfolio view to show all currencies in the same view. So while I no longer need the ability to do delete currencies, the problem still exists.

    Thanks
  • Quicken AnjaQuicken Anja Moderator mod
    @ceschnurr Thanks for the additional information! I'm glad you were able to find something that works for you.

    I was able to confirm that the feature to delete currencies, unfortunately, is not available in the Quicken Canada version. However, if you wish to request that this feature be added in the future, what you can do is create an idea post and add your vote.

    Our Development and Product teams frequently use our idea posts in order to improve Quicken and implement new features requested by customers. This way other users who have the same or a similar request can vote on your idea.

    I hope this helps!
    -Quicken Anja
  • UKRUKR SuperUser ✭✭✭✭✭
    Accepted Answer
    Allow me to go back to your initial question.
    Your issue has to do with switching Currency in the Portfolio View, correct?
    The pulldown selection list in the Currency field is
    • long and requires scrolling to get from top to bottom
    • (in my case) is not consistently alpha-sorted. Currencies added to the list appear at the bottom, in the order that they were added, instead of being properly alpha-sorted. (I added a corrected Euro entry to replace an incorrect one created years before the Euro conversion in 2001. And I added a few other entries while working with Community user questions)
    Personally, I would like to see the list fully sorted A-Z.
    As far as your issue about scrolling the list is concerned ... have you tried this?
    Mouse click or Tab into the Currency field so it's activated.
    Press the first letter of the currency you're trying to switch to, "U" or "C", and the list should scroll to the first entry beginning with "U" or "C". If there are multiple entries beginning with the same first letter, like "U" above, press "U" again until you get to the desired currency. The entries shown will immediately recalculate to the selected currency.
    Tab away from the Currency field or click on a line item so that scrolling the mouse scrolls the view, not the Currency field.
    How's that?
  • ceschnurrceschnurr Member ✭✭
    edited February 22
    Thanks UKR. That works. Even though its not very intuitive.

    The frustrating thing for me is actually quite deeper rooted with Quicken as a company. When I purchase the CANADIAN EDITION of Quicken, I expect the Help to be written to support that edition. I've received many incorrect answers from the Help because the answer was written for the US Edition and is different for no apparent reason.
Sign In or Register to comment.