Net Worth Report Includes Hidden Accounts

The default settings on this report say that it excludes hidden accounts, but they are not excluded. Even when using the selected accounts customization, hidden accounts show up in the selection list. Is this a recent issue?

Answers

  • Quicken Anja
    Quicken Anja Moderator mod
    Hello @Lori Rose,

    Thank you for reaching out to the Community and telling us about your issue, though I apologize that you are experiencing this.

    First, could you please specify and provide which report you are experiencing this issue in, or are you experiencing this in multiple different/all reports?

    Also, could you please check each hidden account's individual Display Options and see if they are also marked as Keep separate? To do so, please follow the navigation described below.
    1. Navigate to Tools
    2. Account List
    3. Check the checkbox on the bottom-left for Show hidden accounts
    4. Click Edit next to a hidden account name
    5. Display Options
    6. Check and see if the first checkbox for Keep this account separate- account will be excluded from Quicken reports and features is checked (see example below).
     
    If it is not checked, then go ahead and check it and click Ok to save (you will need to do this one account at a time) and see if this helps resolve the issue you are experiencing in the report.

    Please check back and let us know what you find! Thank you.
    -Quicken Anja
  • Lori Rose
    Lori Rose Member ✭✭
    Hi Anja, while this works you shouldn't have to check this box. When running historical reports, you do want the account to show on reports even if it is closed or hidden for transaction entry. The better fix is for Quicken to address this issue by actually hiding hidden accounts as it says in the report settings. The report is the Net Worth report as noted in the title.
  • Quicken Anja
    Quicken Anja Moderator mod
    Thank you for your response.

    I went ahead and did some further research as well as tested this in my own personal Quicken program and received the same result, in which the feature is working as designed. Please take a moment to review this Help Article for clarification. As stated in the article under the Notes section; "Accounts must be marked as separate to be removed from reporting and other features". 

    The account selection setting you are referring to within the report itself states "All Accounts (Excludes hidden and separate accounts)". That said; unless the hidden accounts are also marked to Keep separate in the Display Options, they will still be included in the reports.

    I apologize for any confusion, though I hope this clarifies things for you! Thank you.
    -Quicken Anja
  • Lori Rose
    Lori Rose Member ✭✭
    Just because something is working as designed, doesn't mean it is working well. As an accountant, I always want to be able to run historical reports and this prevents them from being accurate (or creates a lot of extra work for me). If a report says it doesn't include hidden accounts, it shouldn't include hidden accounts. If you are including hidden accounts it should read "Excludes separate accounts" which is more accurate.
  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭✭
    edited August 2021
    Lori Rose said:
    Hi Anja, while this works you shouldn't have to check this box. When running historical reports, you do want the account to show on reports even if it is closed or hidden for transaction entry. The better fix is for Quicken to address this issue by actually hiding hidden accounts as it says in the report settings. The report is the Net Worth report as noted in the title.
    Two different levels of "hiding" accounts.  A Hidden account is simply hidden in the Account List and Account Bar but the data is still by default included in reports.  A Separate account hides it not only in the Account List and Account Bar but also by default excludes the data from reports. 
    When you check on "Show Hidden Accounts" in report customization, it will then show both levels of hidden reports in the Accounts tab.  But it will also show that Hidden accounts are by default checked so they are included in the report while Separate accounts are by default unchecked. 
    This is not a new "issue".  I have been using Quicken since 2008 and it has always been like this since at least back then.
    I do agree, however, that the Account tab of the report customization can be somewhat confusing because of this.  Perhaps it might be better on the Accounts tab to have one box for Show Hidden Accounts (and by default have it checked) and one box for Show Separate Accounts (and by default have it unchecked).  I think this would be more intuitive and less confusing than the current single box for both.
    (QW Premier Subscription: R42.21 on Windows 10)
This discussion has been closed.