Net Worth Report Bug? RESOLVED - Corrupted Report

mrzookie
mrzookie Member ✭✭✭✭
edited November 5 in Reports (Windows)
Q36.38 Win10

I just noticed that the Net Worth report display is out of synch with what's chosen in the "Interval" dropdown. If I choose interval "none", I get one column with todays' NW, which is as it should be. But, if I choose "week", I get a column for every day, which is not even a choice (although I like having it as an option). If I choose 2 weeks, I get a week, and so on down the line. My default selection is by month, which is, on its own, changing to "quarter" in the dropdown so I still get the monthly report display. When I click to bring up the report, I can literally see it change. There's a dialog box that says "searching transactions" and the interval says monthly. A second later, another dialog says "updating report" and the interval flips to "quarter".  Because it's self-adjusting, I can't say when the problem started - could be days, weeks or months ago.

Anyone else seeing this?

Comments

  • splasher
    splasher SuperUser ✭✭✭✭
    I'm running R36.38 also, but this is what my Networth Report Interval selections look like:

    There is no other customization to the report, I just ran it and immediately clicked on the Interval selection down arrow.
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • mrzookie
    mrzookie Member ✭✭✭✭
    edited November 5
    @splasher

    Interesting - I don't have the "day" option in the dropdown. This is a saved report that I've added to the Menu Bar with an icon, but no other customizations that I recall. Its been there forever, but perhaps it got corrupted somewhere along the way. I just checked the default NW report on the "Reports" menu and there IS a "day" option on the dropdown. Guess I need to delete this one, and resave a new copy to the Menu Bar (if I even can remember how to do it).

    Thanks for the info.
  • mrzookie
    mrzookie Member ✭✭✭✭
    edited November 5
    Deleted the old saved report from the Menu Bar then deleted the actual saved report. Saved a new report and added to the Menu Bar. Voila, its good. Don't know when or how, but it somehow got corrupted. Hope its OK now. 

    Thanks for the screen shot - it showed me what I needed to do.
  • splasher
    splasher SuperUser ✭✭✭✭
    Maybe you saved the original before Day was a choice and Quicken just didn't handle the transition very well.
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • mrzookie
    mrzookie Member ✭✭✭✭
    Was "Day" a fairly recently added option? If so, that probably explains it.
  • splasher
    splasher SuperUser ✭✭✭✭
    edited November 6
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • mrzookie
    mrzookie Member ✭✭✭✭
    I obviously missed that. It explains what, and why it happened. Thanks for taking the time.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    I wonder how many more people's saved reports would be corrupted by this.
    I would bet that the selection for none, day, week, ... is stored just as in index like 0, 1, 2, ...

    As such when they introduced day into the middle of that it would throw off the indexing and as such give you the wrong interval.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Tom Young
    Tom Young SuperUser ✭✭✭✭✭
    I have a saved Net Worth report created many years ago, and I just installed R36.38 recently. 
    I saw this post earlier and tried that saved report, selecting "Day" from the interval, and the report worked fine.  I then clicked on "Show Graph" and the graph behaved properly too.  I then minimized the report and minimized Quicken.
    I just now opened Quicken from the Task Bar and maximized that report and it came up looking exactly as it did this morning, correctly showing the columns and graph with the interval of Day, but now the drop down selection on the Interval menu doesn't show Day, it starts with None, then Week, and shows Week as the selected interval.
    If I select a different interval then report and graph reflect the proper interval, but selecting Week as the interval has the graph and report showing an interval of Day.
  • mrzookie
    mrzookie Member ✭✭✭✭
    @Chris_QPW - I sorta figured something like that was going on, but not knowing that the "day" interval was newly inserted into the sequence stopped me from putting the pieces together. Now that Splasher straightened me out on that, I'm almost positive that what you described is what's happening. It took me 3 months to notice it, and I use the NW report fairly often. I'm sure a lot of other folks just haven't seen it yet.