Do not want Quicken to enter any stock, fund prices into my account. How to stop it?

My Quicken stock, fund prices are one day off. I am able to get prices from Excel 365 and want to use that just once for each month myself. How can I stop Quicken from entering them, because now I have to erase each one from Quicken first?

Answers

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    If you haven't already, you may want to review: https://www.quicken.com/support/how-update-security-prices
  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭
    Click on "Update" right below the OSU button to open Update Settings.  (Note:  If you are prompted to enter your PW Vault PW, enter it and then click on "Settings"...do not hit the Enter key or click on "Update Now" or "Skip".)
    Then uncheck the box for "Download quotes and investment information".  Then click on "Apply" and then on "Close".

    (QW Premier Subscription: R37.66 on Windows 10)
  • golfbad
    golfbad Member ✭✭
    Thanks, I already had that blanked I believe. So perhaps I have something else checked to cause this. Somewhere I read (a while back) that one cannot eliminate this, but I am too old to remember. Just for info I think I am up to date on Quicken Premier and windows 10.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    golfbad said:
    Thanks, I already had that blanked I believe. So perhaps I have something else checked to cause this. Somewhere I read (a while back) that one cannot eliminate this, but I am too old to remember. Just for info I think I am up to date on Quicken Premier and windows 10.
    As explained in the referenced support documentation provided earlier (https://www.quicken.com/support/how-update-security-prices), to have the CSV import win, you need to not only disable the import of the prices from the third-party quote service but you must also disable the import of the quotes from the financial institution.  This means you would need deactivate the Online Services for the accounts that include the securities.

    I think the better question is why are the stock and fund quotes one day off.  Is your Windows machine is set to the wrong date or an inappropriate time zone?
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Looking at the order of the what method of getting prices wins, it seems that they only one that would win over importing a CSV file is entering a transaction.  So, importing a CSV should win, but there is way that might not seem like what is happening.  Say the last day of the month is the 30th and you are going to be importing prices for that date, but today is the 3rd and is a trading day (or for mutual funds a day later) then if you do a One Step Update you will get a price from the financial institution, and since its date is later that it the price that is going to be shown unless you set the date of the portfolio back to the 30th.

    I might add that some financial institutions like Fidelity will actually give a date one day newer than you would expect.
    They update their prices early the next day and give it that date.  In other words, if you update on the 4th they will send the closing price for the 3rd with a date of the 4th.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited November 2021
    Chris_QPW said:
    Looking at the order of the what method of getting prices wins, it seems that they only one that would win over importing a CSV file is entering a transaction.  So, importing a CSV should win, but there is way that might not seem like what is happening.  Say the last day of the month is the 30th and you are going to be importing prices for that date, but today is the 3rd and is a trading day (or for mutual funds a day later) then if you do a One Step Update you will get a price from the financial institution, and since its date is later that it the price that is going to be shown unless you set the date of the portfolio back to the 30th.

    I might add that some financial institutions like Fidelity will actually give a date one day newer than you would expect.
    They update their prices early the next day and give it that date.  In other words, if you update on the 4th they will send the closing price for the 3rd with a date of the 4th.
    @Chris_QPW I think you've got it backward.  Manual entry of the price is at the top.  The manual price beats quotes from the servers which beats quotes from the brokerage which beats the price from CSV which beats the price from a transaction.

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    @Sherlock yes I read it wrong, and that makes sense since I always seen the manual entry to win.

    I find it really strange that importing from a CSV is at the bottom of the list, without seeing that list I would have guessed it would be the same as a manual entry.

    At any rate, the “one day later” might still be the downloading of the transactions information after the date that is imported from the CSV.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    The fundamental is that you cannot stop a transaction from generating a price history record, but any other source can override that transaction price as the day’s closing price. 
    2). If you do not want your CSV file entries overwritten or augmented (for other days) you need to exclude Download quotes from the OSU settings, never do a Download Quotes from other menus and buttons, never do an historical quotes download, and never download transactions from your financial institutions. 
This discussion has been closed.