BUG REPORT - Confirmed and repeatable - Quicken Reports not recognizing categories

Tom39
Tom39 Member ✭✭
edited May 2022 in Reports (Windows)
Quicken Reports not recognizing categories (Win ver R37.62, Dec 2021)

I have a report I've used for years: Margin interest vs Dividend paid. This year it didn't work.

I ran through every tab to make certain they're correct. Categories (all transactions/any category), all security types, all goals, and correct categories.

Result -- it ignores the "actions" and won't show dividend and interest.

Just for attempt I changed it to show "All Actions" -- it showed my purchases, but none of my sales.

Anyone else seeing reports not working correctly?

Answers

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Did you try re-creating the report from the default Investment Transactions report?

    Sometimes internal changes to Quicken break saved reports.
    QWin Premier subscription
  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭✭
    This sounds a bit like an issue I've had in the past.  You also might want to try going to the Display tab of the report Customization, click on Reset Columns and then click on OK.  It fixed that issue for me.  Maybe it will work for you, too.
    (QW Premier Subscription: R44.20 on Windows 11)
  • Tom39
    Tom39 Member ✭✭
    I tried the Customization > Display >> Reset and click ok. That did not work.

    I did make it work, and I did find a repeatable bug.

    Steps are blow, a video showing how to recreate the bug is here:
    https://www.youtube.com/watch?v=X9IfRzNGhnE

    Step 1. I created a new report using the default "Investment Transactions" for date range "last year". All accounts listed. I then updated it to just my etrade account. Still good, but all categories.

    Step 2. I then went to Actions, and selected "clear all" and then only "Div" and "MargInt". Again, it worked. Still too many columns, however.

    Sept 3. Go to Customize >> Categories. Select "Include only transactions with selected categories." Change NOTHING but click "OK". You will get the same report, it works just fine.

    Step 4. Customize again >> Categories. Select "Include transactions with any category (including uncategorized." Select OK. Everything disappears, and no matter what you do from there, you can't kick it back.

    In fact, if in step 3 you simply click the second radio button, then click back up, then hit OK (you changed NOTHING), the report will be destroyed and unrecoverable (old ones in history list still work).

    So there it is - if a saved report fails, you have to recreate it piece by piece, like a house of cards, saving each step on the way. Thankfully, reports keeps a history of changes so you can step back when a mistake or failure occurs, and try again. I'll report his using the in-program tool as a bug.
  • Tom39
    Tom39 Member ✭✭
    > @Jim_Harman said:
    > Did you try re-creating the report from the default Investment Transactions report?
    > Sometimes internal changes to Quicken break saved reports.
    Yes, thank you, this fixed it. I created a video on reproducing it and changed the title of this post to include "BUG REPORT".
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited January 2022
    I noticed you neglected to select Show (hidden categories) on the Categories tab prior to selecting Select All.  The implication is that you may be unintentionally excluding a range of built-in investment categories including _DivInc and _IntExp.

    Note: I've previously raised a report customize issue where Quicken mistakenly believes all items have been selected when they're not.  The work around is to maintain an unhidden but unchecked item.
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    In my somewhat limited testing follow-up, I am seeing the behavior you identify.  

    I will generalize it a bit further.  My preference setting is to "Customize Report/graph before creating" such that I am always prompted to customize the report when I first create it.  So for me:

    1.  Initiate an Investment Transactions Report customizing to "include only transactions with selected categories. but leave all categories selected (Your Step 3).  You'll have report for all accounts, all actions, all categories.  A limited time frame like Last Month makes the data more manageable.

    2.  Customize that report for the categories now to "include transactions with any category ...".  You'd expect the same report.

    Whereas the initial report appears to show all transaction actions, the second version seems to show a more limited set.  I see only actions of:
    • Cash
    • Bought
    • Sold and SoldX
    • Removed
    • Added
    I see no Div, CG..., IntInc, RtrnCap.  Both regular and reinvested versions appear to be omitted on the reset.  I suspect that is why you got to an empty report.  Your action selection had eliminated the Cash, Bought, Sold, etc.  Since my transaction list is not all inclusive, I can't say for sure what actions are being incorrectly omitted on the reset.  

    HTH
      
  • Tom39
    Tom39 Member ✭✭
    > @Sherlock said:
    > I noticed you neglected to select Show (hidden categories) on the Categories tab prior to selecting Select All.  The implication is that you may be unintentionally excluding a range of built-in investment categories including _DivInc and _IntExp.
    > > Note: I've previously raised a report customize issue where Quicken mistakenly believes all items have been selected when they're not.  The work around is to maintain an unhidden but unchecked item.

    It took me a little bit to figure out what you meant. From the start of the video, you can see that under the Category column, "_IntExp" and "_DivInc", and at the 1min20sec mark, you can see that when I go to the "include only transactions with selected categories", that the "show hidden categories" is checked/selected, when I click OK. So I kept watching.

    I think you're referring to 2m15s. When I return to the options after showing the report failure, Categories Tab, lower radio button for "Include only transactions with selected categories", then the box for "show hidden categories" has unchecked itself.

    I played with that and you got it. If you select the lower radio button, then back to the top, Quicken automatically unchecks all the hidden categories like "_IntExp" and "_DivInc".

    I showed hidden, checked all again, and the report worked.

    On a whim, now that it's all working, I re-attempted the Categories tab top radio button --
    "Include transactions with any categories (including uncategorized)".
    And remember, I have again forced quicken to select all, including hidden categories.

    And once again, the report does not work. The first use of top radio button works correctly (any/all categories). All subsequent use will exclude the hidden categories without alerting the user.

    Thank you for spotting that. Hopefully quicken will review this and fix the bug.
  • Tom39
    Tom39 Member ✭✭
    > @Sherlock said:
    > I noticed you neglected to select Show (hidden categories) on the Categories tab prior to selecting Select All. The implication is that you may be unintentionally excluding a range of built-in investment categories including _DivInc and _IntExp.
    > > Note: I've previously raised a report customize issue where Quicken mistakenly believes all items have been selected when they're not. The work around is to maintain an unhidden but unchecked item.

    It took me a minute to figure out what you meant, because I was showing those in the video. The I kept watching and you got it.

    "Show Hidden Categories" is checked at 1:50. I switch to the top radio button "Include transactions with any category (including categorized)". Then the report fails.

    At the 2:15 point, I return to the categories tab after the report failure, the lower radio button ("Include only transactions with selected categories") -- and the box for "Show Hidden Categories" is unselected. By itself.

    It appears the top radio button "Include transactions with any category (including uncategorized)" works once and only once. If you look at the lower radio button ("Include only transactions with selected categories"), and go back to the top one, Quicken will unselect all hidden categories from then on, causing the report to fail.

    Once I selected "show hidden categories" and then selected the hidden categories, the "broken report" worked. Except I can never use the top radio button again, until Quicken fixes the bug.

    Thank you
  • q_lurker
    q_lurker SuperUser ✭✭✭✭✭
    Yep -- that is what was catching me as well.  I can't believe that was the intent of the programming specification, thus I would think it would still qualify as a bug.
  • I am having problems generating reports from my in my investment accounts also.
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited April 2022
    @[email protected]
    Please try this:
    • When you open one of the problem reports, click on the gear at the top right to customize it and select the Categories tab.
    • Choose the lower "selected Categories" option and click on the Show hidden categories checkbox to select it. 
    • Now you should be able to go back to the All Categories selection and the special investing income categories should be included in the report.
    Please post back and let us know if that fixes your problem. 

    If that does not fix your problem, please start a new discussion and describe the issue in more detail.
    QWin Premier subscription
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    edited April 2022
    I did an experiment with the built in Itemized Categories report, which demonstrated a variation on the problem described above. I am running R39.23
    In my file, some transactions use Hidden Categories.
    When I first open the report, the transactions with the hidden categories are included.
    If I go to the Categories tab in the report customization, the all categories (includes hidden) option is selected so the report shows what I would expect.
    If I switch to the Selected categories option, the Show Hidden categories checkbox is selected and the report still shows the hidden categories as expected.
    Now I go back to the customization and de-select the Show Hidden Categories box. The hidden categories are now not included in the report, still as expected.
    But now I go back to the customization again and select the all categories (included hidden) option. I would expect the report to now include the hidden categories.
    -- BUT NO -- the hidden categories are missing from the report even though "all categories (includes hidden)" is selected. When I changed to the All categories option, it is still honoring the Show hidden selection in the Selected Categories option even though that is no longer displayed. This is clearly a bug I think. 
    It should remember the Show hidden setting in the Selected Categories but when you choose "all categories (includes hidden)", it should do what the option says and include the hidden categories in the report.
    This may seem like an obscure bug, but it is certainly confusing quite a few users. It is particularly important because the  special Investing Categories that begin with underscores are hidden by default. 
    I get the same behavior with the Investment Transactions report. I did not test it with other reports or with other customization tabs, but I assume it affects them as well.
    QWin Premier subscription
This discussion has been closed.