Simple Investing randomly enabling....

hmday
hmday Member ✭✭✭✭
edited March 25 in Investing (Windows)
 I have turned off the option to "Enable Simple Investing" in Edit/Preferences/Investment Transactions. However, periodically enables and screws up the downloads in my Schwab accounts. Anyone know what causes it to enable and how i can prevent it from enabling? I can figure out what triggers it to enable...

Best Answer

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Answer ✓
    Quicken software updates sometimes enable Simple Investing when they should not.

    For each affected account, click the gear at the top right, pick Edit account details, and select Complete in the Tracking Method box.

    Then go to Edit > Preferences > Investment transactions and un-check the Enable Simple Investing box.

    If you just un-check the setting in Preferences and Quicken checks it again, the accounts will switch back to Simple.


    QWin Premier subscription

Answers

  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    Answer ✓
    Quicken software updates sometimes enable Simple Investing when they should not.

    For each affected account, click the gear at the top right, pick Edit account details, and select Complete in the Tracking Method box.

    Then go to Edit > Preferences > Investment transactions and un-check the Enable Simple Investing box.

    If you just un-check the setting in Preferences and Quicken checks it again, the accounts will switch back to Simple.


    QWin Premier subscription
  • hmday
    hmday Member ✭✭✭✭
    Thanks I will try it. 
  • Dave Mayer
    Dave Mayer Member ✭✭
    The "Tracking Method" box does not show when I go to my investment account details. How do I get to the "Tracking Method" box?
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    The "Tracking Method" box does not show when I go to my investment account details. How do I get to the "Tracking Method" box?
    When the global setting is off, the investing mode is hidden and should be defaulted to Complete:
    Edit -> Preferences -> Investment transactions -> Enable Simple Investing (position-only)
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    To use Simple mode, you have to change the setting at Edit > Preferences > Investment transactions first.
    QWin Premier subscription
  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭
    @hmday - I, too, have been experiencing the random switches from Complete Investing to Simple Investing.  For me they usually occur every 3-5 days and can happen at any time while the data file is open.  If not caught right away it can cause some significant investment account issues (missing transactions, account and securities performance integrity issues, tax reporting/planning issues) for anyone who wants/needs Complete Investing.
    Are you still seeing this issue pop up?
    If so and if you have not already done so it would be great if you would report this issue to Quicken.  You can do it via Phone call or Online Chat (https://www.quicken.com/support#contact-support...be sure your popup blockers are off if you want to use Chat) or via Quicken at Help > Report a Problem.
    (QW Premier Subscription: R39.23 on Windows 10)
  • hmday
    hmday Member ✭✭✭✭
    I followed the advice given in this thread and I think I solved that problem. I enabled Simple Investing Global option in Preferences/Investing Transactions Investing. I then opened each individual account (Account Details/General tab) and enabled Complete Investing for each account. Then I disabled Simple Investing at the Global option under Preferences/Investing Transactions. 
    Simple investing is still randomly enabled but now when it randomly enables Simple Investing it does not change my individual account selection.
    I did report via Help>Report a Problem
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    @Boatnmaniac this lines up directly with my belief on how they are storing the global preference.

    Some preferences are stored in the data file, others are stored in configuration files.

    The behavior you are seeing lines up with another preference getting changed all the time.


    Every once in a while, this setting will get set.  This has been going on for many years.

    So, it is important where they are storing the given preference, because clearly some of them are being "reset to defaults" occasionally when updates come in.  Note "updates" isn't just the patch installs.  Quicken updates certain files at startup periodically.  For instance, it updates the financial institution list this way.

    The history on this preference is clear to me.  They never intended it to be a permanent preference:
    When it first showed up it had "beta" on the text, and when they decided it was "tested enough" they actual removed this setting and set the default to on.  For the people that were using it as a global way to turn it off, that meant that instantly there was a possibility of all of their accounts going into simple mode.

    They sent out "hot patch" really quickly to restore the preference, but the die was cast.  They were now storing the preference in a way that it will get set back to the default from time to time.

    If they tried to move it to be stored in the data file, the switch over would most likely cause all kinds of people complaining when it wasn't set right.

    BTW I think you can see by the text alone; this was the intent.


    You aren't enabling simple mode with this setting. What you are doing is enabling the possibility of using simple mode.  As in this preference makes this setting in the Account Details visible.


    I personally have no idea if the global preference is getting reset on my file from time to time since from the start, I never tried to use it as a global way to control this.  I leave it on, and make sure the setting in the Account Details of ever investment account is set right.  I don't actually use Simple mode for any of my accounts, they are all set to Complete.  I have never had one of the individual account settings change.  I'm sure that these are stored in the data file and not subject the "reset to default on some updates".
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • GeoffG
    GeoffG SuperUser ✭✭✭✭✭
    edited February 26
    What's even more interesting/confusing is while never having experienced the setting issue I never could understand the account setting reference mentioned in other posts. 

    My global setting has never been set,


    and I have no account level option on any of my investment accounts.


    user since '92 | Quicken Windows Premier - Subscription | Windows 11 Pro version 21H2
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    @GeoffG that is interesting.  I have no idea why some people seem to be hit with the global setting changing and others not, but maybe in your case because you never changed it, it is somehow "defaulted to off".  Without seeing the code, it would be impossible to really know what exactly is going on.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
This discussion has been closed.