R39.17 - Investment register formatting missing info - messed up the two-line mode.

swcampos
swcampos Member ✭✭
The Investment register is missing transaction type on SOME transactions and only the Memo appears on the line. Other lines have the transaction type but the Memo line is missing. If I click on the line ALL the information appears like it should.

I have tried changing the Register Row Height Setting, but none of the setting makes a difference. It is only happening on accounts that do NOT have the 2-line display option.

Best Answer

  • Quicken Anja
    Quicken Anja Moderator mod
    edited March 8 Answer ✓
    Hello All,

    Thank you for taking the time to visit the Community and reporting this bug, though I apologize that you are experiencing this.

    This bug has been confirmed internally and I have gone ahead and submitted a bug report for this to our Development and Product teams for further investigation and resolution.

    Unfortunately, we won't have an ETA on this. However, once a solution is created it will be made available as part of a future update release.

    Thank you for your patience and for bringing awareness to this issue!
    (CTP-3496)
    -Quicken Anja

Answers

  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Investment accounts all share the same settings, so it is impossible to have some accounts in 1-line mode and others in 2-line mode.

    As for what is displayed, yes it varies depending on the transaction type.  Basically, they have far more fields of information to display than columns in the investment register, so they cram what they think is important for a given transaction into the Description field for 1-line mode.  Note when you select a transaction it is displayed in two-line mode no matter which line mode it is in.

    So, if you want to see all the information, for all the transactions, you need to be in two-line mode.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • swcampos
    swcampos Member ✭✭
    This behavior just changed with the last update.

    Prior the register would display one the first line: Attachment, Cleared status, Date, Action, Security, Description, Share Balance and Investment Amount. The second line would display: Memo, Cash Account.

    Now on only SOME transactions are one or the other line is missing. There appears to be no consist transaction causing the problem.

    I have a series of "Added" transactions ALL have the same Memo and Cash Account entries, i.e. moved security to a different account.

    Here is the problem:
    1. There are two transactions one above the other that have the same type.
    2. The first line of the lower transaction is appearing on the Memo line of the upper transaction.
    3. If you select the lower transaction that is on the Memo line you see the lower transaction.
    4. If you select the Memo line of the lower transaction then the register then looks like it should.
    5. If you don't select the upper transaction and browse the register WITHOUT causing the screen to change, i.e. scroll page up or down, then the register looks as it should. However, if you scroll and come back to this page the register has missing lines. This behavior is random as you scroll through the register.
    6. I have done a validate and found no problems to be fixed.
  • swcampos
    swcampos Member ✭✭
    Here is another example.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    OK I see what you mean. They have messed up the two-line mode.

    I'm normally in one-line mode so I didn't really notice it.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser ✭✭✭✭✭
    I see this new bug also. Very frustrating how they can randomly mess up stuff that's been working fine. I am always in 2-line mode, and now I see stuff like this.

    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    Here is a side-by-side comparison.


    Very frustrating how they can randomly mess up stuff that's been working fine. I am always in 2-line mode, and now I see stuff like this.

    This isn't "random" bug.  From the release notes, under what's fixed (which didn't even know it was "a problem"):


    So, they decided (for some reason) that transactions for a given day needed to be sorted by security instead of how you entered them/date and didn't take into account two-line mode where the line shading toggles.

    The "order" change is "intentional" the "grouping" of the lines isn't.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Rocket J Squirrel
    Rocket J Squirrel SuperUser ✭✭✭✭✭
    I use the word "random" in its most general sense. :wink:
    Speaking of sense, the change makes none:
    Multiple investment transactions from the same day are now sorted alphabetically by security name instead of by date.
    How can you sort multiple transactions from the same day by date? They all have the same date.
    Quicken user since version 2 for DOS, now using QWin Premier Subscription on Win10 Pro.
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    P.S. Even though the release notes say sort by security it looks like they are sorting by action type.  Notice my two sells are grouped together in the new one on the right?

    They were entered as you see on the left.

    As a test I just entered a buy for this day for that security.


    It sorted after the sells.

    I think this "feature/fix" is completely wrong.  I'm betting it is for someone seeing negative balances or the wrong number of shares, at a given point.  But the order of investment transactions is very important, you can't just arbitrarily reorder them.

    And of course, you can't mess up the formatting in the process!
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • miklk
    miklk SuperUser, Windows Beta Beta
    edited March 4
    Yes, this is a pretty disturbing BUG. I don't like messed up investment transactions. (I obviously am seeing this one too)
  • Quicken Anja
    Quicken Anja Moderator mod
    edited March 8 Answer ✓
    Hello All,

    Thank you for taking the time to visit the Community and reporting this bug, though I apologize that you are experiencing this.

    This bug has been confirmed internally and I have gone ahead and submitted a bug report for this to our Development and Product teams for further investigation and resolution.

    Unfortunately, we won't have an ETA on this. However, once a solution is created it will be made available as part of a future update release.

    Thank you for your patience and for bringing awareness to this issue!
    (CTP-3496)
    -Quicken Anja
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    edited March 8
    @Quicken Anja does the bug report include the fact they can't sort by security per day?
    Or at least they need an option that allows that to be turned off.

    The order that investment transactions go into the register is extremely important.

    Here is another example of why this sorting is wrong.
    The original transactions were entered:
    Sold
    MisInc
    MiscExp
    MiscExp
    Misc Exp
    Sold

    The new sorting put the Solds together.  Look at the totaling of the shares.


    It is pretty clear that they are doing "post sorting".  As in the transactions never changed in the position in the actual data.  All they did is before displaying the transactions they did this sorting.  As you can see you can't just rearrange the transactions in an investment account and still get the right results.

    And it would be VERY good idea if the developers would state what problem they were trying to fix, because as far as I know there wasn't a problem with the sorting order before.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    And here is something else wrong with this.  As you enter the transactions they are sorted.  So, instead of seeing the transactions appear one after the other in the register they "jump" to different spots.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    In R39.23 it looks like they reversed their decision to sort by security.  In other words, they fixed both the "formatting" and the "order" problems stated in this thread, by reverting to what it was before they made this change.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • Chris_QPW
    Chris_QPW Member ✭✭✭✭
    P.S. Thanks to the developers.  I think that was the proper thing to do.
    Signature:
    (I'm always using the latest Quicken Windows Premier subscription version)
    This is my website: http://www.quicknperlwiz.com/
  • miklk
    miklk SuperUser, Windows Beta Beta
    Smart decision. 39.23 seems fixed to me along with all the other 39.xx problems
This discussion has been closed.