Invoice discounts not working properly: discount amount reverts to zero.

Before saving an invoice with discount item(s), the discount(s) appear correctly; however, after saving the discount amount reverts to zero (0.00).

I have screenshots to share, and I have upgraded to latest version/build of Quicken (R40.21. Build 27.1.40.21.

Please help. Thanks.
Tagged:

Best Answer

  • UKR
    UKR SuperUser ✭✭✭✭✭
    Answer ✓
    Thanks for the images.
    It has always been my understanding that a "subtotal" line item applies to all the line items above, not a subset of just a few line items. With it came my assumption that you could have only 1 subtotal line item per invoice.
    The "discount" line item when defined with Rate = -xx and "percentage" checked applies to the preceding line item or subtotal item. In that case it's a calculated line item and you cannot enter a finite amount.
    If you want to give a fixed amount of discount, e.g., $45.00, you need to redefine the item definition as if it was a regular sale item, with a rate of -45 and "percentage" not checked. Then, when entering the discount item, enter Qty =1, verify rate = -45 (or override) and you should get a correct $-45.00 discount item that survives saving the invoice, and you should be able to have as many of those as you need per invoice.
    I noticed that you appear to have customized your invoice format and removed the Qty. and Rate (price per item) columns. IMHO, it would be better to put them back in. Qty. = 1 is not assumed for every item and may need to be specified whenever someone buys more than 1 of the same item.

Answers

  • UKR
    UKR SuperUser ✭✭✭✭✭
    Yes, please do show us the screenshots.

    Can you please capture one or more images of the parts of your Quicken window showing the issue, sensitive information blacked out as necessary to protect your privacy but annotated to describe the situation, and attach the image(s) here?
    https://community.quicken.com/discussion/7867159/faq-how-do-i-post-a-screenshot-in-the-community-from-windows

    https://community.quicken.com/discussion/7663259/faq-how-do-i-post-a-screenshot-in-the-community-from-a-mac

    Please save images to files of file type PNG, JPG, or GIF only. They're easier to work with than PDF files.

  • dovetaler
    dovetaler Member ✭✭
    There is nowhere for me to add/attach/upload the screenshots.
    "...you can post it to the Community by clicking the image icon in the row of editing tools above the text entry box of your post as shown here:"

    There are no editing tools in my text entry box. The header just reads, "Leave a Comment"
  • Greg_the_Geek
    Greg_the_Geek SuperUser, Windows Beta ✭✭✭✭✭
    Just drag the image to the text box.
    Quicken Subscription HBRP - Windows 10
  • dovetaler
    dovetaler Member ✭✭
    What an idiot I am!! Thanks @Greg_the_Geek
  • UKR
    UKR SuperUser ✭✭✭✭✭
    Answer ✓
    Thanks for the images.
    It has always been my understanding that a "subtotal" line item applies to all the line items above, not a subset of just a few line items. With it came my assumption that you could have only 1 subtotal line item per invoice.
    The "discount" line item when defined with Rate = -xx and "percentage" checked applies to the preceding line item or subtotal item. In that case it's a calculated line item and you cannot enter a finite amount.
    If you want to give a fixed amount of discount, e.g., $45.00, you need to redefine the item definition as if it was a regular sale item, with a rate of -45 and "percentage" not checked. Then, when entering the discount item, enter Qty =1, verify rate = -45 (or override) and you should get a correct $-45.00 discount item that survives saving the invoice, and you should be able to have as many of those as you need per invoice.
    I noticed that you appear to have customized your invoice format and removed the Qty. and Rate (price per item) columns. IMHO, it would be better to put them back in. Qty. = 1 is not assumed for every item and may need to be specified whenever someone buys more than 1 of the same item.

  • dovetaler
    dovetaler Member ✭✭
    I appreciate your help. I actually tried not using the subtotal first, but the same thing happened. That's why I tried to use the subtotal item... to see if maybe writing the invoice that way would work.

    In any case--when I added the QTY/RATE back in so it appears on the invoice, then re-entered the invoice, everything worked as expected.

    FYI, each time I customized the invoice by checking or unchecking the QTY/RATE and then closed the customize invoice window, Quicken crashed. To Quicken Team: Can you log this as a bug?

    Thank you @UKR, I'm grateful for your insight!
  • UKR
    UKR SuperUser ✭✭✭✭✭
    dovetaler said:
    FYI, each time I customized the invoice by checking or unchecking the QTY/RATE and then closed the customize invoice window, Quicken crashed. To Quicken Team: Can you log this as a bug?
    You're welcome. glad I could help.
    Next time that crash happens, if possible please send a crash report to Quicken then contact Quicken Support on the phone during posted hours of operation to get the wheels rolling.