Net worth report Interval: Saved Report Issue

Anil
Anil Member ✭✭
edited August 10 in Reports (Windows)
I customized the Net worth report a bit. It was working fine until a few day back. In the date range I used 'Earliest to date' in the past and then I changed it to 'Custom to Date' . I always used Year as the interval. After I changed it to custom to date the Interval never works. As you can see the report shows half year even if the interval is set to year. Also I noticed that after I save the report and re-open again, the report doesnt hold the custom to date and it always shows Last 12 months. What am I missing here ?

Best Answer

  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭✭
    edited August 7 Answer ✓
    @Anil - Which version of Quicken are you running?  Help > About Quicken will show this information.
    About a week ago I updated to version R42.21.  A couple of days ago I noticed that all of my customized reports no longer returned the correct results, nor would they properly save any new customizations.
    I ended up deleting all of my customized reports, pulled up new default reports, customized them and saved them.  Then all of them were OK, again....except for Net Worth.  The newly saved customized Net Worth report opens like the default and then will change to the customized report after a couple of seconds.  Something weird is going on.
    I'm assuming my issue has something to do with R42.21 but do not know that for sure.  If you are running version R42.21 then that might be causing the issue you are seeing.  You might what to try doing what I did to see it that resolves the issue for you:  Delete your currently customized Net Worth report, open a new default Net Worth report, customize it, save it, close it and then open it.  Did this resolve the issue for you?
    (QW Premier Subscription: R42.21 on Windows 10)

Answers

  • NotACPA
    NotACPA SuperUser ✭✭✭✭✭
    Except, your jpg is showing a chart .... not a report.  Care to clarify?
    Q user since DOS version 5
    Now running Quicken Windows Subscription, Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • Jim_Harman
    Jim_Harman SuperUser ✭✭✭✭✭
    @Anil
    Please go to Help > About Quicken and let us know what version of Quicken you are running. The Day interval has been added in current versions and for a time that caused a problem with selecting intervals.

    Another possibility is that you are using a report saved when this problem was present. Try creating a new report based on the standard report at Reports > Net Worth & Balances > Net Worth. and see if it has the same problem. 
    QWin Premier subscription
  • Anil
    Anil Member ✭✭
    > @NotACPA said:
    > Except, your jpg is showing a chart .... not a report.  Care to clarify?

    Its a chart in the report. I just took the screenshot of the chart. There is a report that is inline with the chart data.
  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭✭
    edited August 7 Answer ✓
    @Anil - Which version of Quicken are you running?  Help > About Quicken will show this information.
    About a week ago I updated to version R42.21.  A couple of days ago I noticed that all of my customized reports no longer returned the correct results, nor would they properly save any new customizations.
    I ended up deleting all of my customized reports, pulled up new default reports, customized them and saved them.  Then all of them were OK, again....except for Net Worth.  The newly saved customized Net Worth report opens like the default and then will change to the customized report after a couple of seconds.  Something weird is going on.
    I'm assuming my issue has something to do with R42.21 but do not know that for sure.  If you are running version R42.21 then that might be causing the issue you are seeing.  You might what to try doing what I did to see it that resolves the issue for you:  Delete your currently customized Net Worth report, open a new default Net Worth report, customize it, save it, close it and then open it.  Did this resolve the issue for you?
    (QW Premier Subscription: R42.21 on Windows 10)
  • Anil
    Anil Member ✭✭
    > @Boatnmaniac said:
    > @Anil - Which version of Quicken are you running?  Help > About Quicken will show this information.
    > About a week ago I updated to version R42.21.  A couple of days ago I noticed that all of my customized reports no longer returned the correct results, nor would they properly save any new customizations.
    > I ended up deleting all of my customized reports, pulled up new default reports, customized them and saved them.  Then all of them were OK, again....except for Net Worth.  The newly saved customized Net Worth report opens like the default and then will change to the customized report after a couple of seconds.  Something weird is going on.I'm assuming my issue has something to do with R42.21 but do not know that for sure.  If you are running version R42.21 then that might be causing the issue you are seeing.  You might what to try doing what I did to see it that resolves the issue for you:  Delete your currently customized Net Worth report, open a new default Net Worth report, customize it, save it, close it and then open it.  Did this resolve the issue for you?

    I am on R42.21 as well. I am hoping the numbers in the reports are correct, except it doesnt hold the dates and the interval filters when saved. I havent opened the actual report and re-customized it. I will let you know as soon as I have done that. I am assuming everyone might be having this issue once upgraded to this build.
  • Anil
    Anil Member ✭✭
    I just re-customized the original report and it works fine after changing the dates and the interval. I am not sure if this issue is specific to the Net Worth report or others as well.
  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭✭
    Anil said:
    I just re-customized the original report and it works fine after changing the dates and the interval. I am not sure if this issue is specific to the Net Worth report or others as well.
    Thanks for letting us know it fixed the issue for you.  As I mentioned above, the issue for me affected all of my saved customized reports so I'm guessing that it affects any other saved customized reports you might have.
    I have reported this problem to Quicken.  I encourage you to do the same (Help > Report a Problem) so they can look into it further and put in a fix with a future version update.
    (QW Premier Subscription: R42.21 on Windows 10)
  • Bill West
    Bill West Member ✭✭✭
    I have the same issue and it has been happening for several releases.  I am on the current subscription release for QW: R43.14 build 27.1.43.14.
    It appears to occur when there is more than one report saved in report history, as follows:

    1) When creating a net worth report, the drop-down list for the time intervals includes: day, week, two weeks, month, etc. 
    2)  When adding a 2nd report, the drop-down list shows the same time intervals.

    Once that report is SAVED (with all reports in report history) and retrieved, the 1st report continues to have the day interval in the drop down list. However, any following reports start with the "week" interval (not "day") and everything displayed for that report is off by one interval.  That is, selecting interval "week" produces a day report," two weeks" produces a weekly report.

    Again, this interval issues occurs only for the secondary reports that have been saved in report history.

    Here is any example of the interval drop down list in the 1st report vs the 2nd report.

    Once saved, the first report in report history displays intervals correctly. (see below)



    The 2nd report in report history displays intervals incorrectly.  Selecting "week" interval displays a daily interval report. Note: there is no "day" in this drop-down list.  Again, it only occurs once saving a report and then running it.



  • Bill West
    Bill West Member ✭✭✭
    edited August 28
    I have this same issue.  It has been happening for several releases - likely when Quicken added the "day" option for the time interval in Net Worth reports.   Here is what I have found:
    1) When creating a Net Worth report, the interval drop-down list is "day, week, two weeks, half month, ..."
    2) When creating a 2nd report (such as selecting only investment accounts), the interval options are the same.
    Once the report is SAVED (with both reports listed in Report History) and then retrieved, the 1st report in Report History has the drop-down intervals as above ("day, week, two weeks, half month..."). However the 2nd report in Report History only starts with "week" in the drop-down list.  And, interval options are off by one period.  That is, selecting "week" in the report displays a "day" report, selecting "two weeks" displays a "week" report.
    See below for examples.
    This is the drop down list for the 1st report in report history:

    Here is the drop down list for the 2nd report in Report History. Selecting "week" displays a "day" report. Again, this only occurs once a report with mulitple reports in Report History has been SAVED.

    I am currently running the latest QW subscription release: 43.14.