Status of R42.21

hmday
hmday Member ✭✭✭✭
Is R42.21 still being tested or is it released for all?

Answers

  • NotACPA
    NotACPA SuperUser ✭✭✭✭✭
    I believe that R42.21 is in "General Release"  I'm running it without problems ... but I don't use QWeb or QMobile
    Q user since DOS version 5
    Now running Quicken Windows Subscription, Home & Business
    Retired "Certified Information Systems Auditor" & Bank Audit VP
  • hmday
    hmday Member ✭✭✭✭
    Thanks I don't use Qweb or Qmobile either, I will give it a try. Just never sure if we are waiting for a hotfix for the hotfix!
  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭✭
    The Announcement still shows it is in staged release (Windows R42.XX Release (US)) but I'm guessing that it is already in general release and that the Announcement simply has not yet been updated to reflect that.
    BTW, when a new version is in a staged release status it means that testing has been completed.  It's just that they are pushing it to a subset of everyone so they can get some feedback about any issues that might be identified.  However, even though it has been pushed only to that subset, anyone can download and install it...because it has been released.  These staged release Announcements do include a link so that anyone can download and install it if they wish to.
    That all being said, an easy way to determine if it has now been made available as a general release:  Help > Check for Updates.  If the result is R42.21 and it gives you the option to update, that's a really good indication that it is now a general release.
    I, too, have R42.21 installed.  It has been working well for me with one possible caveat: A few days after updating to R42.21 all of my custom saved reports returned odd results.  I ended up needing to delete all of my customized saved reports, pulling up new default reports, customize them and then save them.  After that everything was fine.  I do not know for sure that my saved reports issue was caused by R42.21 or if it was caused by something else.  I have seen only one other person reporting a similar issue.  If this were general issue with R42.41 I would think more people would have been affected by it and would have posted about it here but that does not appear to be the case.

    (QW Premier Subscription: R42.21 on Windows 10)
  • KenS Fin
    KenS Fin Member ✭✭
    I am on 42.21 and it has been completely unstable, crashing everytime I open it. Most of the crashes have been during updates, and all quicken server based updates are failing.
  • Boatnmaniac
    Boatnmaniac SuperUser ✭✭✭✭✭
    edited August 12
    KenS Fin said:
    I am on 42.21 and it has been completely unstable, crashing everytime I open it. Most of the crashes have been during updates, and all quicken server based updates are failing.
    Did you try restoring a recent backup (dated from before the update to R42.21)?  That will often resolve issues encountered right after a version update.  I have seen a few other posts where people who had upgraded to R42.21 had some issues but after restoring their backup file the issues were fully resolved.
    Also, I see you have not posted anything regarding this crashing issue and "all quicken server based updates are failing."  I suggest you start a new thread on these issues providing some more specifics so others can know and have a chance to reply with perhaps some ideas that might help to resolve them.  Either that or reporting the problems to Quicken.
    (QW Premier Subscription: R42.21 on Windows 10)
  • jr_ece
    jr_ece Member ✭✭✭✭
    edited August 20
    Update: Started with a backup from 2 days ago. Restored fine. Data looks okay other than the expected data losses between now and the backup date. I've repeated last nights steps of updating with One Step Update and everything seems to be working fine this morning. I've also run Validate File to confirm there is no data file corruption. All of this is with R42.21. I've NEVER had this specific issue (although plenty of other data integrity issues!) so I feel that it is likely related to R42.21 since it happened in the first 48 hours of using it. But, it's not repeating yet. I'm torn on reverting to R42.8 or sticking with R42.21 that I trust slightly less.

    Original Post:
    I switched to R42.21 approximately 2 days ago after holding off for a few weeks. It appeared to work fine at first until this evening. Eight of 8 investing accounts have had all of their transactions completely wiped out.  I also have a couple of savings accounts that show gazillion dollar values in the side bar and Ending balance but all transactions are also gone. The only thing I've done this evening is run One Step Update. It looks I'm on hold with using Quicken again until I can find a window of time to rollback with a restore and walk through all the data to see what else is lost. This is really getting old...

This discussion has been closed.