Possible Bug: Quicken Changing Transaction Dates to Posted Dates

Hi all. I have been using Quicken for Mac for a couple years now. I have been experiencing an issue lately where Quicken changes my transaction dates to the bank's posting date.

I know this is an optional feature that can be enabled from Quicken Preferences>Connected Services>Downloaded Transactions. However, I do NOT have the "Use posted date for matched transactions (instead of the date you enter manually)" option selected.

This has been very annoying. Especially for someone who is very picky about their data. I've reported this issue several times now, beginning several weeks ago. No updates or acknowledgement yet. Is anyone else experiencing this?

Best Answer

  • Quicken Anja
    Quicken Anja Moderator mod
    edited January 13 Answer ✓
    Hello All,

    Thank you for taking the time to visit the Community to report this issue, though we apologize that you are experiencing this.

    The link previously provided is inaccessible as that alert in particular has been marked resolved.

    However, since we are still receiving reports for this issue, we have gone ahead and forwarded this to the proper channels to have this reinvestigated. In order to do so, we request that you please navigate to Help > Report a problem within your Quicken program and submit a problem report with log files attached to contribute to the investigation. Please add "Attn: CTP-5524" to the title/subject line. 

    While you will not receive a response through this submission, these reports will help our teams in further investigating the issue. The more problem reports we receive, the better.

    We apologize for any inconvenience in the meantime! Thank you.
    -Quicken Anja

Answers

  • RickO
    RickO SuperUser, Mac Beta Beta
    There is an ongoing alert for this: https://community.quicken.com/discussion/7924677/ongoing-12-13-22-quicken-for-mac-date-of-manual-transactions-are-changing-when-cleared#latest

    Some users have been able to resolve it by deleting the Quicken preferences file and then resetting all of their preferences. Here's that process:

    1. Quit Quicken
    2. Locate the quicken preferences file at Users:(your username) :Library:Preferences:com.quicken.Quicken.plist (click the Go menu in Finder with Option key held down to access your user Library folder)
    3. Move the plist file to the Desktop (so you can put it back later if needed)
    4. Launch Quicken (a new preferences file will be created with default settings)
    5. Check that the option to change dates box is NOT checked
    6. Reset preferences as needed (It would be helpful to save screenshots before starting)
    7. Test to see if the issue is resolved.
    Let us know if this works.


    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • mbates311
    mbates311 Member ✭✭
    From Quicken > Settings > Connected Services, in the Downloaded Transactions section I have unchecked the "Use posted date for matched transactions (instead of the date you enter manually)" box. However, all of my matched transactions are still getting switched to the posted date. This is very frustrating especially around this time of year when I have numerous transactions. Please help.
  • islenot
    islenot Member ✭✭
    I'm having the same problem over the past 2 weeks. Tried resetting, closing, and reopening multiple times and that hasn't fixed it. Hoping someone will have some suggestions for us.
  • mbates311
    mbates311 Member ✭✭
    @"Quicken Anja" I have phoned, left a post here, and submitted a Problem Report. I was told to copy my Quicken file to a new one and redo everything to see if that fixes the issue. I have tried every option. Any further troubleshooting on my part and I am going to send Quicken my bill rate for IT level 3 troubleshooting support. :D
  • LotsaCaffeine
    LotsaCaffeine Member ✭✭
    edited January 11
    Hi RickO. I appreciate your response. I have been keeping an eye on the ongoing alert link you provided, which appeared to indicate that the problem has been resolved... However, I am unable to view that link anymore. I receive an error on the Quicken website that reads, "Permission problem. You don't have permission to do that".

    Furthermore, as of this reply, I am running the latest version of Quicken for macOS (Version 6.11.3 (Build 611.47347.100)), and the issue is still occurring.

    I would prefer not to delete my entire preference file, if possible. This bug appeared on its own and it should be fixed by whomever caused it... Are there any updates on the resolution of this problem?

    Thank you!
  • RickO
    RickO SuperUser, Mac Beta Beta
    The link still works for me and is marked as resolved as of 12/20/22. One option would for you to contact Quicken Support. It may be necessary (recognizing that it's a pain) to delete your prefs file. Other than that, I don't have any new info.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • LotsaCaffeine
    LotsaCaffeine Member ✭✭
    edited January 12
    That’s so odd. I am still getting the website error when I try to visit the link (see attachment). I’ll give support a try. Thanks again for the help! :)
  • Egon
    Egon Member
    I would like to give a Me Too here. I'm having this issue and what's more. It's fairly annoying to have to recreate the transaction. I have deleted my preferences and it has made no difference for me. The transactions are still out of line.

    I also can't view that link provided above, I get the same "Permission" problem as LotsaCaffeine mentioned above.

    One way this could be solved would be for you to see transactions that our outside of the month? I seem to remember that before it would show you all UNRECONCILED transactions in the reconciliation window.
  • Quicken Anja
    Quicken Anja Moderator mod
    edited January 13 Answer ✓
    Hello All,

    Thank you for taking the time to visit the Community to report this issue, though we apologize that you are experiencing this.

    The link previously provided is inaccessible as that alert in particular has been marked resolved.

    However, since we are still receiving reports for this issue, we have gone ahead and forwarded this to the proper channels to have this reinvestigated. In order to do so, we request that you please navigate to Help > Report a problem within your Quicken program and submit a problem report with log files attached to contribute to the investigation. Please add "Attn: CTP-5524" to the title/subject line. 

    While you will not receive a response through this submission, these reports will help our teams in further investigating the issue. The more problem reports we receive, the better.

    We apologize for any inconvenience in the meantime! Thank you.
    -Quicken Anja