terribly slow

Options

I have been using Quicken for about 25 years and had no problems until the past few months. Now, it is so incredibly slow I'm about ready to give it up and find another product. I have a large file. It is currently 3,000,000kb in size. I ran the year end copy which was supposed to make it smaller and it had only a tiny effect. It recalculates my investment prices and portfolio values after every entry and that can take 4-5 minutes, or even longer sometimes. Support didn't really offer any practical suggestions.

Anybody have any thoughts?

Tagged:

Answers

  • splasher
    splasher SuperUser ✭✭✭✭✭
    Options

    3GB data file?? Do you have a large amount of attachments in your data file? Are you a day trader with a large number of investment transactions?

    -splasher using Q continuously since 1996
    - Subscription Quicken - Win11 and QW2013 - Win11
    -Questions? Check out the Quicken Windows FAQ list

  • UKR
    UKR SuperUser ✭✭✭✭✭
    Options

    For more information about the size of your data file please do this:
    Click Help in the Menu Bar. Shift+click About Quicken and it'll give you a File
    Information box. Please capture an image snapshot of this File Information box
    and attach it here.
    The Windows Snipping Tool can be used to capture a partial screen image and
    save it to a file of file type PNG, JPG, or GIF only.

    To attach the image here please review

  • DaveFry
    DaveFry Member ✭✭
    Options

    I just ran the validate file (you suggested in May by I just saw that) - it took 3 hours. It found several minor problems, lists my securities at 10142 which is max. The program info shows:

    I'll try the super validate if this hasn't helped later today

  • miklk
    miklk SuperUser, Windows Beta Beta
    Options

    Look at the archive account for your main investment account. That will split your account into current holdings and an archive account with past holdings that can still be included in reports etc.. That usually helps if it is investment account related.

  • splasher
    splasher SuperUser ✭✭✭✭✭
    Options

    My statistics show the securities at 150/150, so if I remember correctly, the first number is the current # of different securities referenced in the investment transactions and the max is the highest the count ever was, so if you haven't gone in and deleted all of the transactions for a given security and not removed the security from the picklist, those #s would be the same.

    Follow @miklk 's sugggestion and see if archiving the closed positions helps. The process reduces the current investment account to just the active positions.

    -splasher using Q continuously since 1996
    - Subscription Quicken - Win11 and QW2013 - Win11
    -Questions? Check out the Quicken Windows FAQ list

  • RickO
    RickO SuperUser, Mac Beta Beta
    Options

    I don't know if this is an issue on QWin, but on QMac, slowness is sometimes caused by having multiple windows open that are hiding behind the main window.

    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • UKR
    UKR SuperUser ✭✭✭✭✭
    Options

    (1) What @miklk refers to is this:

    If you're an active trader and/or your current investment account has many transactions pertaining to sold and no longer held securities you may want to consider this:

    Archive Investment Transactions

    For a couple of years now, a new function has been available in Quicken, Archive Transactions. It will split your investment account register into two parts, leaving only those securities' transactions where you currently hold >0 shares in the active register. The rest is moved to a new Archive register within the current data file.

    Having less transactions in your active register might improve performance.

    Please read and carefully follow instructions here: https://www.quicken.com/support/how-archive-investment-transactions

    Eventually, after a couple of years, you might consider splitting your data file in two, with all the archived investment transactions moving to an archive data file and none remaining in the active data file.

    (2) I'm happy to hear that Validate did not find any serious structural file problems.
    After you ran Validate, did your QDF file size change noticeably, as reported by Windows File Explorer?

    (3) Having that many securities on file, your Quotes Price History table may suffer from bloat because every day you add thousands of new price history records.
    If you suspect that a damaged Quotes Price History causes you problems, repeat Validate and select "Correct investing price history" functions "Delete" or "Repair and Rebuild". See comments in the Validate dialog.

    (4) Looking into your Tools / Security List, how many of your security entries are flagged as being on the Watch List?
    Unless you really do use the Watch List as part of a Portfolio View, none of the active securities should have the Watch List flag enabled. This reduces overhead when downloading price quotes every day. Quicken does not download quotes when you do not hold any shares of a security, except when Watch List is also flagged.

    (5) And in case you haven't looked yet … have you noticed the "More info…" link at the bottom of the File Information window?
    Go ahead, take a peek …

  • Katherine Cole
    Katherine Cole Member ✭✭
    Options

    I have used quicken since 1986 - lots of data. it can take between 20 to 60 seconds just to enter a memo, category or tag in any transaction, so i can spend hours just trying to update/correct transactions. this is absurd. and i don't want to segment the file, because i have investment history that goes back that far. this is a nightmare. anyone have another idea/workaround/competitive product i can upload to? and YES, i have validated everything, no errors, the file is fine. and don't tell me my server is slow. this happens in 4 different locations i have been in the in the last 2 weeks.

  • DaveFry
    DaveFry Member ✭✭
    Options

    Thanks to everyone.

    I ran the Validate again to delete the price histories. I see that option prices history has been deleted and transaction prices are still present. It seems to have worked and my file size in Windows is a little smaller

    I archived my main trading account (yes, I'm an active trader daily) and that dropped the size of the file below 3 GB and there is a notable improvement in speed.

    The 'about Quicken' file still shows I'm maxed out in securities - anyone know how to reduce those?

    Thanks again

  • TomUpNorth
    TomUpNorth Member ✭✭
    Options

    Has this made a difference to your System Resources? I dunno what exactly "available" and "total" memory is about but mine are 5126 MB and 16289 MB while yours are amazingly high.

    Thanks to @UKR for the "Shift-About" tip. I wish the "More info…" report had an expandable window or some other way to print or save that report!?!?!?!

  • DaveFry
    DaveFry Member ✭✭
    Options

    I upgraded to 64GB RAM hoping that would help this slowness - it didn't.

  • splasher
    splasher SuperUser ✭✭✭✭✭
    Options

    Doing the investment account archive will not change the file's size by much since all of the transactional information is still in the file.

    See my previous post on the number of securities concept. Reducing the number of securities would mean that you would have to delete some transactional data.

    -splasher using Q continuously since 1996
    - Subscription Quicken - Win11 and QW2013 - Win11
    -Questions? Check out the Quicken Windows FAQ list

  • ebenfi01
    ebenfi01 Member
    Options

    I found out that my VPN service was causing a terrible slowing down of the program. I now turn it off until I'm signed on and I'm done with the program, works like a charm