Exceeded maximum number of datasets

on initial install of Quicken 2017 (upgrading from Quicken 13) i get the message that i have exceeded the maximum number of datasets and can't proceed. I suppose this is because my Quicken history goes back 20 years or more and there's a lot of data there.
What to do to "trim" these datasets??

Best Answer


  • splasher
    splasher SuperUser ✭✭✭✭✭
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • I am not syncing mobile and/or web - I am not syncing anything and never have. I do not even own a mobile device. So what now??
  • Greg_the_Geek
    Greg_the_Geek SuperUser, Windows Beta ✭✭✭✭✭
    Quicken Customer Support is the only one that can fix the problem.
    Quicken Subscription HBRP - Windows 10
  • UKR
    UKR SuperUser ✭✭✭✭✭
    edited November 2019
    If it's not the (in)famous issue with Web Sync ...
    there does appear to be a limit on the number actual data files when Quicken tries to pull up a list of files in File / Find Files or Open Quicken File
    How many Quicken data files plus backups plus possibly other junk do you have in the folder that contains your active Quicken data file?
    What is the full path and name of your Quicken data file,
    e.g., C:\Users\_your_username_\Documents\Quicken\QDATA.QDF

  • Here's the content of my folder where I keep Quicken data files. I call it 2017 Quicken Backup. There are 4 files.
    2017 Quicken backup/qdata983_20170222_20170222_20170223_20180313_20180519_20191103_SyncLog.dat
    2017 Quicken backup/Qdata983_20170222_20170222_20170223_20180313_20180519_20191103.QDF
    2017 Quicken backup/Qdata983_20170222_20170222_20170223_20180313_20180519_20191103-2019-11-06.QDF-backup
    2017 Quicken backup/Qdata983_20170222_20170222_20170223_20180313_20180519_20191103-2019-11-06-2019-11-07.QDF-backup
    2017 Quicken backup/Qdata983_20170222_20170222_20170223_20180313_20180519_20191103-2019-11-07.QDF-backup
    2017 Quicken backup/Qdata983_20170222_20170222_20170223_20180313_20180519_20191103OFXLOG.DAT

    The top one is a synclog - why it is there, i don't know.
    The second one down is the current data file - the other 3 are backups.

    I have thoroughly cleaned all other Quicken files off this computer. When I do a Files>File Operations>Find Quicken Files I only get 4 files - I think the Sync one does not appear in the list.

    You can see the name of my data file above - the second one down.
  • UKR
    UKR SuperUser ✭✭✭✭✭
    With Quicken closed, I would shorten the data file name from the current monstrosity that it is to just simply qdata983.QDF (leaving the backup names alone)
    You appear to have restored backups 6 times in the past, without removing the added datestamp from the filename, hence the long name over time.
    IIRC, there still are some length restrictions built into Quicken, when it comes to naming data files and path names. Exceed one and Poof!
    By the way, the recommended location for your active Quicken data file is within the  \Documents\Quicken folder on your C:-drive
    This results in Automatic Backups created by Quicken being stored in \Documents\Quicken\Backup
    Manual Backups created by Quicken can be stored anywhere, preferably on an external USB harddrive, memory stick or a cloud backup solution and should not be on your internal harddrive.
  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    I strongly encourage you to reduce the length of the name of your data file and move the file up one level so that it is out of the Backup folder.  As you only have one data file, I suggest QData.QDF.  Note: You may also remove the .DAT files from the backup folder.
    1) I reduced the data file name to qdata983.QDF
    2) I moved the active Qdata file to \Documents\Quicken.
    3) I moved the 2017 Quicken Backup folder to a memory stick.

    So now the only storage i have is in the \Documents\Quicken folder and these are the only files in there:
    /mnt/F488635288631282/Documents and Settings/Wes/Desktop/New folder/BACKUP
    /mnt/F488635288631282/Documents and Settings/Wes/Desktop/New folder/qdata983_SyncLog.dat
    /mnt/F488635288631282/Documents and Settings/Wes/Desktop/New folder/Qdata983.QDF
    /mnt/F488635288631282/Documents and Settings/Wes/Desktop/New folder/Qdata983OFXLOG.DAT

    HOWEVER I'm still getting the "exceeded Maximum Number" warning.

    Any further suggestions??

    I'm constantly being told to go to Quicken Support, but I don't know how to get through to those folks, and what could they say that you can't?
    Should I go to them, and how would I SUCCESSFULLY do that??
  • splasher
    splasher SuperUser ✭✭✭✭✭
    It is not what we, fellow users, can say, support is the only group that can fix this issue for you.
    Quicken Support 
    -splasher  using Q since 1996 -  Subscription  -  Win10
    -also older versions as needed for testing
    -Questions? Check out the  Quicken Windows FAQ list
  • UKR
    UKR SuperUser ✭✭✭✭✭
    When I was talking about "the recommended location for your active Quicken data file is within the  \Documents\Quicken folder on your C:-drive" I did not say anything about moving your active Quicken data file to a networked external drive, because that, even though it may work (for a while until it breaks), is not supported. Your active Quicken data file should be in
    The long path to the networked drive might still be what's causing your "max. datasets" problem ... I'm guessing, because there's a length restriction on both path and file name and I can't find the exact specs on how long a name can be. It's much shorter than what Windows allows.

  • When I click on the button "Talk to Support" nothing happens. That's why I asked how to contact support.
    So, how do I contact Support??
  • Sorry!! - My active Quicken data file IS in this location:
    I do my emailing from my Ubuntu drive and the files picked up some extra nomenclature on the transfer over to that drive and i just copied them from a temporary folder I had put on that desktop without noticing they had picked up the extraneous/wrong info.
    So that file IS where you said to put it - on the C;\ drive.
    And I'm still getting the warning.
  • thecreator
    thecreator SuperUser ✭✭✭✭✭
    thecreator - User of Quicken Subscription R42.21  USA & Quicken 2017 HBRP R20.6 USA
                       Windows 10 Pro 32-Bit Build 19044.1826                   
                       Windows 10 Pro 64-Bit Build 19045.1865 Release Preview Channel. Lost Win 11.
                      also  Windows 10 Pro 64-Bit Build 19044.1826 .
    View: https://community.quicken.com/discussion/7859218/work-with-copies-of-your-actual-quicken-data-files/p1?new=1

This discussion has been closed.