Quicken Community is moving to Single Sign On! Starting 1/22/21, you'll sign in to the community with your Quicken ID. For more information: http://bit.ly/CommunitySSO

Unable to Delete Securities

Chris5
Chris5 Member ✭✭
edited October 2018 in Investing (Mac)
I can't delete securities that have no transactions associated with them. I get an error message when trying that says "These securities can't be deleted...These securities are used by active transactions and cannot be removed." I've used every possible method of searching for transactions that reference the security to be deleted but none to be found in any register, list, report, portfolio view, etc.


Note: This conversation was created from a reply on: Can't delete securities.

Comments

  • Sherlock
    Sherlock SuperUser ✭✭✭✭✭
    edited October 2018
    If you really used every possible method of searching for transactions that reference the security, then the datafile is corrupt: https://www.quicken.com/support/advanced-data-file-troubleshooting-correct-problems-quicken-windows

    I suspect the security is referenced in a hidden transaction list or placeholder you have yet to identify.  
  • Chris5
    Chris5 Member ✭✭
    edited August 2018
    Thanks for the suggestion Sherlock. Appears I have this posted in the wrong spot since I'm using QM18. I checked the link but there is no "file operations" menu on the Mac version. 

    I do suspect that you are correct though that there must be some stray references in the datafile
  • Concordman
    Concordman Mac Beta Beta
    edited March 2018
    Chris said:

    Thanks for the suggestion Sherlock. Appears I have this posted in the wrong spot since I'm using QM18. I checked the link but there is no "file operations" menu on the Mac version. 

    I do suspect that you are correct though that there must be some stray references in the datafile

    In Qm18 securities cannot be deleted. There needs to be the option to hide unused securities when searching thru the security listing.
  • Chris5
    Chris5 Member ✭✭
    edited March 2018
    Chris said:

    Thanks for the suggestion Sherlock. Appears I have this posted in the wrong spot since I'm using QM18. I checked the link but there is no "file operations" menu on the Mac version. 

    I do suspect that you are correct though that there must be some stray references in the datafile

    Are you saying inability to delete a security is a QM18 limitation, regardless of if there is a transaction or not? And the message is not accurate regarding "active transactions"? Odd that there would be the menu option to select "Delete" if this is the case. But at least that would be encouraging that it will be enabled at some point in an update rather than an issue with my datafile...
  • Concordman
    Concordman Mac Beta Beta
    edited March 2018
    Chris said:

    Thanks for the suggestion Sherlock. Appears I have this posted in the wrong spot since I'm using QM18. I checked the link but there is no "file operations" menu on the Mac version. 

    I do suspect that you are correct though that there must be some stray references in the datafile

    dont see it as a limitation but Quicken should allow for hiding unused securities
  • smayer97
    smayer97 SuperUser, Mac Beta, Canada Beta ✭✭✭✭✭
    edited March 2018
    Chris said:

    Thanks for the suggestion Sherlock. Appears I have this posted in the wrong spot since I'm using QM18. I checked the link but there is no "file operations" menu on the Mac version. 

    I do suspect that you are correct though that there must be some stray references in the datafile

    To me, it must be an oversight that you can add a security but not remove it if it never gets used.
    Have Questions? Check out these FAQs (links now fixed):COMPLETE list of Product Ideas - Quicken for Mac to VOTE on

    Object to Quicken's business model, using up 25% of your screen?
    Add your vote here:
    Quicken should eliminate the LARGE Ad space when a subscription expires

    (
    Canadian user since '92, STILL using QM2007)


  • RickO
    RickO SuperUser, Mac Beta Beta
    edited March 2018
    Chris said:

    Thanks for the suggestion Sherlock. Appears I have this posted in the wrong spot since I'm using QM18. I checked the link but there is no "file operations" menu on the Mac version. 

    I do suspect that you are correct though that there must be some stray references in the datafile

    Some of this discussion is not correct: if there are no transactions associated with a security, then you can delete it.

    Chris, my guess is that you may have a hidden account that has transactions for the security, even though the net of those transactions is zero shares. Have you check for hidden accounts (menu Accounts > Hide and Show Accounts)?

    After unhiding all accounts, use the search box in the All Transactions register to search for the security name (not symbol). Make sure there are no Date, Account or Status filters set.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • Chris5
    Chris5 Member ✭✭
    edited March 2018
    Chris said:

    Thanks for the suggestion Sherlock. Appears I have this posted in the wrong spot since I'm using QM18. I checked the link but there is no "file operations" menu on the Mac version. 

    I do suspect that you are correct though that there must be some stray references in the datafile

    There are no hidden accounts and many steps taken to ensure no individual transactions are using the security. I've even done exports to search the datafile using Text Wrangler. No use of the security.

    So it is either that somewhere in the datafile there is some old reference that is not part of any account/register (but I've even changed the security name several times) or it is a problem specific to the delete function
  • RickO
    RickO SuperUser, Mac Beta Beta
    edited March 2018
    Chris said:

    Thanks for the suggestion Sherlock. Appears I have this posted in the wrong spot since I'm using QM18. I checked the link but there is no "file operations" menu on the Mac version. 

    I do suspect that you are correct though that there must be some stray references in the datafile

    In that case, I would guess that you are right, that there's still some reference to the security that's somehow got orphaned. 

    If you are brave, you could open the data file within the Quicken file package with a generic SQL editor and find and delete the security's record. But I have no idea if that might cause other issue or break the database.

    If it's just one extraneous security, I'd just forget about it.

    BTW, if you want to test... create a Buy transaction of some security that you don't currently own. Then delete that transaction. Then go into the security list and delete the security. You will see that it works.
    Quicken Mac Subscription; Quicken Mac user since the early 90s
  • Concordman
    Concordman Mac Beta Beta
    edited March 2018
    Chris said:

    Thanks for the suggestion Sherlock. Appears I have this posted in the wrong spot since I'm using QM18. I checked the link but there is no "file operations" menu on the Mac version. 

    I do suspect that you are correct though that there must be some stray references in the datafile

    Which is why It would be good to hide securities which have been used in the past but are no longer needed to review in the security list
  • Unknown
    Unknown Member
    edited March 2018
    Chris said:

    Thanks for the suggestion Sherlock. Appears I have this posted in the wrong spot since I'm using QM18. I checked the link but there is no "file operations" menu on the Mac version. 

    I do suspect that you are correct though that there must be some stray references in the datafile

    May I add...try buying the security in question that you want to delete.

    I would make it 1000 shares at $10 each.

    Then see in the Portfolio window if there are any small fractional shares of the security in addition to the 1000 shares.

    Quicken Mac has difficulty in seeing shares to the fifth decimal place or more sometimes.  If you have 0.00001 shares, Quicken Mac will show it as zero shares.  
  • Chris5
    Chris5 Member ✭✭
    edited March 2018
    Chris said:

    Thanks for the suggestion Sherlock. Appears I have this posted in the wrong spot since I'm using QM18. I checked the link but there is no "file operations" menu on the Mac version. 

    I do suspect that you are correct though that there must be some stray references in the datafile

    Thanks for the additional troubleshooting ideas. I did try adding new transactions with the security (actually several to check different registers) and checking the # of shares (I always keep the Shares column visible)--no fractional shares (at least down to 3 decimal places).

    I guess I'm a bit OCD and it's actually 6 different securities so hiding them doesn't appeal to me. It's more that I know something somewhere isn't right with my datafile that bugs me.
  • Unknown
    Unknown Member
    edited March 2018
    Chris said:

    Thanks for the suggestion Sherlock. Appears I have this posted in the wrong spot since I'm using QM18. I checked the link but there is no "file operations" menu on the Mac version. 

    I do suspect that you are correct though that there must be some stray references in the datafile

    Okay, try adding 0.001 share of the security and see what happens.  Quicken may show more decimal places of shares than three if it's a small fractional amount.

    Of course, I'm just taking a stab at things to see if they help.  

    Like you, my OCD would drive me crazy over something as trivial as that.  
  • Chris5
    Chris5 Member ✭✭
    edited March 2018
    Chris said:

    Thanks for the suggestion Sherlock. Appears I have this posted in the wrong spot since I'm using QM18. I checked the link but there is no "file operations" menu on the Mac version. 

    I do suspect that you are correct though that there must be some stray references in the datafile

    Now things have gone past being a nuisance... the suggestions to hide were more than OCD since when downloading transactions from my brokerage account, any new transactions are downloaded under the old security name. So I have to manually change each one to the real security.

    But now over the past week, whenever I sync with my account it is adding the old security as the first transaction in the register (2004) with the same share balance as currently in the account. Quicken is doing this as a manual adjustment to match with the online account share balance. So somehow, QM17 has the old security locked to the brokerage security even though I've changed the symbol to nonsense along with the name. And QM17 is ignoring the right security with the real symbol...

    I just disabled the online setup for the account and re-established it to see if that would help. No dice. Old security is still added as the first in the register when synced.
  • Quicken_Tyka
    Quicken_Tyka Moderator mod
    edited March 2018
    Chris said:

    Thanks for the suggestion Sherlock. Appears I have this posted in the wrong spot since I'm using QM18. I checked the link but there is no "file operations" menu on the Mac version. 

    I do suspect that you are correct though that there must be some stray references in the datafile

    Hey Chris,

    I would try merging the old security with the new security.

    You can find detailed steps at https://www.quicken.com/support/merge-securities-quicken-mac.

    Let me know how it goes!
    ~~~***~~~
  • Chris5
    Chris5 Member ✭✭
    edited April 2018
    Chris said:

    Thanks for the suggestion Sherlock. Appears I have this posted in the wrong spot since I'm using QM18. I checked the link but there is no "file operations" menu on the Mac version. 

    I do suspect that you are correct though that there must be some stray references in the datafile

    Thanks for the tip Tyka. I was able to successfully merge three of the securities I was trying to delete. So far doesn't look to have any unexpected consequences... Jury is still out until I have new transactions from my brokerage to ensure they are linked correctly. I'll report back
This discussion has been closed.